Scanner Event Registration Error

R

Rich Bell

I am trying to set the default programs for my Epson V200 scanner buttons
using the Scanners and Cameras Control panel applet. When I choose the
program and click OK I get the following error message:

Event registration failed: The attempt to change the registered event
handler failed. Please make sure the device is turned on and connected
properly.

When I press any of the buttons it brings up a dialog that allows me to
choose a program. The scanner functions normally once the application is
running.

Any ideas why it won't let me change the registered event handlers?
 

My Computer

R

Rich Bell

This turned out to be permissions issue. I had to take ownership of the
applicable Registry keys as an Administrator. I was then able to set the
button assignments as an Administrator.

I got an email response from Epson regarding this problem and their only
suggestion was to reinstall the driver, which I had already done.

"Rich Bell" <[email protected]> wrote in message
news:[email protected]

>I am trying to set the default programs for my Epson V200 scanner buttons
>using the Scanners and Cameras Control panel applet. When I choose the
>program and click OK I get the following error message:
>
> Event registration failed: The attempt to change the registered event
> handler failed. Please make sure the device is turned on and connected
> properly.
>
> When I press any of the buttons it brings up a dialog that allows me to
> choose a program. The scanner functions normally once the application is
> running.
>
> Any ideas why it won't let me change the registered event handlers?
 

My Computer

itmaster

New Member
This turned out to be permissions issue. I had to take ownership of the
applicable Registry keys as an Administrator. I was then able to set the
button assignments as an Administrator.

I got an email response from Epson regarding this problem and their only
suggestion was to reinstall the driver, which I had already done.

"Rich Bell" <[email protected]> wrote in message
news:[email protected]

Hi, I'm also having this problem as well. Do you mind please telling me how you changed the registry ownership? I went into regedit and the keys I found under HKEY_Current_User\Software\Canon\MP Navigator and the subdirectories are alll under my ownership already, yet I still had the error. FYI, my printer is connected to comp and is on, and i have the latest drivers from Canon.

Thanks in advance.
 

My Computer

Top