• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Sharing and Discovery services lost

  • Thread starter Frederick Pouy \(Fred\)
  • Start date
F

Frederick Pouy \(Fred\)

#1
I have this odd situation in Network and Sharing ... and am completely
stumped at this point.

The 'Sharing and Discovery' section listings in 'Network and Sharing Center'
are now all selected Off (not by me) and any attempt to turn on any of them
(e.go. 'Network Discovery') gives me a message stating "The specified
service does not exist as an installed service". Moreover, Windows Firewall
is now also unavailable and gives me a message stating "Due to an
unidentified problem, Windows cannot display Windows Firewall settings."

I'm running 2 desktops (one XP & one Vista Ultimate) both wired directly to
the D-Link DIR-625 router, two XP wireless XP laptops and one wireless
Macintosh laptop. I'm now running Network Magic and all computers connect
flawlessly to the internet and see each other through the software .. I'm
also using it to share my HP Office Jet printer on the network w/no problem.

I thought it might be the Network Magic that was causing the situation, but
I have a clean copy of Vista that had no Sharing & Discovery problem, so I
installed Network Magic on it and Sharing and Discovery work fine.

I suspect the solution is a simple one and the problem probably User
inflicted, but any suggestions gratefully accepted as I've spent way too
much time on this.
--
TIA, Fred
 

My Computer

SSV

New Member
#2
I have this odd situation in Network and Sharing ... and am completely
stumped at this point.

The 'Sharing and Discovery' section listings in 'Network and Sharing Center'
are now all selected Off (not by me) and any attempt to turn on any of them
(e.go. 'Network Discovery') gives me a message stating "The specified
service does not exist as an installed service". Moreover, Windows Firewall
is now also unavailable and gives me a message stating "Due to an
unidentified problem, Windows cannot display Windows Firewall settings."

I'm running 2 desktops (one XP & one Vista Ultimate) both wired directly to
the D-Link DIR-625 router, two XP wireless XP laptops and one wireless
Macintosh laptop. I'm now running Network Magic and all computers connect
flawlessly to the internet and see each other through the software .. I'm
also using it to share my HP Office Jet printer on the network w/no problem.

I thought it might be the Network Magic that was causing the situation, but
I have a clean copy of Vista that had no Sharing & Discovery problem, so I
installed Network Magic on it and Sharing and Discovery work fine.

I suspect the solution is a simple one and the problem probably User
inflicted, but any suggestions gratefully accepted as I've spent way too
much time on this.
--
TIA, Fred
This is due to the Windows Firewall service being removed, usually user-inflicted, but viruses, i suspect, can do the same.

I, of all should know this, considering that I deleted it too and got the same problem here.

Here is how i deleted it:
-Open CMD
-type "sc delete <the windows firewall service name as it appeared in the Task Manger> (which i no longer remember and no longer exists in any service list)

CAN SOMEONE HELP ME, please. Thanks in advance.
 

My Computer