• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

slmgr.vbs -ckms gives Unrecognized Option Error

#1
OK, so i'm trying to get our Vista VL machines and KMS server up and running.
I have not reached the 25min KMS req so last week i activated a couple of
our Vista VL machines against a KMS server in another domain, that worked
fine. Since then the machine has been sysprepped and now i want to point to
our local KMS and this is what i get:
slmgr.vbs -dlv gives all info EXCEPT it DOES NOT list the current KMS server
named
slmgr.vbs -ckms gives unrecognized error message
slmgr.vbs -skms <our server> gives "The RPC server is unavailable"

Any thoughts or suggestions on what the heck is going on here? Why can't i
clear the old KMS with the CKMS command? What doesn't the -dlv command name
the current KMS server anymore in the license detail info? What's the dilio
with the RPC errror?
Thanks
 

My Computer

#2
Update: I'm starting to think my Vista box i'm having problems with is
thinking is a KMS host. Anyone know a way to remove/demote a kms host and
turn it back into a KMS client?


"sc" wrote:

> OK, so i'm trying to get our Vista VL machines and KMS server up and running.
> I have not reached the 25min KMS req so last week i activated a couple of
> our Vista VL machines against a KMS server in another domain, that worked
> fine. Since then the machine has been sysprepped and now i want to point to
> our local KMS and this is what i get:
> slmgr.vbs -dlv gives all info EXCEPT it DOES NOT list the current KMS server
> named
> slmgr.vbs -ckms gives unrecognized error message
> slmgr.vbs -skms <our server> gives "The RPC server is unavailable"
>
> Any thoughts or suggestions on what the heck is going on here? Why can't i
> clear the old KMS with the CKMS command? What doesn't the -dlv command name
> the current KMS server anymore in the license detail info? What's the dilio
> with the RPC errror?
> Thanks
 

My Computer

D

Darrell Gorter[MSFT]

#3
Hello,
What was the output for -DLI?
You can see those errors when the media is not Volume Media
Thanks,
Darrell Gorter[MSFT]

This posting is provided "AS IS" with no warranties, and confers no rights
--------------------
|>Thread-Topic: slmgr.vbs -ckms gives Unrecognized Option Error
|>thread-index: AcdwxttxpXkg8LEXT++2N2jDpLedIw==
|>X-WBNR-Posting-Host: 207.46.198.15
|>From: =?Utf-8?B?c2M=?= <sc@discussions.microsoft.com>
|>Subject: slmgr.vbs -ckms gives Unrecognized Option Error
|>Date: Tue, 27 Mar 2007 16:22:59 -0700
|>Lines: 15
|>Message-ID: <1D384FB6-5418-448D-A29F-587B68891923@microsoft.com>
|>MIME-Version: 1.0
|>Content-Type: text/plain;
|> charset="Utf-8"
|>Content-Transfer-Encoding: 7bit
|>X-Newsreader: Microsoft CDO for Windows 2000
|>Content-Class: urn:content-classes:message
|>Importance: normal
|>Priority: normal
|>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2757
|>Newsgroups: microsoft.public.windows.vista.installation_setup
|>Path: TK2MSFTNGHUB02.phx.gbl
|>Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.windows.vista.installation_setup:13672
|>NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
|>X-Tomcat-NG: microsoft.public.windows.vista.installation_setup
|>
|>OK, so i'm trying to get our Vista VL machines and KMS server up and
running.
|> I have not reached the 25min KMS req so last week i activated a couple
of
|>our Vista VL machines against a KMS server in another domain, that worked
|>fine. Since then the machine has been sysprepped and now i want to point
to
|>our local KMS and this is what i get:
|>slmgr.vbs -dlv gives all info EXCEPT it DOES NOT list the current KMS
server
|>named
|>slmgr.vbs -ckms gives unrecognized error message
|>slmgr.vbs -skms <our server> gives "The RPC server is unavailable"
|>
|>Any thoughts or suggestions on what the heck is going on here? Why can't
i
|>clear the old KMS with the CKMS command? What doesn't the -dlv command
name
|>the current KMS server anymore in the license detail info? What's the
dilio
|>with the RPC errror?
|>Thanks
|>
 

My Computer

#4
Hi Darrell, thanks for the reply. I found my problem. I had used the VL
media but my coworker had syspreped the machine using the KMS VL in the xml
file. We changed that to the Product Key that came prepackaged in the VL and
now things are back to the way i would expect them to be. Now i just have to
figure out a way to maintain the damn 25 Client count on my KMS server....
what a pain.
thanks for your input.

""Darrell Gorter[MSFT]"" wrote:

> Hello,
> What was the output for -DLI?
> You can see those errors when the media is not Volume Media
> Thanks,
> Darrell Gorter[MSFT]
>
> This posting is provided "AS IS" with no warranties, and confers no rights
> --------------------
> |>Thread-Topic: slmgr.vbs -ckms gives Unrecognized Option Error
> |>thread-index: AcdwxttxpXkg8LEXT++2N2jDpLedIw==
> |>X-WBNR-Posting-Host: 207.46.198.15
> |>From: =?Utf-8?B?c2M=?= <sc@discussions.microsoft.com>
> |>Subject: slmgr.vbs -ckms gives Unrecognized Option Error
> |>Date: Tue, 27 Mar 2007 16:22:59 -0700
> |>Lines: 15
> |>Message-ID: <1D384FB6-5418-448D-A29F-587B68891923@microsoft.com>
> |>MIME-Version: 1.0
> |>Content-Type: text/plain;
> |> charset="Utf-8"
> |>Content-Transfer-Encoding: 7bit
> |>X-Newsreader: Microsoft CDO for Windows 2000
> |>Content-Class: urn:content-classes:message
> |>Importance: normal
> |>Priority: normal
> |>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2757
> |>Newsgroups: microsoft.public.windows.vista.installation_setup
> |>Path: TK2MSFTNGHUB02.phx.gbl
> |>Xref: TK2MSFTNGHUB02.phx.gbl
> microsoft.public.windows.vista.installation_setup:13672
> |>NNTP-Posting-Host: tk2msftsbfm01.phx.gbl 10.40.244.148
> |>X-Tomcat-NG: microsoft.public.windows.vista.installation_setup
> |>
> |>OK, so i'm trying to get our Vista VL machines and KMS server up and
> running.
> |> I have not reached the 25min KMS req so last week i activated a couple
> of
> |>our Vista VL machines against a KMS server in another domain, that worked
> |>fine. Since then the machine has been sysprepped and now i want to point
> to
> |>our local KMS and this is what i get:
> |>slmgr.vbs -dlv gives all info EXCEPT it DOES NOT list the current KMS
> server
> |>named
> |>slmgr.vbs -ckms gives unrecognized error message
> |>slmgr.vbs -skms <our server> gives "The RPC server is unavailable"
> |>
> |>Any thoughts or suggestions on what the heck is going on here? Why can't
> i
> |>clear the old KMS with the CKMS command? What doesn't the -dlv command
> name
> |>the current KMS server anymore in the license detail info? What's the
> dilio
> |>with the RPC errror?
> |>Thanks
> |>
>
>
 

My Computer

Greg

New Member
Messages
2
#5
Hi,

I registered for the sole purpose of thinking Darrell for his suggestion. :-)

We had some issues early on with the Vista CDs our supplier supplied. Turns out we received non-Volume License CDs when we should have had Volume License CDs.

I had completely forgotten about this trouble until Darrell suggested that the particular error in question could be tied to non-VL media. That's exactly what's going on with one of our machines It will not accept the server as a viable KMS server. Now we know it's because it was hand-loaded with a single user copy of Vista.

We'll have to Wash-n-Wax the machine to fix the problem, but that's OK...we'll just do it next time it comes in for service.

Thanks much, Darrell!
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)