• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

SmtpClient.UseDefaultCredentials does not work in Authenticated SM

#1
I use SmtpClient to send email in my program, and I set the
UserDefaultCredentials to true to use the logged on user's credentials.
However it doesn't work on authenticated SMTP server. It will throws
exception saying 'System.Net.Mail.SmtpException: The SMTP server requires a
secure connection or the client was not authenticated. The server response
was: 5.7.3 Client was not authenticated'

However if I set UserDefaultCredentials to false and hard-coded my login and
password for SmtpClient.Credentials, it works. It seems as if the
UseDefaultCredentials does not set loggon user's credentials correctly.

Any help would really appreciated.

Vik
 

My Computer

H

Henning Krause [MVP - Exchange]

#2
Hello,

what SMTP server are you using?

If you use the credential of the currently logged on user, the mail server
must support NTLM authentication. If it just supports the LOGIN method, it
won't work.
To check if the server supports this, open a command prompt and type
telnet servername 25

this will open a connection to the smtp server. Then type
ehlo

This will send an extended helo request to the server. The server will now
list all supported commands. If you find a line stating
250-AUTH NTLM

the server has NTLM authentication enabled. If not - you can't use the
default credentials.

Kind regards,
Henning Krause

"vik" <vik@xxxxxx> wrote in message
news:F3A795E9-F783-4060-8452-0F09CB769D89@xxxxxx

>I use SmtpClient to send email in my program, and I set the
> UserDefaultCredentials to true to use the logged on user's credentials.
> However it doesn't work on authenticated SMTP server. It will throws
> exception saying 'System.Net.Mail.SmtpException: The SMTP server requires
> a
> secure connection or the client was not authenticated. The server response
> was: 5.7.3 Client was not authenticated'
>
> However if I set UserDefaultCredentials to false and hard-coded my login
> and
> password for SmtpClient.Credentials, it works. It seems as if the
> UseDefaultCredentials does not set loggon user's credentials correctly.
>
> Any help would really appreciated.
>
> Vik
 

My Computer

#3
Re: SmtpClient.UseDefaultCredentials does not work in Authenticate

Hi Henning,

Thank you very much for your reply to my question. You are right; it was the
SMTP server not supporting NTLM issue, and after we have SMTP server's
settings changed to support NTLM, the email client was able to send email
sucessfully.

Again, I really appreciate your help.

Best Regards,
Vik

"Henning Krause [MVP - Exchange]" wrote:

> Hello,
>
> what SMTP server are you using?
>
> If you use the credential of the currently logged on user, the mail server
> must support NTLM authentication. If it just supports the LOGIN method, it
> won't work.
> To check if the server supports this, open a command prompt and type
> telnet servername 25
>
> this will open a connection to the smtp server. Then type
> ehlo
>
> This will send an extended helo request to the server. The server will now
> list all supported commands. If you find a line stating
> 250-AUTH NTLM
>
> the server has NTLM authentication enabled. If not - you can't use the
> default credentials.
>
> Kind regards,
> Henning Krause
>
> "vik" <vik@xxxxxx> wrote in message
> news:F3A795E9-F783-4060-8452-0F09CB769D89@xxxxxx

> >I use SmtpClient to send email in my program, and I set the
> > UserDefaultCredentials to true to use the logged on user's credentials.
> > However it doesn't work on authenticated SMTP server. It will throws
> > exception saying 'System.Net.Mail.SmtpException: The SMTP server requires
> > a
> > secure connection or the client was not authenticated. The server response
> > was: 5.7.3 Client was not authenticated'
> >
> > However if I set UserDefaultCredentials to false and hard-coded my login
> > and
> > password for SmtpClient.Credentials, it works. It seems as if the
> > UseDefaultCredentials does not set loggon user's credentials correctly.
> >
> > Any help would really appreciated.
> >
> > Vik
>
>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)