• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Start up time is very slow

C

Chad Z. Hower

#1
Pentium D 960, dual core, 3.6 GHz+, RAID 0 striped high speed SATA
drives.

Its rare that something runs slow on this machine. But WCF initiation
takes 18 seconds. I can reboot XP quicker than that, in fact more than
once.

At first I thought it was an endpoint, which really worried me. I have
a need for multiple endpoints on a single machine (simulation). So I
added a second one - and to my delight the second one didnt take 18
seconds, it popped up right after the first.

Does anyone have any idea what takes 18 seconds and if I can speed it
up? Its really making debugging a chore. I dont have any code in my
init, its a simple console app derived from the standard WCF host
template.

The shell looks like this (Nothing useful to see, but to illustrate
what I mean better).

static void Start(string aURI) {
Console.WriteLine("Starting: " + aURI);
new AgentServiceHost(aURI);
Console.WriteLine(" OK");
}

static void Main(string[] args) {
Start("http://localhost:8080/x");
Start("http://localhost:8080/y");
Console.WriteLine("");
Console.WriteLine("All started");
Console.ReadLine();
}

So right away I see:
Starting http://localhost:8080/x

Then 18 seconds delay, then immediately all at once:
Ok
Starting http://localhost:8080/y
Ok

All started




--
"Programming is an art form that fights back"
http://www.KudzuWorld.com/
Need a professoinal technical speaker at your event? See www.woo-hoo.net
 

My Computer

C

Chad Z. Hower

#2
Chad Z. Hower wrote:
> So right away I see:
> Starting http://localhost:8080/x
>
> Then 18 seconds delay, then immediately all at once:
> Ok
> Starting http://localhost:8080/y
> Ok
>
> All started


Now that I have each one running in its own AppDomain, its 18 seconds
for each one. :( Start up time during debugging is horrible.


--
"Programming is an art form that fights back"
http://www.KudzuWorld.com/
Need a professoinal technical speaker at your event? See www.woo-hoo.net
 

My Computer

C

Chad Z. Hower

#3
Chad Z. Hower wrote:
> Now that I have each one running in its own AppDomain, its 18 seconds
> for each one. :( Start up time during debugging is horrible.


Actually its not 18 seconds each one, but more like 20 for first, 10
for second and so on.

I put them in a threadpool so that they would all start simulteaneously
and hopefully thus when I started 10 or so, it would take 20 seconds
and not 110. But even threadpool + app domains does not help. It still
takes just as long. :(



--
"Programming is an art form that fights back"
http://www.KudzuWorld.com/
Need a professoinal technical speaker at your event? See www.woo-hoo.net
 

My Computer

C

Chad Z. Hower

#4

My Computer

C

Chad Z. Hower

#5
Chad Z. Hower wrote:
> WCF server startup slow on W2K3 in VM
> http://blogs.thinktecture.com/ingo/archive/2006/09/04/414684.aspx
>
> I'm on XP and not even part of a domain, but maybe?


Bugger all. :( Thats what it is. This machine has two ethernet + wifi +
several virtual adaptors. WCF is only using one, but that is exactly
what is taking so long.

Anyone have any work arounds? I'm on XP Pro, cant make it a domain
controller and I really cant drop it from the network either.

--
"Programming is an art form that fights back"
http://www.KudzuWorld.com/
Need a professoinal technical speaker at your event? See www.woo-hoo.net
 

My Computer

A

Arkady Frenkel

#6
Didn't you tried to disable adapters before ?
Arkady

"Chad Z. Hower" <chad-ng@hower.org> wrote in message
news:eqJNBD74GHA.512@TK2MSFTNGP06.phx.gbl...
> Chad Z. Hower wrote:
>> WCF server startup slow on W2K3 in VM
>> http://blogs.thinktecture.com/ingo/archive/2006/09/04/414684.aspx
>>
>> I'm on XP and not even part of a domain, but maybe?

>
> Bugger all. :( Thats what it is. This machine has two ethernet + wifi +
> several virtual adaptors. WCF is only using one, but that is exactly
> what is taking so long.
>
> Anyone have any work arounds? I'm on XP Pro, cant make it a domain
> controller and I really cant drop it from the network either.
>
> --
> "Programming is an art form that fights back"
> http://www.KudzuWorld.com/
> Need a professoinal technical speaker at your event? See www.woo-hoo.net
 

My Computer

C

Chad Z. Hower

#7
Arkady Frenkel wrote:
> Didn't you tried to disable adapters before ?


I cant - I need this machine to be on the internet. Besides I did a TCP
spy and its only using one adaptor, the main one.

--
"Programming is an art form that fights back"
http://www.KudzuWorld.com/
Need a professional technical speaker at your event? See www.woo-hoo.net
 

My Computer

A

Arkady Frenkel

#8
Hi, Chad!
"Chad Z. Hower" <chad-ng@hower.org> wrote in message
news:uohq6d45GHA.4116@TK2MSFTNGP03.phx.gbl...
> Arkady Frenkel wrote:
>> Didn't you tried to disable adapters before ?

>


That proposition for tests only.
> I cant - I need this machine to be on the internet. Besides I did a TCP
> spy and its only using one adaptor, the main one.
>

Sure, only one used due to route table ( IP of route with less metric - you
can check which with "route print" command in dos box routing ). For me it
always take few seconds ( up to 3-5 ) but not 18 ( but I'm in domain ) both
on IIS or as selfhost. Did you tried to add to domain ( temporarily ) to see
the difference ?
Arkady

> --
> "Programming is an art form that fights back"
> http://www.KudzuWorld.com/
> Need a professional technical speaker at your event? See www.woo-hoo.net
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)