• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Superfetch Service Won't Start

S

Steve Foxon

#1
Hi,

Don't know if anyone can help, but I noticed today that the Superfetch
service will not start. I get "Error 197: The operating System is not
presently configured to run this application".

Any ideas? I have Vista Business and it was upgraded from XP PRo (yes not a
brilliatn idea, but I am testing whether it is a possible course of action
for all users).

Cheers.
 
R

Ronnie Vernon MVP

#2
Steve

Have you activated this copy of Vista yet?

--

Ronnie Vernon
Microsoft MVP
Windows Shell/User


"Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote in message
news:62EB6DB5-6A6E-40EC-A5A7-8418D4030BFC@microsoft.com...
> Hi,
>
> Don't know if anyone can help, but I noticed today that the Superfetch
> service will not start. I get "Error 197: The operating System is not
> presently configured to run this application".
>
> Any ideas? I have Vista Business and it was upgraded from XP PRo (yes not
> a
> brilliatn idea, but I am testing whether it is a possible course of action
> for all users).
>
> Cheers.
>
 
S

Steve Foxon

#3
Yes I have.

Steve.

"Ronnie Vernon MVP" wrote:

> Steve
>
> Have you activated this copy of Vista yet?
>
> --
>
> Ronnie Vernon
> Microsoft MVP
> Windows Shell/User
>
>
> "Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote in message
> news:62EB6DB5-6A6E-40EC-A5A7-8418D4030BFC@microsoft.com...
> > Hi,
> >
> > Don't know if anyone can help, but I noticed today that the Superfetch
> > service will not start. I get "Error 197: The operating System is not
> > presently configured to run this application".
> >
> > Any ideas? I have Vista Business and it was upgraded from XP PRo (yes not
> > a
> > brilliatn idea, but I am testing whether it is a possible course of action
> > for all users).
> >
> > Cheers.
> >

>
 
M

meteorash

#4
Hi,

I have the same problem as well. I don't seem to have any idea how to get
Superfetch running. Please help.

Ashwin

"Steve Foxon" wrote:

> Yes I have.
>
> Steve.
>
> "Ronnie Vernon MVP" wrote:
>
> > Steve
> >
> > Have you activated this copy of Vista yet?
> >
> > --
> >
> > Ronnie Vernon
> > Microsoft MVP
> > Windows Shell/User
> >
> >
> > "Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote in message
> > news:62EB6DB5-6A6E-40EC-A5A7-8418D4030BFC@microsoft.com...
> > > Hi,
> > >
> > > Don't know if anyone can help, but I noticed today that the Superfetch
> > > service will not start. I get "Error 197: The operating System is not
> > > presently configured to run this application".
> > >
> > > Any ideas? I have Vista Business and it was upgraded from XP PRo (yes not
> > > a
> > > brilliatn idea, but I am testing whether it is a possible course of action
> > > for all users).
> > >
> > > Cheers.
> > >

> >
 
S

Steve Foxon

#5
Hi,

Microsoft gave me the solution to this. A couple of values in the registry
need changing to get it working. Both are under:

HKLM\System\CurrentContorlSet\Session Manager\Memory Management\Prefetch
Parameters

Both 'EnableSuperfetch' & 'EnablePrefetcher' need to be set to a value of 1.

After doing that, I was able to enable the Superfetch Service to run.

Hope that helps.

Steve.

"meteorash" wrote:

> Hi,
>
> I have the same problem as well. I don't seem to have any idea how to get
> Superfetch running. Please help.
>
> Ashwin
>
> "Steve Foxon" wrote:
>
> > Yes I have.
> >
> > Steve.
> >
> > "Ronnie Vernon MVP" wrote:
> >
> > > Steve
> > >
> > > Have you activated this copy of Vista yet?
> > >
> > > --
> > >
> > > Ronnie Vernon
> > > Microsoft MVP
> > > Windows Shell/User
> > >
> > >
> > > "Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote in message
> > > news:62EB6DB5-6A6E-40EC-A5A7-8418D4030BFC@microsoft.com...
> > > > Hi,
> > > >
> > > > Don't know if anyone can help, but I noticed today that the Superfetch
> > > > service will not start. I get "Error 197: The operating System is not
> > > > presently configured to run this application".
> > > >
> > > > Any ideas? I have Vista Business and it was upgraded from XP PRo (yes not
> > > > a
> > > > brilliatn idea, but I am testing whether it is a possible course of action
> > > > for all users).
> > > >
> > > > Cheers.
> > > >
> > >
 
R
#6
"Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote
> Hi,
>
> Microsoft gave me the solution to this. A couple of values in the registry
> need changing to get it working. Both are under:
>
> HKLM\System\CurrentContorlSet\Session Manager\Memory Management\Prefetch
> Parameters
>
> Both 'EnableSuperfetch' & 'EnablePrefetcher' need to be set to a value of
> 1.
>
> After doing that, I was able to enable the Superfetch Service to run.
>
> Hope that helps.


> "meteorash" wrote:
>
>> Hi,
>>
>> I have the same problem as well. I don't seem to have any idea how to get
>> Superfetch running. Please help.
>>
>> Ashwin
>>
>> "Steve Foxon" wrote:
>>
>> > Yes I have.
>> >
>> > Steve.
>> >
>> > "Ronnie Vernon MVP" wrote:
>> >
>> > > Steve
>> > >
>> > > Have you activated this copy of Vista yet?
>> > >


>> > > "Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote
>> > > > Hi,
>> > > >
>> > > > Don't know if anyone can help, but I noticed today that the
>> > > > Superfetch
>> > > > service will not start. I get "Error 197: The operating System is
>> > > > not
>> > > > presently configured to run this application".
>> > > >
>> > > > Any ideas? I have Vista Business and it was upgraded from XP PRo
>> > > > (yes not
>> > > > a
>> > > > brilliatn idea, but I am testing whether it is a possible course of
>> > > > action
>> > > > for all users).
>> > > >
>> > > > Cheers.


I think you left out a level and misspelled another in that registry key.
It should be
HKLM\System\CurrentControlSet\Control\Session Manager\Memory
Management\PrefetchParameters

Unfortunately I don't know what the various settings for these values mean.
On my system superfetch seems to be running and the settings are

EnablePrefetcher = 3
EnableSuperfetch = 3

Did the MS tech support person say what the settings corresponded to?
--
Rock [MS-MVP User/Shell]
 
S

Steve Foxon

#7
Hi,

sorry, ues you're quite right, I missed the 'Control' part out! And
mispelled control!

Mine are also now at 3, but when I altered them they were set to 0 and I was
told to change them to 1. So at some point they have changed.

All he said was that 0 meant they were diabled and 1 enabled and both need
to be enabled for superfetch to work. Couldn't tell you what 3 means though.

Steve.

>
> I think you left out a level and misspelled another in that registry key.
> It should be
> HKLM\System\CurrentControlSet\Control\Session Manager\Memory
> Management\PrefetchParameters
>
> Unfortunately I don't know what the various settings for these values mean.
> On my system superfetch seems to be running and the settings are
>
> EnablePrefetcher = 3
> EnableSuperfetch = 3
>
> Did the MS tech support person say what the settings corresponded to?
> --
> Rock [MS-MVP User/Shell]
>
>
 
M

mikeyhsd

#8
if it follows the same pattern as XP
0—Disable
1—Application Launch Prefetch
2—Boot Prefetch
3—Prefetch everything



mikeyhsd@comcast.net



"Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote in message news:B31011FC-65EA-4700-BA40-9D03ADD74703@microsoft.com...
Hi,

sorry, ues you're quite right, I missed the 'Control' part out! And
mispelled control!

Mine are also now at 3, but when I altered them they were set to 0 and I was
told to change them to 1. So at some point they have changed.

All he said was that 0 meant they were diabled and 1 enabled and both need
to be enabled for superfetch to work. Couldn't tell you what 3 means though.

Steve.

>
> I think you left out a level and misspelled another in that registry key.
> It should be
> HKLM\System\CurrentControlSet\Control\Session Manager\Memory
> Management\PrefetchParameters
>
> Unfortunately I don't know what the various settings for these values mean.
> On my system superfetch seems to be running and the settings are
>
> EnablePrefetcher = 3
> EnableSuperfetch = 3
>
> Did the MS tech support person say what the settings corresponded to?
> --
> Rock [MS-MVP User/Shell]
>
>
 
R
#9
"Steve Foxon" <SteveFoxon@discussions.microsoft.com> wrote
> Hi,
>
> sorry, ues you're quite right, I missed the 'Control' part out! And
> mispelled control!
>
> Mine are also now at 3, but when I altered them they were set to 0 and I
> was
> told to change them to 1. So at some point they have changed.
>
> All he said was that 0 meant they were diabled and 1 enabled and both need
> to be enabled for superfetch to work. Couldn't tell you what 3 means
> though.


>> I think you left out a level and misspelled another in that registry key.
>> It should be
>> HKLM\System\CurrentControlSet\Control\Session Manager\Memory
>> Management\PrefetchParameters
>>
>> Unfortunately I don't know what the various settings for these values
>> mean.
>> On my system superfetch seems to be running and the settings are
>>
>> EnablePrefetcher = 3
>> EnableSuperfetch = 3
>>
>> Did the MS tech support person say what the settings corresponded to?


Ok thanks. Interesting that you set it to 1 but it's at 3 now. Superfetch
is working fine here with the same registry setting. Maybe SF resets it to
3 after first running.

--
Rock [MS-MVP User/Shell]