• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

suppressing confirmation prompt

P

Peter Lawton

#1
I'm having problems running an Exchange shell script automatically because I
can't suppress the confirmation prompt. I've tried asking in an exchange
group but nobody there could help.

The command I'm trying to run is:-

get-mailbox | set-mailbox -Confirm:$False -ManagedFolderMailboxPolicy
"Default Policy"

But I get the prompt:-

Confirm
When assigning a managed folder mailbox policy with managed custom folders
to
the mailbox "domain/Users/username", Outlook clients older than
Outlook 2007 do not have all available client features and clients older
than
Outlook 2003 SP2 are not supported. You may use the "Set-CASMailbox" task to
enable client version blocking. Are you sure you want to assign a managed
folder mailbox policy to this mailbox?
[Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?] Help
(default is "Y"):

I've also tried setting $ConfirmPreference="none" or
$ConfirmPreference="high" but the prompt still appears

Can anyone think of a way to suppress the prompt or automatically answer "A"
so I can run this unnattended?

Many thanks

Peter Lawton
 

My Computer

S

Shay Levi

#2
I recreated your scenario and tried various commands, none helped, including
setting $ConfirmPreference to "none".

Then I tried to make the change through the GUI. The confirm dialog
appears even in the GUI.

I guess the Exchange team refers to this as a significant change, thus you
cant
avoid the dialog.


HTH

Shay
http://scriptolog.blogspot.com



> I'm having problems running an Exchange shell script automatically
> because I can't suppress the confirmation prompt. I've tried asking in
> an exchange group but nobody there could help.
>
> The command I'm trying to run is:-
>
> get-mailbox | set-mailbox -Confirm:$False -ManagedFolderMailboxPolicy
> "Default Policy"
>
> But I get the prompt:-
>
> Confirm
> When assigning a managed folder mailbox policy with managed custom
> folders
> to
> the mailbox "domain/Users/username", Outlook clients older than
> Outlook 2007 do not have all available client features and clients
> older
> than
> Outlook 2003 SP2 are not supported. You may use the "Set-CASMailbox"
> task to
> enable client version blocking. Are you sure you want to assign a
> managed
> folder mailbox policy to this mailbox?
> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?] Help
> (default is "Y"):
> I've also tried setting $ConfirmPreference="none" or
> $ConfirmPreference="high" but the prompt still appears
>
> Can anyone think of a way to suppress the prompt or automatically
> answer "A" so I can run this unnattended?
>
> Many thanks
>
> Peter Lawton
>
 

My Computer

M

Marco Shaw

#3
Peter Lawton wrote:
> I'm having problems running an Exchange shell script automatically because I
> can't suppress the confirmation prompt. I've tried asking in an exchange
> group but nobody there could help.
>
> The command I'm trying to run is:-
>
> get-mailbox | set-mailbox -Confirm:$False -ManagedFolderMailboxPolicy
> "Default Policy"
>
> But I get the prompt:-
>
> Confirm
> When assigning a managed folder mailbox policy with managed custom folders
> to
> the mailbox "domain/Users/username", Outlook clients older than
> Outlook 2007 do not have all available client features and clients older
> than
> Outlook 2003 SP2 are not supported. You may use the "Set-CASMailbox" task to
> enable client version blocking. Are you sure you want to assign a managed
> folder mailbox policy to this mailbox?
> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?] Help
> (default is "Y"):
>
> I've also tried setting $ConfirmPreference="none" or
> $ConfirmPreference="high" but the prompt still appears
>
> Can anyone think of a way to suppress the prompt or automatically answer "A"
> so I can run this unnattended?


WScript has some funtionality to send key strokes to the screen:
http://www.devguru.com/Technologies/wsh/quickref/wshshell_SendKeys.html

Just for fun, I used AutoIt:

PSH>$autoit=new-object -comobject autoitx3.control
PSH>$autoit.send("write-host `"test`"");$autoit.send("{ENTER}")
PSH> write-host "test"
test
PSH>

You could likely write a dynamic script that does a repeated loop and
sends the proper key strokes to the PowerShell console.

That being said, you might want some kind of error control, but you
might just be able to do a start-transcript/stop-transcript and review
the console log to make sure all was well...

Marco


--
----------------
PowerGadgets MVP
http://www.powergadgets.com/mvp

Blog:
http://marcoshaw.blogspot.com
 

My Computer

P

Peter Lawton

#4
I was afraid of that it's an Exchange team "feature", my suspicion is that
when they created the custom warning about versions of Outlook they forgot
to make it honour any of the standard confirm supression :(

"Shay Levi" <no@addre.ss> wrote in message
news:8766a944557c8c9b47e4b97aa18@news.microsoft.com...
>I recreated your scenario and tried various commands, none helped,
>including
> setting $ConfirmPreference to "none".
>
> Then I tried to make the change through the GUI. The confirm dialog
> appears even in the GUI.
>
> I guess the Exchange team refers to this as a significant change, thus you
> cant avoid the dialog.
>
>
> HTH
>
> Shay
> http://scriptolog.blogspot.com
>
>
>
>> I'm having problems running an Exchange shell script automatically
>> because I can't suppress the confirmation prompt. I've tried asking in
>> an exchange group but nobody there could help.
>>
>> The command I'm trying to run is:-
>>
>> get-mailbox | set-mailbox -Confirm:$False -ManagedFolderMailboxPolicy
>> "Default Policy"
>>
>> But I get the prompt:-
>>
>> Confirm
>> When assigning a managed folder mailbox policy with managed custom
>> folders
>> to
>> the mailbox "domain/Users/username", Outlook clients older than
>> Outlook 2007 do not have all available client features and clients
>> older
>> than
>> Outlook 2003 SP2 are not supported. You may use the "Set-CASMailbox"
>> task to
>> enable client version blocking. Are you sure you want to assign a
>> managed
>> folder mailbox policy to this mailbox?
>> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?] Help
>> (default is "Y"):
>> I've also tried setting $ConfirmPreference="none" or
>> $ConfirmPreference="high" but the prompt still appears
>>
>> Can anyone think of a way to suppress the prompt or automatically
>> answer "A" so I can run this unnattended?
>>
>> Many thanks
>>
>> Peter Lawton
>>

>
>
 

My Computer

S

Shay Levi

#5
BTW, does it prompts for each user in the pipeline or just for the first one?

Shay
http://scriptolog.blogspot.com



> I was afraid of that it's an Exchange team "feature", my suspicion is
> that when they created the custom warning about versions of Outlook
> they forgot to make it honour any of the standard confirm supression
> :(
>
> "Shay Levi" <no@addre.ss> wrote in message
> news:8766a944557c8c9b47e4b97aa18@news.microsoft.com...
>
>> I recreated your scenario and tried various commands, none helped,
>> including
>> setting $ConfirmPreference to "none".
>> Then I tried to make the change through the GUI. The confirm dialog
>> appears even in the GUI.
>>
>> I guess the Exchange team refers to this as a significant change,
>> thus you cant avoid the dialog.
>>
>> HTH
>>
>> Shay
>> http://scriptolog.blogspot.com
>>> I'm having problems running an Exchange shell script automatically
>>> because I can't suppress the confirmation prompt. I've tried asking
>>> in an exchange group but nobody there could help.
>>>
>>> The command I'm trying to run is:-
>>>
>>> get-mailbox | set-mailbox -Confirm:$False
>>> -ManagedFolderMailboxPolicy "Default Policy"
>>>
>>> But I get the prompt:-
>>>
>>> Confirm
>>> When assigning a managed folder mailbox policy with managed custom
>>> folders
>>> to
>>> the mailbox "domain/Users/username", Outlook clients older than
>>> Outlook 2007 do not have all available client features and clients
>>> older
>>> than
>>> Outlook 2003 SP2 are not supported. You may use the "Set-CASMailbox"
>>> task to
>>> enable client version blocking. Are you sure you want to assign a
>>> managed
>>> folder mailbox policy to this mailbox?
>>> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?]
>>> Help
>>> (default is "Y"):
>>> I've also tried setting $ConfirmPreference="none" or
>>> $ConfirmPreference="high" but the prompt still appears
>>> Can anyone think of a way to suppress the prompt or automatically
>>> answer "A" so I can run this unnattended?
>>>
>>> Many thanks
>>>
>>> Peter Lawton
>>>
 

My Computer

P

Peter Lawton

#6
It prompts for the first user it comes to that hasn't already got a policy
set, if I answer "Y" to that it'll prompt again at the next one, if I answer
"A" to that it'll run through all the users OK, so I really need to send it
an "A"

Peter Lawton

"Shay Levi" <no@addre.ss> wrote in message
news:8766a94455b68c9b4881e250f44@news.microsoft.com...
> BTW, does it prompts for each user in the pipeline or just for the first
> one?
>
> Shay
> http://scriptolog.blogspot.com
>
>
>
>> I was afraid of that it's an Exchange team "feature", my suspicion is
>> that when they created the custom warning about versions of Outlook
>> they forgot to make it honour any of the standard confirm supression
>> :(
>>
>> "Shay Levi" <no@addre.ss> wrote in message
>> news:8766a944557c8c9b47e4b97aa18@news.microsoft.com...
>>
>>> I recreated your scenario and tried various commands, none helped,
>>> including
>>> setting $ConfirmPreference to "none".
>>> Then I tried to make the change through the GUI. The confirm dialog
>>> appears even in the GUI.
>>>
>>> I guess the Exchange team refers to this as a significant change,
>>> thus you cant avoid the dialog.
>>>
>>> HTH
>>>
>>> Shay
>>> http://scriptolog.blogspot.com
>>>> I'm having problems running an Exchange shell script automatically
>>>> because I can't suppress the confirmation prompt. I've tried asking
>>>> in an exchange group but nobody there could help.
>>>>
>>>> The command I'm trying to run is:-
>>>>
>>>> get-mailbox | set-mailbox -Confirm:$False
>>>> -ManagedFolderMailboxPolicy "Default Policy"
>>>>
>>>> But I get the prompt:-
>>>>
>>>> Confirm
>>>> When assigning a managed folder mailbox policy with managed custom
>>>> folders
>>>> to
>>>> the mailbox "domain/Users/username", Outlook clients older than
>>>> Outlook 2007 do not have all available client features and clients
>>>> older
>>>> than
>>>> Outlook 2003 SP2 are not supported. You may use the "Set-CASMailbox"
>>>> task to
>>>> enable client version blocking. Are you sure you want to assign a
>>>> managed
>>>> folder mailbox policy to this mailbox?
>>>> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?]
>>>> Help
>>>> (default is "Y"):
>>>> I've also tried setting $ConfirmPreference="none" or
>>>> $ConfirmPreference="high" but the prompt still appears
>>>> Can anyone think of a way to suppress the prompt or automatically
>>>> answer "A" so I can run this unnattended?
>>>>
>>>> Many thanks
>>>>
>>>> Peter Lawton
>>>>

>
>
 

My Computer

S

Shay Levi

#7
In DOS we could do something like

command < ECHO A

But the input redirection is not implemented in PowerShell v1.0 :(

Shay
http://scriptolog.blogspot.com



> It prompts for the first user it comes to that hasn't already got a
> policy set, if I answer "Y" to that it'll prompt again at the next
> one, if I answer "A" to that it'll run through all the users OK, so I
> really need to send it an "A"
>
> Peter Lawton
>
> "Shay Levi" <no@addre.ss> wrote in message
> news:8766a94455b68c9b4881e250f44@news.microsoft.com...
>
>> BTW, does it prompts for each user in the pipeline or just for the
>> first one?
>>
>> Shay
>> http://scriptolog.blogspot.com
>>> I was afraid of that it's an Exchange team "feature", my suspicion
>>> is that when they created the custom warning about versions of
>>> Outlook they forgot to make it honour any of the standard confirm
>>> supression :(
>>>
>>> "Shay Levi" <no@addre.ss> wrote in message
>>> news:8766a944557c8c9b47e4b97aa18@news.microsoft.com...
>>>> I recreated your scenario and tried various commands, none helped,
>>>> including
>>>> setting $ConfirmPreference to "none".
>>>> Then I tried to make the change through the GUI. The confirm dialog
>>>> appears even in the GUI.
>>>> I guess the Exchange team refers to this as a significant change,
>>>> thus you cant avoid the dialog.
>>>>
>>>> HTH
>>>>
>>>> Shay
>>>> http://scriptolog.blogspot.com
>>>>> I'm having problems running an Exchange shell script automatically
>>>>> because I can't suppress the confirmation prompt. I've tried
>>>>> asking in an exchange group but nobody there could help.
>>>>>
>>>>> The command I'm trying to run is:-
>>>>>
>>>>> get-mailbox | set-mailbox -Confirm:$False
>>>>> -ManagedFolderMailboxPolicy "Default Policy"
>>>>> But I get the prompt:-
>>>>>
>>>>> Confirm
>>>>> When assigning a managed folder mailbox policy with managed custom
>>>>> folders
>>>>> to
>>>>> the mailbox "domain/Users/username", Outlook clients older than
>>>>> Outlook 2007 do not have all available client features and clients
>>>>> older
>>>>> than
>>>>> Outlook 2003 SP2 are not supported. You may use the
>>>>> "Set-CASMailbox"
>>>>> task to
>>>>> enable client version blocking. Are you sure you want to assign a
>>>>> managed
>>>>> folder mailbox policy to this mailbox?
>>>>> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?]
>>>>> Help
>>>>> (default is "Y"):
>>>>> I've also tried setting $ConfirmPreference="none" or
>>>>> $ConfirmPreference="high" but the prompt still appears
>>>>> Can anyone think of a way to suppress the prompt or automatically
>>>>> answer "A" so I can run this unnattended?
>>>>> Many thanks
>>>>>
>>>>> Peter Lawton
>>>>>
 

My Computer

P

Peter Lawton

#8
Someone on anotehr group gave me a way to do it now, seems that this
particular Exchange command needs a special switch
"-ManagedFolderMailboxPolicyAllowed" to suppress the confirmation
(standards - we've heard of them ;-)

Get-mailbox | Set-Mailbox -ManagedFolderMailboxPolicy "Policy
Name" -ManagedFolderMailboxPolicyAllowed

Peter Lawton

"Shay Levi" <no@xxxxxx> wrote in message
news:8766a94455f38c9b48ba3356b4a@xxxxxx

> In DOS we could do something like
>
> command < ECHO A
>
> But the input redirection is not implemented in PowerShell v1.0 :(
>
> Shay
> http://scriptolog.blogspot.com
>
>
>

>> It prompts for the first user it comes to that hasn't already got a
>> policy set, if I answer "Y" to that it'll prompt again at the next
>> one, if I answer "A" to that it'll run through all the users OK, so I
>> really need to send it an "A"
>>
>> Peter Lawton
>>
>> "Shay Levi" <no@xxxxxx> wrote in message
>> news:8766a94455b68c9b4881e250f44@xxxxxx
>>

>>> BTW, does it prompts for each user in the pipeline or just for the
>>> first one?
>>>
>>> Shay
>>> http://scriptolog.blogspot.com
>>>> I was afraid of that it's an Exchange team "feature", my suspicion
>>>> is that when they created the custom warning about versions of
>>>> Outlook they forgot to make it honour any of the standard confirm
>>>> supression :(
>>>>
>>>> "Shay Levi" <no@xxxxxx> wrote in message
>>>> news:8766a944557c8c9b47e4b97aa18@xxxxxx
>>>>> I recreated your scenario and tried various commands, none helped,
>>>>> including
>>>>> setting $ConfirmPreference to "none".
>>>>> Then I tried to make the change through the GUI. The confirm dialog
>>>>> appears even in the GUI.
>>>>> I guess the Exchange team refers to this as a significant change,
>>>>> thus you cant avoid the dialog.
>>>>>
>>>>> HTH
>>>>>
>>>>> Shay
>>>>> http://scriptolog.blogspot.com
>>>>>> I'm having problems running an Exchange shell script automatically
>>>>>> because I can't suppress the confirmation prompt. I've tried
>>>>>> asking in an exchange group but nobody there could help.
>>>>>>
>>>>>> The command I'm trying to run is:-
>>>>>>
>>>>>> get-mailbox | set-mailbox -Confirm:$False
>>>>>> -ManagedFolderMailboxPolicy "Default Policy"
>>>>>> But I get the prompt:-
>>>>>>
>>>>>> Confirm
>>>>>> When assigning a managed folder mailbox policy with managed custom
>>>>>> folders
>>>>>> to
>>>>>> the mailbox "domain/Users/username", Outlook clients older than
>>>>>> Outlook 2007 do not have all available client features and clients
>>>>>> older
>>>>>> than
>>>>>> Outlook 2003 SP2 are not supported. You may use the
>>>>>> "Set-CASMailbox"
>>>>>> task to
>>>>>> enable client version blocking. Are you sure you want to assign a
>>>>>> managed
>>>>>> folder mailbox policy to this mailbox?
>>>>>> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?]
>>>>>> Help
>>>>>> (default is "Y"):
>>>>>> I've also tried setting $ConfirmPreference="none" or
>>>>>> $ConfirmPreference="high" but the prompt still appears
>>>>>> Can anyone think of a way to suppress the prompt or automatically
>>>>>> answer "A" so I can run this unnattended?
>>>>>> Many thanks
>>>>>>
>>>>>> Peter Lawton
>>>>>>

>
>
 

My Computer

M

Mike Parrish

#9
I used the -ManagedFolderMailboxPolicyAllowed parameter to supress the
confirmation prompt.

"Peter Lawton" wrote:

> I'm having problems running an Exchange shell script automatically because I
> can't suppress the confirmation prompt. I've tried asking in an exchange
> group but nobody there could help.
>
> The command I'm trying to run is:-
>
> get-mailbox | set-mailbox -Confirm:$False -ManagedFolderMailboxPolicy
> "Default Policy"
>
> But I get the prompt:-
>
> Confirm
> When assigning a managed folder mailbox policy with managed custom folders
> to
> the mailbox "domain/Users/username", Outlook clients older than
> Outlook 2007 do not have all available client features and clients older
> than
> Outlook 2003 SP2 are not supported. You may use the "Set-CASMailbox" task to
> enable client version blocking. Are you sure you want to assign a managed
> folder mailbox policy to this mailbox?
> [Y] Yes [A] Yes to All [N] No [L] No to All Suspend [?] Help
> (default is "Y"):
>
> I've also tried setting $ConfirmPreference="none" or
> $ConfirmPreference="high" but the prompt still appears
>
> Can anyone think of a way to suppress the prompt or automatically answer "A"
> so I can run this unnattended?
>
> Many thanks
>
> Peter Lawton
>
>
>
>
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)