• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Tab and escape not working in Virtual PC?

A

Andomar

#1
In Virtual PC, my TAB and Escape keys no longer work. Tried rebooting
both the Virtual PC and the host but no effect.

Has anyone seen this problem or found a way to fix it?

TIA,
Andomar
 

My Computer

M

Mark Rae [MVP]

#2
"Andomar" <nothing@xxxxxx> wrote in message
news:op.unwxqgebcq0pnc@xxxxxx

> In Virtual PC, my TAB and Escape keys no longer work. Tried rebooting
> both the Virtual PC and the host but no effect.
Presumably, by "Virtual PC" you mean one of your virtual machines...?

1) What is the host OS?

2) What is the guest OS?

3) Assuming it's Windows of some sort, have you re-installed the
Additions...?

4) How much RAM does the host have?

5) How much of it have you assigned to the guest?

6) Does this happen in all virtual machines or only one?


--
Mark Rae
ASP.NET MVP
http://www.markrae.net
 

My Computer

A

Andomar

#3
Host OS = Windows 7
Guest OS = Windows XP
Additions removed and reinstalled, didn't help
Host has 4GB RAM, guest has 512MB RAM and a big pagefile
I have only one virtual machine, and the problem appeared recently
Tab and escape work fine on the host

Any tips appreciated:)

-Andomar

On Sat, 17 Jan 2009 19:58:56 +0100, Mark Rae [MVP]
<mark@xxxxxx> wrote:

> "Andomar" <nothing@xxxxxx> wrote in message
> news:op.unwxqgebcq0pnc@xxxxxx
>

>> In Virtual PC, my TAB and Escape keys no longer work. Tried rebooting
>> both the Virtual PC and the host but no effect.
>
> Presumably, by "Virtual PC" you mean one of your virtual machines...?
>
> 1) What is the host OS?
>
> 2) What is the guest OS?
>
> 3) Assuming it's Windows of some sort, have you re-installed the
> Additions...?
>
> 4) How much RAM does the host have?
>
> 5) How much of it have you assigned to the guest?
>
> 6) Does this happen in all virtual machines or only one?
>
>
 

My Computer

M

Mark Rae [MVP]

#4
"Andomar" <nothing@xxxxxx> wrote in message
news:op.unxf7vyncq0pnc@xxxxxx

[please don't top-post]

>>> In Virtual PC, my TAB and Escape keys no longer work. Tried rebooting
>>> both the Virtual PC and the host but no effect.
>>
>> Presumably, by "Virtual PC" you mean one of your virtual machines...?
>>
>> 1) What is the host OS?
>>
>> 2) What is the guest OS?
>>
>> 3) Assuming it's Windows of some sort, have you re-installed the
>> Additions...?
>>
>> 4) How much RAM does the host have?
>>
>> 5) How much of it have you assigned to the guest?
>>
>> 6) Does this happen in all virtual machines or only one?
>
> Host OS = Windows 7
> Guest OS = Windows XP
> Additions removed and reinstalled, didn't help
> Host has 4GB RAM, guest has 512MB RAM and a big pagefile
> I have only one virtual machine, and the problem appeared recently
> Tab and escape work fine on the host
1) When the guest is running, do the Tab and Escape keys continue to work in
the host?

2) Launch Notepad in the guest, hold down the left Alt key and (on the
number pad) type 0009 - does that produce a tab in Notepad...?


--
Mark Rae
ASP.NET MVP
http://www.markrae.net
 

My Computer

A

Andomar

#5
> 1) When the guest is running, do the Tab and Escape keys continue to

> work in the host?
>
Yes, tab on the host always works.

> 2) Launch Notepad in the guest, hold down the left Alt key and (on the
> number pad) type 0009 - does that produce a tab in Notepad...?
>
The problem appears to have vanished today, both tab and left-alt-0009
work.

Thanks for your reply, I'll post back when it reoccurs!

=Andoamr
 

My Computer

M

Mike Warriner

#6
Hi,

I've got exactly the same problem here too - Windows 7 x64 host, Windows XP
32bit guest. Host is 8gb and guest is 2gb.

Mike

"Andomar" wrote:

> > 1) When the guest is running, do the Tab and Escape keys continue to
> > work in the host?
> >
> Yes, tab on the host always works.
>

> > 2) Launch Notepad in the guest, hold down the left Alt key and (on the
> > number pad) type 0009 - does that produce a tab in Notepad...?
> >
> The problem appears to have vanished today, both tab and left-alt-0009
> work.
>
> Thanks for your reply, I'll post back when it reoccurs!
>
> =Andoamr
>
 

My Computer

J

JJ Streicher-Bremer

#8

> In Virtual PC, my TAB and Escape keys no longer work. Tried rebooting
> both the Virtual PC and the host but no effect.
>
> Has anyone seen this problem or found a way to fix it?
>
> TIA,
> Andomar
If you are running into this issue on Vista and Windows 7 you can get the TAB key back by creating a software allow policy. Go to administrative tools, local security policy, Software Restriction Policies, Additional Rules. Create a new rule for %appdata%\microsoft\vritual pc\vpckeyboard.dll and set it to Unrestricted. Restart Virtual PC.

If the variable doesn't work, try using an explicit path i.e. c:\users\username\appdata\roaming\microsoft\virtualpc\vpckeyboard.dll



Posted via http://www.VirtualServerFaq.com - Brought to you by Business Information Technology Shop - http://www.bitshop.com
 

My Computer

#9
Thanks that worked perfectly. Hopefully others will find this easily like I did.

I'm indifferent to (as opposed to proud of) the fact that I found this thread via Bing. Hey, it's fun to try new things.
 

My Computer