• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Trouble deleting folders because of 'security controls'!

  • Thread starter =?Utf-8?B?aW1hY2tlbg==?=
  • Start date
?

=?Utf-8?B?aW1hY2tlbg==?=

#1
Hi!
I have Vista Beta 2 installed, and in general I'm pretty happy, but I have
an issue that comes up a lot, and that is I can't delete certain folders, I
just get a message along the lines of 'There is security controlling
access.... You do not sufficient permission.....'.
I am the only user with administrative rights.
What can I do?
One of the folders I amn trying to remove is '_$WINDOWS.~Q' which I guess is
a remnant of a previous failed install.
Any help appreciated.
Iain
 

My Computer

J

Jimmy Brush

#2
Hello,

It sounds like this file is set up to not allow administrators access to it.

Generally, if you try to access a folder from explorer that you do not have
access to, it will ask you if you want to give yourself permission to access
the folder. If you go through this process and you still can't get to the
folder, then that means the folder does not allow administrators access to
it.

However, you can still do it the old fashioned way:

1) Open an "administrator/root" explorer
- Click start
- Type explorer
- right-click windows explorer
- click run-as administrator

2) Give yourself ownership of the folder
- Right-click on the folder in question
- Click Properties
- Click Security Tab
- Click Edit
- Click Advanced
- Click Owner
- Click Administrators
- Click the box next to "Replace owner on subcontainers and objects"
(WARNING: This is a dangerous option, especially when dealing with operating
system-created files. However, since your intent is to delete the folder in
question and any file or folder underneath it, this is necessary)
- Click OK
- Click OK
- Click OK

3) Give yourself access to the folder
- Right-click the folder again
- Click Properties
- Click security tab
- Click Edit
- Click Advanced
- Click Add
- Type your username
- Press enter
- Click the checkbox under Allow next to Full control
- Click OK
- Click the box next to "Replace all existing inheritable permissions on..."
(WARNING: This is a dangerous option, especially when dealing with operating
system-created files. However, since your intent is to delete the folder in
question and any file or folder underneath it, this is necessary)
- Click OK
- Click OK

You should now be able to delete the folder.

- JB

Vista FAQ
http://www.jimmah.com/vista/
 

My Computer

?

=?Utf-8?B?aW1hY2tlbg==?=

#3
Thanks Jimmy, but I'm afraid it doesn't work.
Everything is OK until 'Click the box next to "Replace owner on
subcontainers and objects"'. Then I just get a mass of the same 'There is
security controlling
access.... You do not have sufficient permission.....'.
I think the folder in question - _$WINDOWS.~Q - is a temporary one created
by the install of Vista.
I wouldn't normally bother, but it's taking up about 2Gb of space!
Any other suggestions?


"Jimmy Brush" wrote:

> Hello,
>
> It sounds like this file is set up to not allow administrators access to it.
>
> Generally, if you try to access a folder from explorer that you do not have
> access to, it will ask you if you want to give yourself permission to access
> the folder. If you go through this process and you still can't get to the
> folder, then that means the folder does not allow administrators access to
> it.
>
> However, you can still do it the old fashioned way:
>
> 1) Open an "administrator/root" explorer
> - Click start
> - Type explorer
> - right-click windows explorer
> - click run-as administrator
>
> 2) Give yourself ownership of the folder
> - Right-click on the folder in question
> - Click Properties
> - Click Security Tab
> - Click Edit
> - Click Advanced
> - Click Owner
> - Click Administrators
> - Click the box next to "Replace owner on subcontainers and objects"
> (WARNING: This is a dangerous option, especially when dealing with operating
> system-created files. However, since your intent is to delete the folder in
> question and any file or folder underneath it, this is necessary)
> - Click OK
> - Click OK
> - Click OK
>
> 3) Give yourself access to the folder
> - Right-click the folder again
> - Click Properties
> - Click security tab
> - Click Edit
> - Click Advanced
> - Click Add
> - Type your username
> - Press enter
> - Click the checkbox under Allow next to Full control
> - Click OK
> - Click the box next to "Replace all existing inheritable permissions on..."
> (WARNING: This is a dangerous option, especially when dealing with operating
> system-created files. However, since your intent is to delete the folder in
> question and any file or folder underneath it, this is necessary)
> - Click OK
> - Click OK
>
> You should now be able to delete the folder.
>
> - JB
>
> Vista FAQ
> http://www.jimmah.com/vista/
>
 

My Computer

M

Mark D. VandenBerg

#4
If you are dual-booting you could access it from the other O/S.

--
Ted Stevens taught me everything I know about putting internets in tubes...


"imacken" <imacken@discussions.microsoft.com> wrote in message
news:216372F4-301F-4F17-97B9-6C21C40299DB@microsoft.com...
> Thanks Jimmy, but I'm afraid it doesn't work.
> Everything is OK until 'Click the box next to "Replace owner on
> subcontainers and objects"'. Then I just get a mass of the same 'There is
> security controlling
> access.... You do not have sufficient permission.....'.
> I think the folder in question - _$WINDOWS.~Q - is a temporary one created
> by the install of Vista.
> I wouldn't normally bother, but it's taking up about 2Gb of space!
> Any other suggestions?
>
>
> "Jimmy Brush" wrote:
>
>> Hello,
>>
>> It sounds like this file is set up to not allow administrators access to
>> it.
>>
>> Generally, if you try to access a folder from explorer that you do not
>> have
>> access to, it will ask you if you want to give yourself permission to
>> access
>> the folder. If you go through this process and you still can't get to the
>> folder, then that means the folder does not allow administrators access
>> to
>> it.
>>
>> However, you can still do it the old fashioned way:
>>
>> 1) Open an "administrator/root" explorer
>> - Click start
>> - Type explorer
>> - right-click windows explorer
>> - click run-as administrator
>>
>> 2) Give yourself ownership of the folder
>> - Right-click on the folder in question
>> - Click Properties
>> - Click Security Tab
>> - Click Edit
>> - Click Advanced
>> - Click Owner
>> - Click Administrators
>> - Click the box next to "Replace owner on subcontainers and objects"
>> (WARNING: This is a dangerous option, especially when dealing with
>> operating
>> system-created files. However, since your intent is to delete the folder
>> in
>> question and any file or folder underneath it, this is necessary)
>> - Click OK
>> - Click OK
>> - Click OK
>>
>> 3) Give yourself access to the folder
>> - Right-click the folder again
>> - Click Properties
>> - Click security tab
>> - Click Edit
>> - Click Advanced
>> - Click Add
>> - Type your username
>> - Press enter
>> - Click the checkbox under Allow next to Full control
>> - Click OK
>> - Click the box next to "Replace all existing inheritable permissions
>> on..."
>> (WARNING: This is a dangerous option, especially when dealing with
>> operating
>> system-created files. However, since your intent is to delete the folder
>> in
>> question and any file or folder underneath it, this is necessary)
>> - Click OK
>> - Click OK
>>
>> You should now be able to delete the folder.
>>
>> - JB
>>
>> Vista FAQ
>> http://www.jimmah.com/vista/
>>
 

My Computer

?

=?Utf-8?B?aW1hY2tlbg==?=

#5
Thanks MArk, but unfortunately I'm not!

"Mark D. VandenBerg" wrote:

> If you are dual-booting you could access it from the other O/S.
>
> --
> Ted Stevens taught me everything I know about putting internets in tubes...
>
>
> "imacken" <imacken@discussions.microsoft.com> wrote in message
> news:216372F4-301F-4F17-97B9-6C21C40299DB@microsoft.com...
> > Thanks Jimmy, but I'm afraid it doesn't work.
> > Everything is OK until 'Click the box next to "Replace owner on
> > subcontainers and objects"'. Then I just get a mass of the same 'There is
> > security controlling
> > access.... You do not have sufficient permission.....'.
> > I think the folder in question - _$WINDOWS.~Q - is a temporary one created
> > by the install of Vista.
> > I wouldn't normally bother, but it's taking up about 2Gb of space!
> > Any other suggestions?
> >
> >
> > "Jimmy Brush" wrote:
> >
> >> Hello,
> >>
> >> It sounds like this file is set up to not allow administrators access to
> >> it.
> >>
> >> Generally, if you try to access a folder from explorer that you do not
> >> have
> >> access to, it will ask you if you want to give yourself permission to
> >> access
> >> the folder. If you go through this process and you still can't get to the
> >> folder, then that means the folder does not allow administrators access
> >> to
> >> it.
> >>
> >> However, you can still do it the old fashioned way:
> >>
> >> 1) Open an "administrator/root" explorer
> >> - Click start
> >> - Type explorer
> >> - right-click windows explorer
> >> - click run-as administrator
> >>
> >> 2) Give yourself ownership of the folder
> >> - Right-click on the folder in question
> >> - Click Properties
> >> - Click Security Tab
> >> - Click Edit
> >> - Click Advanced
> >> - Click Owner
> >> - Click Administrators
> >> - Click the box next to "Replace owner on subcontainers and objects"
> >> (WARNING: This is a dangerous option, especially when dealing with
> >> operating
> >> system-created files. However, since your intent is to delete the folder
> >> in
> >> question and any file or folder underneath it, this is necessary)
> >> - Click OK
> >> - Click OK
> >> - Click OK
> >>
> >> 3) Give yourself access to the folder
> >> - Right-click the folder again
> >> - Click Properties
> >> - Click security tab
> >> - Click Edit
> >> - Click Advanced
> >> - Click Add
> >> - Type your username
> >> - Press enter
> >> - Click the checkbox under Allow next to Full control
> >> - Click OK
> >> - Click the box next to "Replace all existing inheritable permissions
> >> on..."
> >> (WARNING: This is a dangerous option, especially when dealing with
> >> operating
> >> system-created files. However, since your intent is to delete the folder
> >> in
> >> question and any file or folder underneath it, this is necessary)
> >> - Click OK
> >> - Click OK
> >>
> >> You should now be able to delete the folder.
> >>
> >> - JB
> >>
> >> Vista FAQ
> >> http://www.jimmah.com/vista/
> >>

>
 

My Computer

J

Jean-Yves \(398693\)

#7
If "Folder" is empty, go to Run, then type CMD
Enter : DEL "Folder Name" (without cotes)
Normally it works

--
Jean-Yves
http://www.ifrance.com/jychamb/
"imacken" <imacken@discussions.microsoft.com> a écrit dans le message de
news: 2CDB0DDD-DA6F-4D5A-BBB9-A75AB7EC2368@microsoft.com...
> Hi!
> I have Vista Beta 2 installed, and in general I'm pretty happy, but I have
> an issue that comes up a lot, and that is I can't delete certain folders,
> I
> just get a message along the lines of 'There is security controlling
> access.... You do not sufficient permission.....'.
> I am the only user with administrative rights.
> What can I do?
> One of the folders I amn trying to remove is '_$WINDOWS.~Q' which I guess
> is
> a remnant of a previous failed install.
> Any help appreciated.
> Iain
 

My Computer