UAC setting blocking auto run...

G

Greg

Hello,

I have an app I created I need to run following a reboot after an
installation - and I am using a key in the HKLM\Software\Microsoft
\Windows\CurrentVersion\Run path of the registry to start the process.

Running the app manually it works (I get a prompt with a warning
coming from the UAC). But when run with the registry entry in place
after reboot, if the UAC setting is enabled, the program does not
start (and does not give any type of UAC warning prompt). If I
disable the UAC setting it works fine after the reboot.

How can I get the app to run after a reboot with the UAC setting still
enabled?

Thanks for any help,
Greg
[email protected]
 

My Computer

F

FromTheRafters

Have you tried scheduling it as a task?

"Greg" <[email protected]> wrote in message
news:[email protected]

> Hello,
>
> I have an app I created I need to run following a reboot after an
> installation - and I am using a key in the HKLM\Software\Microsoft
> \Windows\CurrentVersion\Run path of the registry to start the process.
>
> Running the app manually it works (I get a prompt with a warning
> coming from the UAC). But when run with the registry entry in place
> after reboot, if the UAC setting is enabled, the program does not
> start (and does not give any type of UAC warning prompt). If I
> disable the UAC setting it works fine after the reboot.
>
> How can I get the app to run after a reboot with the UAC setting still
> enabled?
>
> Thanks for any help,
> Greg
> [email protected]
 

My Computer

Top