• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

USB drivers are failing

Messages
31
#1
This problem has been here for a while but I never tried fixing it until now. Other USB devices such as printers etc. work fine but the mass storage devices and card slots do not. I have deduced that the problem is with the actual drivers (code 10) but I cannot update them, reinstall new ones, or roll them back. Also in device managers, there is the yellow triangle next to USB Mass Storage Device.

Thank you in advance for you help
Windows Vista SP2 32bit
 

My Computer

System One

  • Manufacturer/Model
    Windows
    CPU
    Pentium Dual Core
    Memory
    2046 MB, 3GB
    Graphics Card(s)
    GeForce 8400 GS, Intel Graphics Media Accelerator 4500MHD
    Monitor(s) Displays
    HP w17e
    Screen Resolution
    1400x900

richc46

Staff member
Vista Guru
Gold Member
Messages
20,105
Location
Fairfield County, CT
#2
Starting with a system restore point, uninstall the drivers. Then boot the computer, you should get updated drivers. Make sure that your Windows installer is set to install automatically. If things go bad, just go back with the system restore.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

Patonb

Vista Guru
Gold Member
Messages
2,245
#3
Is this on a phone, or usb external too?
 

My Computer

System One

  • CPU
    Dual L5639 // i7 950 @ 4.0Ghz
    Motherboard
    Evga SR-2 // Gigabyte x58a-ud3r
    Memory
    12Gig Corsair XMS3 // 6Gig OCZ Gold
    Graphics Card(s)
    gtx 560 ti // gtx 260-216
    Monitor(s) Displays
    Dual 22" // Headless
    Hard Drives
    OCZ aGILITY 3, 120Gig + Seagate 500Gig x 2
    PSU
    Silverstone da700 // Corsair 520hx
    Case
    Rosewill BlackHawk Ultra // Antec 900v1
    Cooling
    Twin CM Hyper 212+ // Noctua NH-u12
    Other Info
    Acer 8930 laptop with x9100...
Messages
31
#4
I uninstalled the drivers, but upon restart, my computer simply tried and failed to reinstall the drivers.

Also, this is on an external usb flash drive as well as pretty much any type of mass storage device. Again, the sd card slots and such also do not work.
 

My Computer

System One

  • Manufacturer/Model
    Windows
    CPU
    Pentium Dual Core
    Memory
    2046 MB, 3GB
    Graphics Card(s)
    GeForce 8400 GS, Intel Graphics Media Accelerator 4500MHD
    Monitor(s) Displays
    HP w17e
    Screen Resolution
    1400x900

wither 3

Vista Guru
Gold Member
Messages
2,227
#5
It could be the mobo drivers since most of your other devices don't work. You could try reinstalling them from safe mode, if you can get there. If you can get to safe mode, you might try a virus or malware scan.
 

My Computer

wither 3

Vista Guru
Gold Member
Messages
2,227
#9
In Control Panel, click on System. The Service Pack version should be near the top.

In Control Panel, Device Manager, is there any errors shown when you open the Universal Serial Bus Controllers.

Do any of these keyboards come with setup software?
 

My Computer

Messages
1
#10
just doing this for college work but if you go into control panel and click on System. The Service Pack version should be in there and that should be able to sort it, if not try consulting windows via the phone and see what they have to say
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)