• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Vista...Connection Status Unknown?

  • Thread starter nickolas80@gmail.com
  • Start date


Running Vista Ultimate, just the other day, the network connection
icon in the sys tray started showing a red 'x' and showing the message
"Connection Status: Unknown Server Execution Failed".

I can still access the internet. I have tried running ipconfig/
release, ipconfig/renew, and get a good ip address. I can see my
router and its setup (via

I have downloaded installed the fix for it at KB929451, but that
didn't help.

Any ideas?

My Computer



On May 28, 4:03 pm, nickola...@gmail.com wrote:
> RunningVistaUltimate, just the other day, the networkconnection
> icon in the sys tray started showing a red 'x' and showing the message
> "ConnectionStatus:UnknownServer Execution Failed".
> I can still access the internet. I have tried running ipconfig/
> release, ipconfig/renew, and get a good ip address. I can see my
> router and its setup (via
> I have downloaded installed the fix for it at KB929451, but that
> didn't help.
> Any ideas?

I also have the same problem with Connection Status: Unknown Server.
In addition, i also am unable to play any video or audio media via
winamp or windows media player/any video player. I have no idea how
to solve either problems. Can anybody help?

My Computer

I am having the same problem:

The icon turns into the pic shown above and lists Connection Status Unkown Sever Execution Failed, yet the internet clearly works, as I am writing this post while the icon shows it. Sound through my internet browser (Firefox) on sites such as youtube work fine, yet in games such as Halo 2 for Windows Vista and Shadowrun, the sound does not work. Additionally, when I connect my digital camera via the USB drive, it no longer works like it did a few days ago; the device manager knows that it is there, but it cannot open it. The drivers are all up to date.

All of these problems only started at about noon today; previously, everything had worked perfectly. I am at a loss as to what has caused this sudden malfunction...

My Computer


It occurred to me that it may have been the result of installing a printer and its drivers earlier, so I uninstalled all of them, but to no avail. As a last resort effort, I used System Restore to restore to the System Schedule Checkpoint from yesterday and now everything is working just as it used to.

Just another thought, perhaps the malfunctions were due to the update? Previous to the restore, I had done the update from Windows Update, but I have not done it yet, and don't plan to at least until I make a new back up point.

My Computer

Well, it won't let me edit my post, but I installed the update last night, and the connection error message is still gone. My guess is that it was the printer drivers, but I'm not sure still.

My Computer


New Member
Apologies if this was already posted somewhere, but I didn't see it anywhere else. I have the "Connection status unkown" problem AND the audio prolem (i.e. system sounds play fine, but unable to play mp3s through Nero, WMP, etc.) Anyway, I got the sound to work fine. Clicked on Control Panel -> Sound, it brought up an error message saying something was not working correctly, and gave me the option to disable it. After doing so, sound is working fine. The network "red x" junk is odd - wireless connection is still active (i.e. can access the internet), but Network and Sharing Center is bogged down, still have the red x, etc.

My Computer

Here are the fix step by step:

>>Right click "Computer"
>>Click "Manage"
>>Under the "System Tools" section, Double click "Local Users and Groups"
>>Click "Groups"
>>Right click "Administrators"
>>Click "Add to group..."
>>Click "Add"
>>Click "Advanced"
>>Click "Find Now"
>>Double click "Local Service"
>>Click "Ok"
>>"NT Authority\Local Service" should show up in the list now
>>Click "Ok"
>>Close Computer Management and reboot.

It worked for me, it should work for you.

My Computer


New Member
Thanks for your post Pete. This forum seems to be dead, but just in case...
The fix you posted doesn't work for Vista Home Premium or less, but the forum at: Re: No network - server execution failed - TechNet Forums
came up with the following solution for those running the home version (worked for me):
* Boot Windows to Safe Mode.
* From the command prompt, enter: "net localgroup Administrators LocalService /add"
* Verify using "net localgroup Administrators"
* Restart Windows normally.

My Computer

Alright, I typically don't post but after spending 5 hours troubleshooting this problem I thought I might save some people some time.


- Unknown Network (public) Local only on the network connection
- Gateway may or may not be missing but either way its typically it's not always accessible.
- Network Locations missing: Home/Work/Public
- Packets sent out, none received

- In my case which seemed to be pretty common, my machine was woke up from a sleep condition where someone else was logged in. I switched user and logged in and had no network connectivity.

OS: Vista Ultimate 64bit
FW: Norton 360
AV: Norton 360

I don't think it matters whether you are running Vista Ultimate/Home/Premium etc., however there may be a difference between 32bit and 64bit because the drivers are typically different.

I run both windows defender and Norton 360 for malware, and Norton 360 for Firewall and Antivirus protection.

My initial thoughts were that the system was corrupted and didn't come back from sleep correctly. So after much reading on many sites like this I decided to uninstall and reinstall the NIC drivers. No luck. Then I went after all the AV and FW software, first disabling them all, then reinstalling Norton 360. Still no luck. I rebooted my Cable Modem, Linksys Router, and even my computer... at one point all at the same time. After reboot... yep you guessed it.... still no network. I read suggestions and how things mysteriously started working again for people but no one could put a reason why. I gave up shut everything off, including my powerstrip on the floor because of frustration and went to bed.

Next morning I wake up and check it. Can you believe immediately after logging in, Vista asks me which network I'm on - Public/Work/Home and once I put it in everything works. This really bothered me and I went to work describing these conditions and the fact someone had mentioned on one of the boards that the NIC was broadcasting some checksum that basically said the NIC was still off or asleep.

To the credit of my co-workers, I think we came up with a solution!

- The NIC because of a driver issue never gets the reset from the OS. Since new motherboards have Wake-On-Lan enabled, they still have power regardless of what you power off. EXCEPT physically unplugging your machine long enough for everything to discharge and loose their state.

This would explain why some people solved this by replacing the NIC, or performing any function that they may have physically removed power from the Case/Motherboard.

Hope that helps, sorry for it being a long one....

My Computer


New Member
Had a similar problem. Simple fix:

Go to Start
type in sevices.msc
click enter
scroll down to Network Location Awareness
right click
click on Properties
look for Startup type
set it to Automatic
click Apply
click OK
now restart the computer

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)