VPN identity on local network

D

David Lozzi

Howdy,

I don't think this is a specific Vista-ism, may happen with XP as well, but
noticing it most with Vista. I'm running Vista Ultimate. When I VPN into a
customer's network my local resources try to connect using the VPN account,
not my Windows account. For example. I VPN into Customer with username of
Delphi and my machine's local items like Outlook, SharePoint, MS CRM 3.0,
Visual SourceSafe, Windows Explorer, which all assume my Windows login of
dlozzi are now trying to authenticate me with a username of Delphi. Some
items like Outlook, SharePoint and VSS I can manually override and enter in
the correct info. CRM and Explorer doesn't let me. I can see in Event View
on my machine that CRM failed connect due to invalid credentials with user
name Delphi. I cannot access my local network servers, \\Server1, due to
invalid credentials and it won't let me enter any in. This is quite
annoying. Is there anyway to keep my Windows authentication running for my
local items?

Thanks!!

David Lozzi
 

My Computer

R

Robert L [MVP - Networking]

You may want to use net use command to cache the credentials. these search results may help,

Can access remote computer via VPN occasionally
However, when the same user access the VPN, he uses cached credentials to access the remote computer. The VPN user may lose the cached credentials and may ...
http://www.chicagotech.net/casestudy/vpnaccess1.htm - Similar pages

VPN Issues
How to get VPN client to authenticate on the server with the same credentials that they used to connect to the VPN How to manage VPN idle time ...
http://www.chicagotech.net/vpn.htm


Bob Lin, MS-MVP, MCSE & CNE
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
"David Lozzi" <[email protected]> wrote in message news:[email protected]
Howdy,

I don't think this is a specific Vista-ism, may happen with XP as well, but
noticing it most with Vista. I'm running Vista Ultimate. When I VPN into a
customer's network my local resources try to connect using the VPN account,
not my Windows account. For example. I VPN into Customer with username of
Delphi and my machine's local items like Outlook, SharePoint, MS CRM 3.0,
Visual SourceSafe, Windows Explorer, which all assume my Windows login of
dlozzi are now trying to authenticate me with a username of Delphi. Some
items like Outlook, SharePoint and VSS I can manually override and enter in
the correct info. CRM and Explorer doesn't let me. I can see in Event View
on my machine that CRM failed connect due to invalid credentials with user
name Delphi. I cannot access my local network servers, \\Server1, due to
invalid credentials and it won't let me enter any in. This is quite
annoying. Is there anyway to keep my Windows authentication running for my
local items?

Thanks!!

David Lozzi
 

My Computer

A

Aanand Ramachandran

Hi David,
This is a know problem in Vista due to a design change in Credentail
Manager. The windows account (domain) credentials are actually cached,
however, when a VPN connection is setup and VPN creds dont work while
accessing a local resource the credential manager (CredMan)doesnt
automatically fall back to the windows creds. To get around this problem
there are 2 workarounds

1. Specify the full FQDN of the resource when you try to access it. This
will enable CredMan to fallback to the cached windows creds automatically
2. Disable caching of VPN creds. If you do this the windows account creds
will be used for all resources and you will be able to seamlessly access
local
resources. However, this will cause resources in the remote network to
prompt for creds. Here is the procedure to disable caching of VPN creds
- In the phonebook.pbk file there is a key called UseRasCredentials for
every connectoid on your computer. For the one that you are using to setup
the
VPN connection set the value of this key to 0.

thanks
Aanand

"David Lozzi" <[email protected]> wrote in message
news:[email protected]
> Howdy,
>
> I don't think this is a specific Vista-ism, may happen with XP as well,
> but noticing it most with Vista. I'm running Vista Ultimate. When I VPN
> into a customer's network my local resources try to connect using the VPN
> account, not my Windows account. For example. I VPN into Customer with
> username of Delphi and my machine's local items like Outlook, SharePoint,
> MS CRM 3.0, Visual SourceSafe, Windows Explorer, which all assume my
> Windows login of dlozzi are now trying to authenticate me with a username
> of Delphi. Some items like Outlook, SharePoint and VSS I can manually
> override and enter in the correct info. CRM and Explorer doesn't let me. I
> can see in Event View on my machine that CRM failed connect due to invalid
> credentials with user name Delphi. I cannot access my local network
> servers, \\Server1, due to invalid credentials and it won't let me enter
> any in. This is quite annoying. Is there anyway to keep my Windows
> authentication running for my local items?
>
> Thanks!!
>
> David Lozzi
 

My Computer

D

David Lozzi

Where is this file located? I cannot find it.

Thanks,

David Lozzi


"Aanand Ramachandran" <[email protected]> wrote in message
news:[email protected]
> Hi David,
> This is a know problem in Vista due to a design change in Credentail
> Manager. The windows account (domain) credentials are actually cached,
> however, when a VPN connection is setup and VPN creds dont work while
> accessing a local resource the credential manager (CredMan)doesnt
> automatically fall back to the windows creds. To get around this problem
> there are 2 workarounds
>
> 1. Specify the full FQDN of the resource when you try to access it. This
> will enable CredMan to fallback to the cached windows creds automatically
> 2. Disable caching of VPN creds. If you do this the windows account creds
> will be used for all resources and you will be able to seamlessly access
> local
> resources. However, this will cause resources in the remote network to
> prompt for creds. Here is the procedure to disable caching of VPN creds
> - In the phonebook.pbk file there is a key called UseRasCredentials for
> every connectoid on your computer. For the one that you are using to setup
> the
> VPN connection set the value of this key to 0.
>
> thanks
> Aanand
>
> "David Lozzi" <[email protected]> wrote in message
> news:[email protected]
>> Howdy,
>>
>> I don't think this is a specific Vista-ism, may happen with XP as well,
>> but noticing it most with Vista. I'm running Vista Ultimate. When I VPN
>> into a customer's network my local resources try to connect using the VPN
>> account, not my Windows account. For example. I VPN into Customer with
>> username of Delphi and my machine's local items like Outlook, SharePoint,
>> MS CRM 3.0, Visual SourceSafe, Windows Explorer, which all assume my
>> Windows login of dlozzi are now trying to authenticate me with a username
>> of Delphi. Some items like Outlook, SharePoint and VSS I can manually
>> override and enter in the correct info. CRM and Explorer doesn't let me.
>> I can see in Event View on my machine that CRM failed connect due to
>> invalid credentials with user name Delphi. I cannot access my local
>> network servers, \\Server1, due to invalid credentials and it won't let
>> me enter any in. This is quite annoying. Is there anyway to keep my
>> Windows authentication running for my local items?
>>
>> Thanks!!
>>
>> David Lozzi

>
 

My Computer

Top