• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

WCF: SVC file behind IIS and HTTPS - 'could not be activated' error

  • Thread starter ronscottlangham@yahoo.com
  • Start date
R

ronscottlangham@yahoo.com

#1
I have my WCF Web Service behind IIS and HTTPS. If I try to access
from my remote client I get the following error...

The requested service, 'https://db-appsvr02/appService/appService.svc'
could not be activated. See the server's diagnostic trace logs for
more information.

If I go into IIS Manager and right click on the SVC file and set the
File Security to 'Enable anonymous access' and turn off the Secure
Communications Certificate 'Require secure channel' then things
work. I have HTTPS working on a web application that is under the
same IIS so pretty sure that HTTPS is all configured and working ok.

Anyone else have WCF Web Services working behind HTTPS?

Thanks,
Ron
 

My Computer

Messages
1
#2
I have the same problem but when I try to browse my service at browser, I get an exception:

Memory gates checking failed because the free memory (134033408 bytes) is less than 5% of total memory. As a result, the service will not be available for incoming requests. To resolve this, either reduce the load on the machine or adjust the value of minFreeMemoryPercentageToActivateService on the serviceHostingEnvironment config element.

I close some programs, change 'mex' service path to absolute and service starts work properly.
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)