• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows 7 joining SBS 2003 R2 domain

C

cdavis82

#1
I'm having an issue with connectcomputer and joining a Windows 7 Ultimate PC
to our SBS 2003 R2 domain. When I attempt to join I get the following error:

"An error occurred while trying to copy the Client Setup files. Check the
following, and then try again:

If you use a public proxy server to browse the Internet, clear the Internet
Explorer connection setting for using a proxy server. To do this, from the
Tools menu, click Internet Options, click the Connections tab, click LAN
settings button, and then clear the check box in Proxy Server.

If you on not have a public proxy configured for Internet Explorer, then
your network administrator must reinstall the Client Deployment component on
the server. To do this, from Add or Remove Programs, run Windows Small
Business Server Setup in maintenance mode, and then run Client Setup again."

I don't run any sort of proxy and I have tried the suggestion for
reinstalling the client deployment component with no luck. I have also
confirmed that KB926505 is installed and that connectcomputer is not setup
for SSL.

I know I can join the domain manually, but I'd really prefer to do it the
way it was designed to be done so nothing gets missed.

Any help would be appreciated.

Casey
 

My Computer

R

Russ SBITS.Biz [SBS-MVP]

#2
Are you using a profile that has local Administrator rights on the PC?

Russ

--
Russell Grover - SBITS.Biz [SBS-MVP]
MCP, MCPS, MCNPS, SBSC
Small Business Server/Computer Support - www.SBITS.Biz
Question or Second Opinion - www.PersonalITConsultant.com
BPOS - Microsoft Online Services - www.BPOSMadeEasy.com
http://www.twitter.com/SBITSdotBiz

"cdavis82" <cdavis82@newsgroup> wrote in message
news:ECB27DF1-A2A7-471A-A730-CBA6D73B6ABD@newsgroup

> I'm having an issue with connectcomputer and joining a Windows 7 Ultimate
> PC
> to our SBS 2003 R2 domain. When I attempt to join I get the following
> error:
>
> "An error occurred while trying to copy the Client Setup files. Check the
> following, and then try again:
>
> If you use a public proxy server to browse the Internet, clear the
> Internet
> Explorer connection setting for using a proxy server. To do this, from
> the
> Tools menu, click Internet Options, click the Connections tab, click LAN
> settings button, and then clear the check box in Proxy Server.
>
> If you on not have a public proxy configured for Internet Explorer, then
> your network administrator must reinstall the Client Deployment component
> on
> the server. To do this, from Add or Remove Programs, run Windows Small
> Business Server Setup in maintenance mode, and then run Client Setup
> again."
>
> I don't run any sort of proxy and I have tried the suggestion for
> reinstalling the client deployment component with no luck. I have also
> confirmed that KB926505 is installed and that connectcomputer is not setup
> for SSL.
>
> I know I can join the domain manually, but I'd really prefer to do it the
> way it was designed to be done so nothing gets missed.
>
> Any help would be appreciated.
>
> Casey
 

My Computer

R

Robbin Meng [MSFT]

#3
Hello Casey,

Thanks for your post and Russ' input.

Besides confirming the user account that should has local administrator right, please also ensure the Windows 7 client's DNS is pointing to SBS internal IP address. Based on
my research, this error message may occur if SSL is enabled on ConnectComputer virtual directory in IIS. By default SSL is disabled on ConnectComputer virtual directory.

I noticed that you said "KB926505 is installed and that connectcomputer is not setup for SSL." I still would like to suggest you double confirm it. Please follow the steps below to
verify it:

1. Open IIS Manager.
2. Expand SBSSERVER\Web Sites\Default Web Site\ConnectComputer.
3. Right click ConnectComputer and select Properties.
4. Switch to "Directory Security" tab and click Edit under "Secure communications".
5. Make sure the option "Require secure channel (SSL)" is unchecked and click OK.
6. Click OK.
7. Run the command: iisreset.

Then, run the connectcomputer wizard again(put http://MYSERVER/connectcomputer in IE) on the Windows 7 laptop to check the result.

For more information, please refer to the following article:

Default settings of 'Default Website', Virtual Directories under Default Website and Companyweb on a SBS 2003 Server
http://blogs.technet.com/asksbs/arc...site-and-companyweb-on-a-sbs-2003-server.aspx

Hope this helps.



Best regards,
Robbin Meng(MSFT)
Microsoft Online Newsgroup Support

==================================================================
Please post your SBS 2008 related questions to the SBS newsgroup on Connect website:
https://connect.microsoft.com/sbs08/community/discussion/richui/default.aspx

Please post your EBS related questions to the EBS newsgroup on Connect website:
https://connect.microsoft.com/ebs08/community/discussion/richui/default.aspx

If you want to use a newsreader other than a web forum to access these newsgroups,
please refer to the following blog to apply NNTP password and configure a newsreader:
http://msmvps.com/blogs/bradley/archive/2008/11/02/signing-up-for-the-sbs-2008-newsgroups.aspx
==================================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
==================================================================
This posting is provided "AS IS" with no warranties, and confers no rights.
==================================================================
 

My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)