• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Defender Tray Notification Missing After System Start...

S

Susan

#1
I set Windows Defender to run and to display its tray notification all
the time. After starting the computer no tray icon appears until
opening program. Something looks amiss? Icon should be present all
the time when WD is running. Any ideas?

~<Susan>~
 

My Computer

D

diggerop

#2
"Susan" <UCE@xxxxxx> wrote in message
news:2kjqn4tmnu12b9trdqt9lcpblh2fh7mcst@xxxxxx

>I set Windows Defender to run and to display its tray notification all
> the time. After starting the computer no tray icon appears until
> opening program. Something looks amiss? Icon should be present all
> the time when WD is running. Any ideas?
>
> ~<Susan>~


Are you saying that you have to start Defender manually?

It might be worth seeing to see if it's set to run automatically. One of the
following options in Defender may be unchecked ...........tools/options/use
realtime protection or tools/options/administrator options.
 

My Computer

S

Susan

#3
On Mon, 26 Jan 2009 16:44:15 +0900, "diggerop" <toobusy@xxxxxx>
wrote:

>"Susan" <UCE@xxxxxx> wrote in message
>news:2kjqn4tmnu12b9trdqt9lcpblh2fh7mcst@xxxxxx

>>I set Windows Defender to run and to display its tray notification all
>> the time. After starting the computer no tray icon appears until
>> opening program. Something looks amiss? Icon should be present all
>> the time when WD is running. Any ideas?

>Are you saying that you have to start Defender manually?
>
>It might be worth seeing to see if it's set to run automatically. One of the
>following options in Defender may be unchecked ...........tools/options/use
>realtime protection or tools/options/administrator options.
No, I think Defender is running in background okay--Services says it
is Started and Automatic.

What I'm saying is that although I have checked the option to display
the tray icon Always, when I reboot the computer Defender does not
display the tray icon at all so I do not know its status that way.
When I open the program window its tray icon appears. From that point
on I can Close Defender and the tray icon continues to display.

Right clicking the tray icon only reveals Open and Exit options and
mousing over the icon only says Windows Defender unless I'm in a scan
I think. Rebooting repeats. No tray icon until Defender is opened.

I checked options and it is set to run automatically...real time
protection is checked along with all its subs checked and admin at the
bottom is checked along with its sub too.

~<Susan>~
 

My Computer

D

diggerop

#4
"Susan" <UCE@xxxxxx> wrote in message
news:0r4rn4d1ejrfdpij5k8btl0fp1cjuums26@xxxxxx

> On Mon, 26 Jan 2009 16:44:15 +0900, "diggerop" <toobusy@xxxxxx>
> wrote:
>

>>"Susan" <UCE@xxxxxx> wrote in message
>>news:2kjqn4tmnu12b9trdqt9lcpblh2fh7mcst@xxxxxx

>>>I set Windows Defender to run and to display its tray notification all
>>> the time. After starting the computer no tray icon appears until
>>> opening program. Something looks amiss? Icon should be present all
>>> the time when WD is running. Any ideas?
>

>>Are you saying that you have to start Defender manually?
>>
>>It might be worth seeing to see if it's set to run automatically. One of
>>the
>>following options in Defender may be unchecked
>>...........tools/options/use
>>realtime protection or tools/options/administrator options.
>
> No, I think Defender is running in background okay--Services says it
> is Started and Automatic.
>
> What I'm saying is that although I have checked the option to display
> the tray icon Always, when I reboot the computer Defender does not
> display the tray icon at all so I do not know its status that way.
> When I open the program window its tray icon appears. From that point
> on I can Close Defender and the tray icon continues to display.
>
> Right clicking the tray icon only reveals Open and Exit options and
> mousing over the icon only says Windows Defender unless I'm in a scan
> I think. Rebooting repeats. No tray icon until Defender is opened.
>
> I checked options and it is set to run automatically...real time
> protection is checked along with all its subs checked and admin at the
> bottom is checked along with its sub too.
>
> ~<Susan>~


Have you switched off Defender at some stage?

Out of curiosity, (and being foolhardy,) I unchecked Defender in the Startup
tab of System Configuration, then re-booted.
Then looked Services which still showed Defender as Started/Automatic!
...... No tray icon.
I then went back into System Configuration, checked Defender again and
re-booted.

I then had the exactly the same symptoms as you ... Defender reported as
running in Services, no tray icon unless I opened Defender myself.
Made sure everything was checked, re-booted again but to no avail.

My fix was to do a system restore, which brought everything back to normal.

If you haven't already done so, it might pay to look at Startup in System
Configuration
Perhaps system restore is an option for you?
 

My Computer

S

Susan

#5
On Tue, 27 Jan 2009 03:30:37 +0900, "diggerop" <toobusy@xxxxxx>
wrote:

>Have you switched off Defender at some stage?
Yes, I have on two other occasions but the first time I didn't have
the tray icon "always" on so I only noticed this problem after the
second time I turned it off and then back on...sigh.

>Out of curiosity, (and being foolhardy,) I unchecked Defender in the Startup
>tab of System Configuration, then re-booted.
Would you like to try this again? :)

>Then looked Services which still showed Defender as Started/Automatic!
>... No tray icon.
Yes, same here.

>I then went back into System Configuration, checked Defender again and
>re-booted.
So far so good...

>I then had the exactly the same symptoms as you ... Defender reported as
>running in Services, no tray icon unless I opened Defender myself.
>Made sure everything was checked, re-booted again but to no avail.
That's it!

>My fix was to do a system restore, which brought everything back to normal.
>
>If you haven't already done so, it might pay to look at Startup in System
>Configuration. Perhaps system restore is an option for you?
It is a good option and I tried it. I had to go back 3 days which
wasn't much of a bother before finding the restore point where I had
left msconfig Startup for WinDefend unchecked--and I think this was
the earliest I can use--it is now the latest in a sense. The restore
was successful and I first rechecked the Startup. Rebooted the
computer... Went through the WinDefend options to turn everything
back on including the tray icon on "always". Manually checked for
updates. Closed Defender. Opened it to see if all the choices still
stuck. Verified Services showed Started and Automatic and Services in
the Task Manager showed Running. Rebooted the computer and waited
long enough that everything was running and the machine was settled
down but the Windows Defender icon was no where to be found in the
tray. I reviewed all the settings and nothing had changed--"Always"
was still checked.

I need new ideas to try. Maybe a Regedit key to check and modify?
Perhaps it is time for a Google search? I found a different possible
solution. Will report back. It seems like many have noticed this
problem and have been or were looking for solutions.
~<Susan>~

Don't worry about the world coming to
an end today. It's already tomorrow in
Australia. - Charles Schultz
 

My Computer

S

Susan

#6
Here is a possible solution until MS does a possible Windows Defender
update? After a Google search I found a number of ppl having the same
problem and what one person discovered/posted here:

http://www.mydigitallife.info/2006/...n-not-found-in-system-tray-notification-area/

Here is the text that I cleaned up a little:

>Hektor
>October 23rd, 2008 14:35
>I had the same problem that most people had, windows defender tray icon didnt appear even with the options of always enable and everything; but the real solution is to put in the run command (regedit):
>HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
>
>“C:\Program Files\Windows Defender\MSASCui.exe” -hide
>
>instead of
>
>%Program Files\Windows Defender\MSASCui.exe -hide
[When I looked at my reg line I found:
%ProgramFiles%\Windows Defender\MSASCui.exe -hide
No space between Program Files and the second following '%']

>to be honest i dont know why it works that way but for dumb problems dumb solutions
I tried other possibilities like removing the '-hide' and adding a
space between 'Program Files' but those changes in and of themselves
made no difference. However, dropping the '%'s in favor of "C:\..."
above seems to have worked perfect. Not only did Defender's tray icon
appear before KIS 2009 (Kaspersky Internet Security 2009) but it made
some acknowledgement about Kaspersky running. I looked in Defenders
History Allowed and Quarantined folders and found nothing so who
knows. A second and third reboot didn't reveal anything new. As of
right now this problem is solved.
~<Susan>~

Don't worry about the world coming to
an end today. It's already tomorrow in
Australia. - Charles Schultz
 

My Computer

S

Susan

#7
On Mon, 26 Jan 2009 22:48:46 -0800, Susan <UCE@xxxxxx> wrote:

>It is a good option and I tried it. I had to go back 3 days which
>wasn't much of a bother before finding the restore point where I had
>left msconfig Startup for WinDefend unchecked--and I think this was
>the earliest I can use--it is now the latest in a sense. The restore
>was successful and I first rechecked the Startup. Rebooted the
>computer... Went through the WinDefend options to turn everything
>back on including the tray icon on "always". Manually checked for
>updates. Closed Defender. Opened it to see if all the choices still
>stuck. Verified Services showed Started and Automatic and Services in
>the Task Manager showed Running. Rebooted the computer and waited
>long enough that everything was running and the machine was settled
>down but the Windows Defender icon was no where to be found in the
>tray. I reviewed all the settings and nothing had changed--"Always"
>was still checked.
Ah I see why it worked for you and didn't work for me. You went far
enough back to where the reg Run line hadn't been changed while I only
could go back to after Defender was unchecked in MSConfig and the reg
Run line was already changed.

~<Susan>~
 

My Computer

D

diggerop

#8
"Susan" <UCE@xxxxxx> wrote in message
news:08etn41faunc3up1fh59moetpkun4q1q5n@xxxxxx

> Here is a possible solution until MS does a possible Windows Defender
> update? After a Google search I found a number of ppl having the same
> problem and what one person discovered/posted here:
>
> http://www.mydigitallife.info/2006/...n-not-found-in-system-tray-notification-area/
>
> Here is the text that I cleaned up a little:
>

>>Hektor
>>October 23rd, 2008 14:35
>>I had the same problem that most people had, windows defender tray icon
>>didnt appear even with the options of always enable and everything; but
>>the real solution is to put in the run command (regedit):
>>HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
>>
>>"C:\Program Files\Windows Defender\MSASCui.exe" -hide
>>
>>instead of
>>
>>%Program Files\Windows Defender\MSASCui.exe -hide
>
> [When I looked at my reg line I found:
> %ProgramFiles%\Windows Defender\MSASCui.exe -hide
> No space between Program Files and the second following '%']
>

>>to be honest i dont know why it works that way but for dumb problems dumb
>>solutions
>
> I tried other possibilities like removing the '-hide' and adding a
> space between 'Program Files' but those changes in and of themselves
> made no difference. However, dropping the '%'s in favor of "C:\..."
> above seems to have worked perfect. Not only did Defender's tray icon
> appear before KIS 2009 (Kaspersky Internet Security 2009) but it made
> some acknowledgement about Kaspersky running. I looked in Defenders
> History Allowed and Quarantined folders and found nothing so who
> knows. A second and third reboot didn't reveal anything new. As of
> right now this problem is solved.
> ~<Susan>~
>
> Don't worry about the world coming to
> an end today. It's already tomorrow in
> Australia. - Charles Schultz



Thanks for the info Susan and I'm pleased you've found a solution. : )

As a matter of interest, I looked at my registry entry, It shows
%ProgramFiles%\Windows Defender\MSASCui.exe -hide
with everything working as it should.

Does that point to a corrupted user variable string during the
disable/enable process?
I wonder if the "C:\" over-rides the variable in the string ... i.e. the
icon is now a permanent fixture?
Or maybe I'm just talking nonsense.

Following a 6 month break in civilisation, I'm about to disappear into the
far Nor-West of the country in your Sig. Remote area construction.
No internet. : (

Best of Luck Happy Computing
 

My Computer