• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Windows Sidebar Repair/Reinstall - MVP/MSFT Help needed

#1
Ok a long time ago I posted about repairing my Sidebar in Vista, that was
messed up when I uninstalled a program and it uninstalled an old version of
java. My system restore didnt go back far enough and all everyone else had
to offer was make sure I had the latest version of Java.
I tried a bunch of stuff on my own and nothing worked and made it a little
worse. Well I deleted everything in the folder. Then I browsed into the
Install.wim on the Vista DVD and restored the C:\Program Files\Windows
Sidebar folder. Now I am back to the original problem - When I run the
sidebar.exe (whether from shortcut or running the .exe or running it as
admin), it does nothing. It doesnt give any error boxes or show up in the
process list or anything.
So I ran Process Monitor (I love sysinternals) and captured all the data
created when I attempt to start Sidebar. I tried to attach the data in a CSV
file or put it in txt format in this post but it wouldnt let me post it. Can
someone help me check out the data and see if they can tell why it isnt
running?

Thank you in advance for any help.
 
D

Daniel Martín [MVP Windows]

#2
Hi, Ron:

I can work with you on this problem. Could you send to my e-mail address all
the data captured by Process Monitor?

--
Regards,
Daniel Martín
Microsoft MVP Windows - Shell/User


"Ron" <rrosson1@cox.net> wrote in message
news:%23MSTGBtyHHA.1072@TK2MSFTNGP04.phx.gbl...
> Ok a long time ago I posted about repairing my Sidebar in Vista, that was
> messed up when I uninstalled a program and it uninstalled an old version
> of
> java. My system restore didnt go back far enough and all everyone else had
> to offer was make sure I had the latest version of Java.
> I tried a bunch of stuff on my own and nothing worked and made it a little
> worse. Well I deleted everything in the folder. Then I browsed into the
> Install.wim on the Vista DVD and restored the C:\Program Files\Windows
> Sidebar folder. Now I am back to the original problem - When I run the
> sidebar.exe (whether from shortcut or running the .exe or running it as
> admin), it does nothing. It doesnt give any error boxes or show up in the
> process list or anything.
> So I ran Process Monitor (I love sysinternals) and captured all the data
> created when I attempt to start Sidebar. I tried to attach the data in a
> CSV
> file or put it in txt format in this post but it wouldnt let me post it.
> Can
> someone help me check out the data and see if they can tell why it isnt
> running?
>
> Thank you in advance for any help.
>
>
>
 
D

Daniel Martín [MVP Windows]

#3
If anyone is interested, the problem has been resolved after following these
steps:

Click Start, All Programs, Accessories, right-click Command Prompt and
select "Run as administrator".

Type these commands one by one:

Regsvr32 atl.dll
Regsvr32 "%ProgramFiles%\Windows Sidebar\sbdrop.dll"
Regsvr32 "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"

--
Regards,
Daniel Martín
Microsoft MVP Windows - Shell/User


"Ron" <rrosson1@cox.net> wrote in message
news:%23MSTGBtyHHA.1072@TK2MSFTNGP04.phx.gbl...
> Ok a long time ago I posted about repairing my Sidebar in Vista, that was
> messed up when I uninstalled a program and it uninstalled an old version
> of
> java. My system restore didnt go back far enough and all everyone else had
> to offer was make sure I had the latest version of Java.
> I tried a bunch of stuff on my own and nothing worked and made it a little
> worse. Well I deleted everything in the folder. Then I browsed into the
> Install.wim on the Vista DVD and restored the C:\Program Files\Windows
> Sidebar folder. Now I am back to the original problem - When I run the
> sidebar.exe (whether from shortcut or running the .exe or running it as
> admin), it does nothing. It doesnt give any error boxes or show up in the
> process list or anything.
> So I ran Process Monitor (I love sysinternals) and captured all the data
> created when I attempt to start Sidebar. I tried to attach the data in a
> CSV
> file or put it in txt format in this post but it wouldnt let me post it.
> Can
> someone help me check out the data and see if they can tell why it isnt
> running?
>
> Thank you in advance for any help.
>
>
>
 
H

howcome

#4
your solution fixed my problem. Thanks.......

"Daniel Martín [MVP Windows]" wrote:

> If anyone is interested, the problem has been resolved after following these
> steps:
>
> Click Start, All Programs, Accessories, right-click Command Prompt and
> select "Run as administrator".
>
> Type these commands one by one:
>
> Regsvr32 atl.dll
> Regsvr32 "%ProgramFiles%\Windows Sidebar\sbdrop.dll"
> Regsvr32 "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"
>
> --
> Regards,
> Daniel Martín
> Microsoft MVP Windows - Shell/User
>
>
> "Ron" <rrosson1@cox.net> wrote in message
> news:%23MSTGBtyHHA.1072@TK2MSFTNGP04.phx.gbl...
> > Ok a long time ago I posted about repairing my Sidebar in Vista, that was
> > messed up when I uninstalled a program and it uninstalled an old version
> > of
> > java. My system restore didnt go back far enough and all everyone else had
> > to offer was make sure I had the latest version of Java.
> > I tried a bunch of stuff on my own and nothing worked and made it a little
> > worse. Well I deleted everything in the folder. Then I browsed into the
> > Install.wim on the Vista DVD and restored the C:\Program Files\Windows
> > Sidebar folder. Now I am back to the original problem - When I run the
> > sidebar.exe (whether from shortcut or running the .exe or running it as
> > admin), it does nothing. It doesnt give any error boxes or show up in the
> > process list or anything.
> > So I ran Process Monitor (I love sysinternals) and captured all the data
> > created when I attempt to start Sidebar. I tried to attach the data in a
> > CSV
> > file or put it in txt format in this post but it wouldnt let me post it.
> > Can
> > someone help me check out the data and see if they can tell why it isnt
> > running?
> >
> > Thank you in advance for any help.
> >
> >
> >

>
>
 
W

wilma

#6
Hi Daniel,
The advice you give below doesn't seem to work for me.When I Click Start,
All Programs, Accessories, right-click Command Prompt and select "Run as
administrator the root directory is still in c:\Users\Wilma. Should I change
directory to cd:\ first, then type the commands you set out below? I have
been trying all sors of things to replace my sidebar.This sems to be the
closest I' getting.
Look forard to any advice you can give me.
Regards
wilma


"Daniel Martín [MVP Windows]" wrote:

> If anyone is interested, the problem has been resolved after following these
> steps:
>
> Click Start, All Programs, Accessories, right-click Command Prompt and
> select "Run as administrator".
>
> Type these commands one by one:
>
> Regsvr32 atl.dll
> Regsvr32 "%ProgramFiles%\Windows Sidebar\sbdrop.dll"
> Regsvr32 "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"
>
> --
> Regards,
> Daniel Martín
> Microsoft MVP Windows - Shell/User
>
>
> "Ron" <rrosson1@xxxxxx> wrote in message
> news:%23MSTGBtyHHA.1072@xxxxxx

> > Ok a long time ago I posted about repairing my Sidebar in Vista, that was
> > messed up when I uninstalled a program and it uninstalled an old version
> > of
> > java. My system restore didnt go back far enough and all everyone else had
> > to offer was make sure I had the latest version of Java.
> > I tried a bunch of stuff on my own and nothing worked and made it a little
> > worse. Well I deleted everything in the folder. Then I browsed into the
> > Install.wim on the Vista DVD and restored the C:\Program Files\Windows
> > Sidebar folder. Now I am back to the original problem - When I run the
> > sidebar.exe (whether from shortcut or running the .exe or running it as
> > admin), it does nothing. It doesnt give any error boxes or show up in the
> > process list or anything.
> > So I ran Process Monitor (I love sysinternals) and captured all the data
> > created when I attempt to start Sidebar. I tried to attach the data in a
> > CSV
> > file or put it in txt format in this post but it wouldnt let me post it.
> > Can
> > someone help me check out the data and see if they can tell why it isnt
> > running?
> >
> > Thank you in advance for any help.
> >
> >
> >
>
>
 

Brink

Staff member
mvp
#7
Hi Daniel,
The advice you give below doesn't seem to work for me.When I Click Start,
All Programs, Accessories, right-click Command Prompt and select "Run as
administrator the root directory is still in c:\Users\Wilma. Should I change
directory to cd:\ first, then type the commands you set out below? I have
been trying all sors of things to replace my sidebar.This sems to be the
closest I' getting.
Look forard to any advice you can give me.
Regards
wilma


"Daniel MartÃ*n [MVP Windows]" wrote:
> If anyone is interested, the problem has been resolved after following these
> steps:
>
> Click Start, All Programs, Accessories, right-click Command Prompt and
> select "Run as administrator".
>
> Type these commands one by one:
>
> Regsvr32 atl.dll
> Regsvr32 "%ProgramFiles%\Windows Sidebar\sbdrop.dll"
> Regsvr32 "%ProgramFiles%\Windows Sidebar\wlsrvc.dll"
>
> --
> Regards,
> Daniel MartÃ*n
> Microsoft MVP Windows - Shell/User
>
>
> "Ron" <rrosson1@xxxxxx> wrote in message
> news:%23MSTGBtyHHA.1072@xxxxxx
>
>
Hi Wilma,

This should help you out to get Windows Sidebar started again.

http://www.vistax64.com/tutorials/117192-windows-sidebar-will-not-start-vista.html

Shawn
 
#9
Thank you for the excellent advice. My sidebar was acting flaky with gadgets appearing and disappearing seemingly at will. It seems to be stable again, thank you.:D