Windows Vista Forums

Internet links will not open in Windows Mail

  1. #1



    Newbie
    Join Date : Sep 2008
    Posts : 5
    Vista x32
    Local Time: 02:48 AM

    Internet links will not open in Windows Mail

    My problem is that I can't open IE7 links from within WinMail anymore. I've looked here and elsewhere for a solution ('Windows cannot find 'http -/- html'. Make sure you typed the name correctly, and then try again'). From this and other events, I suspect this is a permissions issue. Any ideas?


    George

      My System SpecsSystem Spec

  2.   


  3. #2
    Brink's Avatar

    Administrator


    Join Date : Apr 2007
    Texas, USA
    Posts : 31,329
    64-bit Windows 8.1 Enterprise (RTM)
    Local Time: 07:48 PM
    usa us oklahoma

     

    Re: TrustedInstaller - Restore as Owner

    Hello Kito, and welcome to Vista Forums.

    That problem has nothing to do with TrustedInstaller.

    Check to make sure that you have Internet Explorer set as the default program with all of it's associations set (checked) for it. This tutorial will show you how to if needed.

    Default Programs - Program Default Associations

    Hope this helps,
    Shawn

      My System SpecsSystem Spec

  4. #3



    Newbie
    Join Date : Sep 2008
    Posts : 5
    Vista x32
    Local Time: 02:48 AM


      Thread Starter

    Re: TrustedInstaller - Restore as Owner

    Thanks for your reply.
    I tried the IE default program settings, but it doesn't seem to have made WinMail 'communicate' with it. For example, I get Windows cannot find 'http://www.vistax64.com/showthread.php?t=159360&goto=newpost'. Make sure you typed the name correctly, and then try again from your message.

    I also tried resetting WinMail, via your excellent guide, still with no 'linking' result.

    The problem seemed to start after I had to install an ActiveX item to download a GeForce driver from nVidia's official site -- 'seemed' because I was also updating Creative SB X-Fi driver / utilities at around the same time.

    Since then, there seem to be more '(a program) has stopped working
    Windows is checking for a solution to the problem...' alerts than before.

    So I wonder if something in IE7 has become corrupted, or whether this was a system-wide problem (e.g. permissions).

    So, a couple of questions:
    (i) Can IE be removed from the registry and 'reset'/restored as with the WinMail guide?
    (ii) Have you (or any other Vista users) noticed this problem in relation to ActiveX or driver installation?

    Any help appreciated before I resort to repairing Vista
    George

      My System SpecsSystem Spec

  5. #4
    Brink's Avatar

    Administrator


    Join Date : Apr 2007
    Texas, USA
    Posts : 31,329
    64-bit Windows 8.1 Enterprise (RTM)
    Local Time: 07:48 PM
    usa us oklahoma

     

    Re: TrustedInstaller - Restore as Owner

    George,

    Double check your settings in Windows Mail (Tools - Options), in the Security tab to make sure that Internet Zone is dotted and to uncheck Do not allow attachments.... and Block images and other .....

    Are you able to copy the link from Windows Mail and manually paste it in the Internet Explorer address bar and it opens that page then?

    This will show you how to reset IE7 if needed.

    Internet Explorer - Reset

    Hope this helps,
    Shawn

      My System SpecsSystem Spec

  6. #5



    Newbie
    Join Date : Sep 2008
    Posts : 5
    Vista x32
    Local Time: 02:48 AM


      Thread Starter

    Re: Internet links will not open in Windows Mail

    Yes, copying the link works; however, relaxing WinMail security settings gives the same result.

    Tried resetting IE7, no difference.
    Installed and tried IE8, same story.

    I note that trying to open internet shortcut (.url) files directly from the Favorites folder produces the same 'Windows cannot find...' message. But will open .xps files, so doubt it's a file association/extension issue - maybe a Windows Explorer problem?

      My System SpecsSystem Spec

  7. #6
    Brink's Avatar

    Administrator


    Join Date : Apr 2007
    Texas, USA
    Posts : 31,329
    64-bit Windows 8.1 Enterprise (RTM)
    Local Time: 07:48 PM
    usa us oklahoma

     

    Re: Internet links will not open in Windows Mail

    I would leave your WinMail security settings relaxed to be able to open links when you click on them.

    Does opening Favorites from within IE7 work fine? Have you doublechecked the links that you get this message on to make sure that they are valid addresses?

      My System SpecsSystem Spec

  8. #7



    Newbie
    Join Date : Sep 2008
    Posts : 5
    Vista x32
    Local Time: 02:48 AM


      Thread Starter

    Re: Internet links will not open in Windows Mail

    Sorry, maybe my answer wasn't too clear - I still can't open (any) links from WinMail, even with relaxed security settings.

    Favorites from within IE7 work as normal. Links checked; all valid urls.

    A bit of a Vista mystery...

      My System SpecsSystem Spec

  9. #8
    Brink's Avatar

    Administrator


    Join Date : Apr 2007
    Texas, USA
    Posts : 31,329
    64-bit Windows 8.1 Enterprise (RTM)
    Local Time: 07:48 PM
    usa us oklahoma

     

    Re: Internet links will not open in Windows Mail

    You might check your antivirus and other security program to see if they have any sort of Windows Mail filtering feature turned on. If they do, try disabling that setting and/or the program itself temporarily to see if it is interfering.

      My System SpecsSystem Spec

  10. #9



    Newbie
    Join Date : Sep 2008
    Posts : 5
    Vista x32
    Local Time: 02:48 AM


      Thread Starter

    Re: Internet links will not open in Windows Mail

    Hello again. I've found the cause, but not a complete solution.
    The problem appears to be related to User Account Control.

    [-] Disabling UAC allows direct opening of .url links from (a) within WinMail, (b) the Favorites folder on the Start Menu, and (c) the Favorites folder in Windows Explorer.

    [+] Enabling UAC prevents these actions.

    I'm sure it didn't always behave this way. Does this happen to anyone else?
    My feeling is that something has become corrupted.

    I've also tried:
    1 Checking antivirus/security settings: they don't seem to affect this.
    2 Elevating Administrator Privilege
    3 Enable Hidden Built-In Administrator Account
    4 Uninstalling SP1 (didn't complete).

    So, while disabling UAC - or 3, above - fixes the problem, it's not the most secure solution.

    Many thanks for your dedicated help, anyway, Shawn. Good luck to anyone who encounters this problem or finds a fix for it!

    George

      My System SpecsSystem Spec

  11. #10
    Brink's Avatar

    Administrator


    Join Date : Apr 2007
    Texas, USA
    Posts : 31,329
    64-bit Windows 8.1 Enterprise (RTM)
    Local Time: 07:48 PM
    usa us oklahoma

     

    Re: Internet links will not open in Windows Mail

    Thank you George for posting back the results you have found. I'm not sure what else to try either. Hopefully someone will know if a better solution for you.

      My System SpecsSystem Spec


Internet links will not open in Windows Mail
Similar Threads
Thread Forum
How to set windows sidebar to open internet links in Firefox Browsers & Mail
Microsoft Mail - Can not open internet links Vista mail
Links won't open in Windows mail Live Mail
Can't open links in Windows Mail Vista mail
Windows Mail won't open some links Vista mail