Windows Vista Forums

Cannot access internet even though connected

  1. #1



    Newbie
    Join Date : Jul 2009
    Posts : 8
    Vista Home Premium x64
    Local Time: 10:13 AM

    Cannot access internet even though connected

    I upgraded my Vista Home Premium x64 to SP2 on 8/28. No problem until 8/31. Now I cannot get on the internet regardless of firefox, IE, or Chrome. The Windows Network Diagnostics did not find any problems. The network and Sharing center shows that I am connected to my network and then to the internet with no issues. IPv4 = Internet. IPv6 = limited.

    Steps completed thus far:
    • I rebooted the cable modem and the router (linksys wrt54g)
    • I successfully pinged the x64 computer with a different cpu on the network. Status activity shows bytes sent and received successfully on the x64 system.
    • I tried to system restore prior to SP2 upgrade but says failed, however System properties show that running SP1. (???)
    • I updated network card driver (intel 82567lf-2) to most recent - 7/23
    • I ran the Intel network card diagnostics and all test were sucessful
    • Booted into safe mode with networking. Unsuccessful.
    • Ran Hijackthis, nothing unusual.
    I am at a loss of what to do. I do even know how to describe the situation succinctly enough to search and see if others have had the same problem. My computer is a Dell XPS Studio Core i7 w/ x64 Home Premium. Please help.

    Also I am now getting the pesky Data Execution Prevention message after ever window that I close. I tried to do the bcedit.exe fix, but said that bcedit wasn't recognized.

      My System SpecsSystem Spec

  2.   


  3. #2



    Member
    Join Date : May 2009
    Posts : 124
    Vista Home Premium 64bit
    Local Time: 09:13 AM


     

    Re: Cannot access internet even though connected

    Have you tried bypassing your router and connecting directly to your cable modem?

      My System SpecsSystem Spec

  4. #3



    Newbie
    Join Date : Jul 2009
    Posts : 8
    Vista Home Premium x64
    Local Time: 10:13 AM


      Thread Starter

    Re: Cannot access internet even though connected

    I did that while waiting for someone to reply. No dice. Same scenario. Nothing will load on IE/FF/Chrome or connect (thunderbird, tried to update spyware), but the network and sharing center shows I am connected to the internet.

      My System SpecsSystem Spec

  5. #4



    Member
    Join Date : May 2009
    Posts : 124
    Vista Home Premium 64bit
    Local Time: 09:13 AM


     

    Re: Cannot access internet even though connected

    Quote Originally Posted by JeremyT View Post
    I did that while waiting for someone to reply. No dice. Same scenario. Nothing will load on IE/FF/Chrome or connect (thunderbird, tried to update spyware), but the network and sharing center shows I am connected to the internet.
    Try the ping tests:

    1. Start Orb > type "cmd" in search box > DOS screen appears.

    2. Ping the network controller in your computer, type "ping 127.0.0.1"
    --- You should see 4 replies.

    3. Ping your router. Type "ping xxx.xxx.x.x"
    192.168.2.1 = Belkin & SMC
    192.168.0.1 = D-Link & Netgear
    192.168.1.1 = Linksys

    4. Ping yahoo.com. Type "ping www.yahoo.com"

    What happens?

      My System SpecsSystem Spec

  6. #5



    Newbie
    Join Date : Jul 2009
    Posts : 8
    Vista Home Premium x64
    Local Time: 10:13 AM


      Thread Starter

    Re: Cannot access internet even though connected

    Ping function works. While waiting for replies, I searched for more info on connectivity issues with Vista after SP2. There are a few responses listed on various boards with suggestions related to Vista SP2 Windows Scaling for TCP not compatible with certain routers. Any thoughts?

      My System SpecsSystem Spec

  7. #6



    Member
    Join Date : May 2009
    Posts : 124
    Vista Home Premium 64bit
    Local Time: 09:13 AM


     

    Re: Cannot access internet even though connected

    Quote Originally Posted by JeremyT View Post
    Ping function works. While waiting for replies, I searched for more info on connectivity issues with Vista after SP2. There are a few responses listed on various boards with suggestions related to Vista SP2 Windows Scaling for TCP not compatible with certain routers. Any thoughts?
    I invite others to chime in. Am not familiar with the Data Execution message.

    I assume the browsers are loading and opening up OK. Exactly what happens then? Info might allow others to help.

    BTW, which anti-virus software and firewall are you running? At this point, I would set the default home page in a browser to a trusted web site like microsoft.com, close the browser, disable anti-virus and firewall and then open the browser to try a quick connection to see if my anti-virus or firewall is the culprit. Then run a full anti-virus scan of my computer afterwards to see if anything was infected. I would leave the router out of the picture until I was able to successfully connect to the internet.

    Hope others will chime in,
    Sky

      My System SpecsSystem Spec


Cannot access internet even though connected
Similar Threads
Thread Forum
Messenger syas i have no internet connection when im connected to the internet. Live Messenger
Access HDD when connected to another PC? Vista General
It says my internet is connected but when I open Internet Explorer it doesn't work! Browsers & Mail
Vista says I'm not connected to the Internet while I am connected Vista networking & sharing
Windows Mobile device can't access Internet when connected to Vist Vista hardware & devices