Windows Vista Forums

Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

  1. #1


    Join Date : Jun 2008
    India
    Posts : 25
    Vista Ultimate SP1
    Local Time: 10:15
    india

    Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    Hi all,

    i have updated my system to ultimate x64 sp1.

    now in device manager, i found one unknown device(which is shown in Other Devices in Device manager), i tried most of drivers for it.

    but not able to get it. i even do not know what device it is.

    Please refer attached images.

    -screen1-jpg

    -screen2-jpg

    thanks,
    krunal

      My System SpecsSystem Spec

  2. #2
    johngalt's Avatar

    Join Date : May 2008
    3rd Rock
    Posts : 3,847
    Windows 7 Ultimate x64
    Local Time: 12:15
    usa us georgia

     

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    DId you *upgrade* from 32bit to 64bit?

      My System SpecsSystem Spec

  3. #3


    Join Date : Jun 2008
    India
    Posts : 25
    Vista Ultimate SP1
    Local Time: 10:15
    india

      Thread Starter

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    nope,

    i have installed 64bit.

    krunal

      My System SpecsSystem Spec

  4. #4
    johngalt's Avatar

    Join Date : May 2008
    3rd Rock
    Posts : 3,847
    Windows 7 Ultimate x64
    Local Time: 12:15
    usa us georgia

     

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    According to what the second one looks like (and this is the really weird part0 it looks like you have installed Virtual PC 2004....which is not Vista compatible.

    You need Virtual PC2007....

    But I suspect that is not the case either - so I suggest you make sure you have *all* drivers for your hardware installed, motherboard, chipset, etc....

      My System SpecsSystem Spec

  5. #5


    Join Date : Jun 2008
    India
    Posts : 25
    Vista Ultimate SP1
    Local Time: 10:15
    india

      Thread Starter

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    i tried all drivers from lenovo driver cd. but it may be possible that some drivers are not for 64. so thats y some problem

    and one thing i havnt using virtual pc. i have fresh installed vista ultimate x64.

    thanks,
    krunal

      My System SpecsSystem Spec

  6. #6
    johngalt's Avatar

    Join Date : May 2008
    3rd Rock
    Posts : 3,847
    Windows 7 Ultimate x64
    Local Time: 12:15
    usa us georgia

     

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    That is what I thought - and that is the problem with taking an OEM machine and upgrading it to x64 or downgrading it to XP - you have to make sure all your drivers are available *before* upgrading.

    But, have you contacted Lenovo, since *they* are the ones that made it?

      My System SpecsSystem Spec

  7. #7


    Join Date : Jun 2008
    India
    Posts : 25
    Vista Ultimate SP1
    Local Time: 10:15
    india

      Thread Starter

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    Yes, i go thru the support site, for latest drivers and softwares. but it seems that they providing it for 32 vista only.

    so i have to try other drivers for 64.

    thanks,
    krunal

      My System SpecsSystem Spec

  8. #8
    johngalt's Avatar

    Join Date : May 2008
    3rd Rock
    Posts : 3,847
    Windows 7 Ultimate x64
    Local Time: 12:15
    usa us georgia

     

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    Well, you have to *identify* what the 'device' is before you can use a driver....

      My System SpecsSystem Spec

  9. #9


    Join Date : Jun 2008
    India
    Posts : 25
    Vista Ultimate SP1
    Local Time: 10:15
    india

      Thread Starter

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    hmmmm, i have done driver scan from driveragent site. and it shows lots of new drivers available for my system and download is not free .. sad.

    krunal

      My System SpecsSystem Spec

  10. #10
    johngalt's Avatar

    Join Date : May 2008
    3rd Rock
    Posts : 3,847
    Windows 7 Ultimate x64
    Local Time: 12:15
    usa us georgia

     

    Re: Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

    Like I said = you need to go to the Lenovo site. If there are no new drivers there then start looking up your motherboard manufacturer and see if there are BIOS updates, drivers etc for Windows Vista 64bit.

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
Unknown Device on Microsoft ACPI Compliant Embedded Controller?!?!

Similar Threads
Thread Forum
Unknown Device (Related to ACPI)
I have windows vista x64 installed. My system is an AMD 64 X2 6000+, ASUS M2A - VM motherboard. I cannot figure out what device is unknown. Can...
Drivers
ACPI embedded controller Failed to respond
I get the Red error {listed below}in the Event V when the computer is in a True Sleep mode. It does not happen in Hibernation or in any other...
Vista performance & maintenance
110 IRQs assigned to "Microsoft ACPI-compliant system"
In trying to get Quake Wars to work on my computer with Windows Vista Home Premium, the tech support guy requested my sysinfo file. He didn't help...
Vista hardware & devices
Microsoft ACPI-Compliant System
Hi all, I've just installed Vista Ultimate on my PC. Everything seems to install fine, except that when I look in Device Manager there is an...
Vista General
ACPI\PNPB02F Unknown device issue solution
I have spent way too much time trying to solve the very annoying ACPI\PNPB02F Unknown device issue which asks me to scan the computer for a...
Vista hardware & devices
ACPI\PNPB02F Unknown device issue solved!!!!
I have spent way too much time trying to solve the very annoying ACPI\PNPB02F Unknown device issue which asks me to scan the computer for a...
Vista General
ACPI\PNPB02F Unknown device
I have spent a lot of time (too much) trying to solve the very annoying ACPI\PNPB02F Unknown device issue which asks me to scan the computer for a...
Vista General