Windows Vista Forums

AHCI drivers for Vista x64 ultimate

  1. #1


    Join Date : Aug 2008
    Posts : 5
    XP PRO, Vista Ultimate x64, TIGER, Leopard
    Local Time: 11:54

    AHCI drivers for Vista x64 ultimate

    Hi all,
    I run hackintosh so I need to set the SATA to AHCI.
    I installed XP PRO with no problem using the F6 Floppy drivers.

    after that I installed vista x32 with the drivers from intel's web site with no problem.

    Now I wanted to move and install a fresh copy of VISTA ULT x64bit

    but I can't install the proper driver for it.

    I dloaded the 64-bit Floppy Configuration Utility for Intel® Matrix Storage Manager (227KB) 8.2.0.100

    Copied the driver to USB disk.

    but when I tried to "LOAD DRIVER" during VISTA's install I loaded the ICH9 driver
    After that I got the message "NO DRIVES WERE FOUND"

    WTF?

    Why am I having trouble installing the x64 version?
    can anyone direct me to a proper driver for 82801IR controller - vista x64 driver!

    damn!

    BTW I did manage to install this Vista x64 in IDE mode...
    HELP!

      My System SpecsSystem Spec

  2. #2


    Join Date : Jan 2008
    Where it always stinks when an East wind is blowing
    Posts : 329
    Vista X64 Ultimate
    Local Time: 04:54


     

    Re: AHCI drivers for Vista x64 ultimate

    Just follow the instructions on the Microsoft Knowledge Base page below. They will tell you to enable AHCI via a registry edit, then you reboot and turn on AHCI mode in the bios for your motherboard. I've done it this way many times and it works.

    Error message when you start a Windows Vista-based computer after you change the SATA mode of the boot drive: "STOP 0x0000007B INACCESSABLE_BOOT_DEVICE"

      My System SpecsSystem Spec

  3. #3


    Join Date : Aug 2008
    Posts : 5
    XP PRO, Vista Ultimate x64, TIGER, Leopard
    Local Time: 11:54


      Thread Starter

    Re: AHCI drivers for Vista x64 ultimate

    First thing, thanks for the quick replay.

    I Guess I can install Vista x64 this way - but Isn't there a simple way to just load the proper AHCI driver during install (like I did in XP and Vista 32)?

    I mean, its really awkward, to install in IDE mode - only to change it to AHCI after that.

    Even more important - say I do have it your way - will my system be stable?
    Will it affect the stability or performance?

    Thanks!




    Quote Originally Posted by WildEagle View Post
    Just follow the instructions on the Microsoft Knowledge Base page below. They will tell you to enable AHCI via a registry edit, then you reboot and turn on AHCI mode in the bios for your motherboard. I've done it this way many times and it works.

    Error message when you start a Windows Vista-based computer after you change the SATA mode of the boot drive: "STOP 0x0000007B INACCESSABLE_BOOT_DEVICE"

      My System SpecsSystem Spec

  4. #4


    Join Date : Jan 2008
    Where it always stinks when an East wind is blowing
    Posts : 329
    Vista X64 Ultimate
    Local Time: 04:54


     

    Re: AHCI drivers for Vista x64 ultimate

    You should be able to press F6 on your keyboard, and then it should ask you to install the driver, but make sure you have AHCI mode enabled in the bios, when you attempt this, as Microsoft will first install a generic AHCI driver.

      My System SpecsSystem Spec

  5. #5


    Join Date : Aug 2008
    Posts : 5
    XP PRO, Vista Ultimate x64, TIGER, Leopard
    Local Time: 11:54


      Thread Starter

    Re: AHCI drivers for Vista x64 ultimate

    I'm feeling stupid.

    I gave up trying to load a AHCI driver during install.

    So I said to myself lets try something else.

    I just installed Vista x64 ult. sp1 in AHCI mode. without loading any driver.

    Windows installed itself with no problem!

    after the install I got the messsage "competability ICH9 issue" and a window popped to download the latest intel chipset driver.

    I installed it - no prblm.

    everything works great!
    in AHCI mode.

    Didn't need to load any driver at setup!

    Thanks but I guess problem solved...!

      My System SpecsSystem Spec

  6. #6


    Join Date : Jan 2008
    Where it always stinks when an East wind is blowing
    Posts : 329
    Vista X64 Ultimate
    Local Time: 04:54


     

    Re: AHCI drivers for Vista x64 ultimate

    You're welcome. It's good to see you got AHCI working, but for some reason my soundcard does not get along with AHCI.

      My System SpecsSystem Spec

  7. #7


    Join Date : Aug 2008
    Posts : 5
    XP PRO, Vista Ultimate x64, TIGER, Leopard
    Local Time: 11:54


      Thread Starter

    Re: AHCI drivers for Vista x64 ultimate

    Quote Originally Posted by WildEagle View Post
    You're welcome. It's good to see you got AHCI working, but for some reason my soundcard does not get along with AHCI.
    Weird, do you run the latest sound drivers?

    is it on board?
    which board?
    I don't see any connection between AHCI and Sound
    Are you sure its an AHCI problem?!

      My System SpecsSystem Spec

  8. #8


    Join Date : Jan 2008
    Where it always stinks when an East wind is blowing
    Posts : 329
    Vista X64 Ultimate
    Local Time: 04:54


     

    Re: AHCI drivers for Vista x64 ultimate

    It happens with both my HT Omega Claro or the onboard IDT 9247 7.1HD codec.

    When running AHCI the sound stutters. I expierenced this on two ATI/ULI motherboards a couple of years ago, and it happens with AHCI on my board now.

    I'm running the latest drivers, which is why I suspect the AHCI drivers are at fault. I have no problems when in IDE mode.

      My System SpecsSystem Spec

  9. #9


    Join Date : Aug 2008
    Posts : 5
    XP PRO, Vista Ultimate x64, TIGER, Leopard
    Local Time: 11:54


      Thread Starter

    Re: AHCI drivers for Vista x64 ultimate

    Sorry can't help you there..

      My System SpecsSystem Spec

  10. #10
    johngalt's Avatar

    Join Date : May 2008
    3rd Rock
    Posts : 3,847
    Windows 7 Ultimate x64
    Local Time: 05:54
    usa us georgia

     

    Re: AHCI drivers for Vista x64 ultimate

    Wild - according to Advanced Host Controller Interface - Wikipedia, the free encyclopedia, AHCI offers hot plugging and native command queuing - do you use either of those? If not, you might consider moving back to IDE permanently....that wiki also has some other good info that might be relevant.

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast
AHCI drivers for Vista x64 ultimate

Similar Threads
Thread Forum
Vostro 1000 Vista Ultimate 64 bit Drivers
Hi everyone, I just installed Vista Ultimate 64 bit on my Vostro 1000 and was wondering if anyone knew where 64 it drivers were. It runs great, but...
Drivers
Vista Ultimate 64 bit & Canon Camera Drivers???
Hi again guys. As i am in the process of setting up my new rig, have any of you had any experience or issues involving Canon drivers for digital EOS...
Drivers
SB600 AHCI Drivers
Ok, so I've been trying to install the latest SB600 drivers on my Vista Ultimate 64 system with no luck. If I turn on AHCI I get a BSOD. I know...
Drivers
Issue with Nvidia drivers and Vista Ultimate x64
Good morning everyone, I set up Vista 64-bit on a new drive (dual-booting with XP) on my main gaming pc last night. After it installed, it...
Drivers
Vista Ultimate 64 bit and DVD drivers
I am on my 2nd DVD burner that Vista says it can't recognize because it doesn't have the drivers and this one was billed as being Vista compliant....
Vista hardware & devices
Vista Ultimate: Unable to Locate Drivers
Windows Vista Ultimate: Activated, Installed latest updates: None pending..... I am unable to get my pc to recognize anyhardware that I'm...
Vista installation & setup
Drivers for Vista 64-bit Ultimate
I am having trouble with my audio driver. The names as they appear on the vista scan are "ATI SMBus (by ATI Technologies)" and " AC97 Soft Data Fax...
Vista hardware & devices