Windows Vista Forums

No drivers detected Vista Home Premium Install :l

  1. #1


    Join Date : Jan 2010
    Posts : 2
    Vista Home Premium 32bit
    Local Time: 11:48

    No drivers detected Vista Home Premium Install :l

    I'm trying to reinstall Windows Vista after a bunch of issues I've had with my PC.
    I am reinstalling vista but after booting from DVD Vista does not recognise my hard disk on the "Where do you want to install Windows?" screen.
    It gives me the option to load new drivers but I have no idea how to do that.
    I live to far out too to get any computer experts to help :/
    So I guess what I'm basicly asking for is how to get the drivers on my computer so vista can read them and install... (and also how to install the drivers on my computer)
    Please help, I've been getting very frustrated with my computer just trying to get it past the booting screen, and then this problem came up...

      My System SpecsSystem Spec

  2. #2


    Join Date : Dec 2009
    FLORIDA
    Posts : 197
    Windows Seven Home Premium x64
    Local Time: 15:48
    usa us florida

     

    Re: No drivers detected Vista Home Premium Install :l

    Is your hard-drive detected in BIOS? Has your computer been freezing/slowing down? Any error messages? What kind of problems?

    You shoud not have to load drivers for HDD.. A HDD uses a generic storage/AHCI/SATA Driver.

      My System SpecsSystem Spec

  3. #3
    theog's Avatar

    Join Date : Aug 2009
    uk Hampshire
    Posts : 642
    vista home premium 32bit
    Local Time: 20:48
    uk

     

    Re: No drivers detected Vista Home Premium Install :l

    Hi

    You would need download the drivers for your SATA controller.

      My System SpecsSystem Spec

  4. #4


    Join Date : Jan 2010
    Posts : 2
    Vista Home Premium 32bit
    Local Time: 11:48


      Thread Starter

    Re: No drivers detected Vista Home Premium Install :l

    I fixed the problem now thankfully (not at all sure what the heck I did...)
    but I just started pluging in cables, re-pluging others, and even wacking the case.. (lol I know bad idea) and all of a sudden it started up when I tried again.
    But thanks so much for the suggestions, normaly on other forms I have to wait weeks for someone to actually help me out... But you guys here reply so fast, and seem very kind and helpfull, thanks

    *edit* I just got a flash light and check on the inside of my Computer and looked at the cabels I re-plugged in. It turns out that they were something called SATA cables, and I plugged em into my hard-drive and it fixed the problem. *palm to face*

      My System SpecsSystem Spec

No drivers detected Vista Home Premium Install :l

Similar Threads
Thread Forum
where are device drivers stored in Vista Home Premium
Hi, I need to reformat my hard drive due to a virus. I have a 'System Backup CD' (made after purchasing and setting up the Computer). I have...
Drivers
Re: Vista Home Premium Install Hangs At Completing. (Clean Install)
I borrowed this fix from another posting and it worked for me! I tried for 3 days to fix this issue until I found this. I was using a Dell...
Vista installation & setup
Sound device not detected on vista 64 home premium
Hello, I've just setup a new computer with vista but after installing, vista didn't detect any sound device. I have an Asus Rampage II extreme...
Sound & Audio
How Can I Back Up My Drivers in Vista Home Premium
Must I upgrade to Ultimate, or is there a way to back up my drivers? Thanks, deirdre
Vista installation & setup
Best ATI drivers for agp and vista home premium
Hello folks, Looking for the best overall ATI drivers for Vista Premium and a 1950 agp card. I'm having issues with the refresh defaulting back...
Graphic cards
Scanner Drivers not loading in Vista Home Premium
I have a Lexmark 4300 Allinone and a Canon N1240U scanner. I have downloaded the Vista drivers for both devices but when Vista tries to install the...
Vista print fax & scan
Can't Install Vista Home premium upgrade - "can't install a file and quits
After about 20 minutes of installation time, all of a sudden I get a message that a file cannot be copied/installed (NO mention of file) and...
Vista installation & setup