Windows Vista Forums

Age of Empires 3 Won't Work

  1. #1
    yarow12's Avatar

    Member
    Join Date : Dec 2008
    Posts : 38
    Vista Home Premium 64bit SP 2
    Local Time: 02:25 AM

    Age of Empires 3 Won't Work

    Now, now. I did read a few threads on the site hoping to get some answers, but I got nothing. No matter what I do, it won't work. >.<
    I have Vista 64bit SP1, and I installed the 1.12 patch (restarted as well)--but I still can't play AoE3. A Microsoft Windows pops-up saying, "Protection Stub has stopped working."
    What do I do? How do I get it to work? Age of Empires 2 works, why doesn't this one? o.O QUESTIONS!!!!!!!!! XD

      My System SpecsSystem Spec

  2.   


  3. #2



    Junior Member
    Join Date : Sep 2008
    Posts : 11
    vista home premium 32bit
    Local Time: 09:25 AM


     

    Re: Age of Empires 3 Won't Work

    Hi yarow12
    have u tryied the google way..? :P
    [try the solution here and let us know if that make any difference for you.
    i've also found the same problem in another thread, here on the same forum.
    many times the search button helps you more than opening a new thread.
    excuse me for my bad english.
    goodbye

      My System SpecsSystem Spec

  4. #3
    yarow12's Avatar

    Member
    Join Date : Dec 2008
    Posts : 38
    Vista Home Premium 64bit SP 2
    Local Time: 02:25 AM


      Thread Starter

    Re: Age of Empires 3 Won't Work

    Thank you!!!

      My System SpecsSystem Spec


Age of Empires 3 Won't Work
Similar Threads
Thread Forum
Age of Empires 3 Vista Games
age of empires 2 Vista Games
Age of Empires Vista Games
Age of Empires 2, the conquerors expansion stop to work randomly Vista Games
Age of empires 2 Vista Games