Windows Vista Forums

Age of Empires 3 not Installing

  1. #1



    Junior Member
    Join Date : Mar 2009
    Posts : 10
    Windows Vista x64 Ultimate
    Local Time: 12:54 PM

    Age of Empires 3 not Installing

    I have read through 100 posts on forums and such about this problem, none seem to pertain to me or solve the issue. I have Windows Vista x64 Ultimate, and when I try to install AOE...here is what happens...

    Put in disk and autorun, it loads the program and gives me the option to install, I click install and nothing happens, just sits there and freezes, I have to then use the task manager to close out of the program. I have also tried to explore the disk and installw ith the setup, same thing, freezes when i click explore. I am logged in under the Admin, also have the USER CONTROL off already, anyone have any ideas? I can install other games on here, and AOE works on my home computer with XP.

      My System SpecsSystem Spec

  2.   


  3. #2
    lordbob75's Avatar

    Lord of Bobs


    Join Date : Dec 2008
    In my Fortress
    Posts : 1,676
    Windows 7 x64 build 7100 & Ubuntu 9.04
    Local Time: 11:54 AM
    usa

     

    Re: Age of Empires 3 not Installing

    Hello Snake,

    Try running the setup off the disk in XP compatibility mode as an Admin.

    ~Lordbob

      My System SpecsSystem Spec

  4. #3



    Junior Member
    Join Date : Mar 2009
    Posts : 10
    Windows Vista x64 Ultimate
    Local Time: 12:54 PM


      Thread Starter

    Re: Age of Empires 3 not Installing

    How do I do that?

      My System SpecsSystem Spec

  5. #4
    smarteyeball's Avatar

    Eye know, eye know


    Join Date : Oct 2007
    Australia
    Posts : 1,874
    7 Ultimate x64 : Vista x86 VM :W8 RP x64
    Local Time: 04:54 AM
    australia au queensland

     

    Re: Age of Empires 3 not Installing

    Right-click on the setup.exe(whatever it's named)>select properties and it's under the Compatibility tab.

    If it fails to install from the disc, you could always try copy the disc to hard drive and running the setup from there as a last resort.

      My System SpecsSystem Spec

  6. #5



    Junior Member
    Join Date : Mar 2009
    Posts : 10
    Windows Vista x64 Ultimate
    Local Time: 12:54 PM


      Thread Starter

    Re: Age of Empires 3 not Installing

    SO I tried that, TOOOK at least 60 mins to explore the disk, and no luck, can't get anywhere, just sits there like its going to freeze, then it just stops and continues working like I didn't click anything. when I try to install or explore the disk, its soooo slow, never had a problem with a game. I know AOE3 is quite the game when it comes to using up the PC and it's parts, but whats the deal, you would think a Windows game wouldn't have this much trouble, Windows Vista even lists it as a compatible game for the WIndows x63 bit system!

      My System SpecsSystem Spec

  7. #6
    lordbob75's Avatar

    Lord of Bobs


    Join Date : Dec 2008
    In my Fortress
    Posts : 1,676
    Windows 7 x64 build 7100 & Ubuntu 9.04
    Local Time: 11:54 AM
    usa

     

    Re: Age of Empires 3 not Installing

    Quote Originally Posted by LiquidSnake View Post
    WIndows x63 bit system!
    Wha.....???

    I am assuming you meant 64bit....

    I don't know why that would not have worked........

    Hmmm.... *wracks brain*

    ~Lordbob

      My System SpecsSystem Spec

  8. #7



    Junior Member
    Join Date : Mar 2009
    Posts : 10
    Windows Vista x64 Ultimate
    Local Time: 12:54 PM


      Thread Starter

    Re: Age of Empires 3 not Installing

    Yes, 64 Bit Sorry about that! Well shucks, doesnt' seem like anyone can help me.

      My System SpecsSystem Spec

  9. #8
    lordbob75's Avatar

    Lord of Bobs


    Join Date : Dec 2008
    In my Fortress
    Posts : 1,676
    Windows 7 x64 build 7100 & Ubuntu 9.04
    Local Time: 11:54 AM
    usa

     

    Re: Age of Empires 3 not Installing

    Is this the only game that does that? Can you install other things?
    Can you try it in a different drive?

    ~Lordbob

      My System SpecsSystem Spec

  10. #9



    Junior Member
    Join Date : Mar 2009
    Posts : 10
    Windows Vista x64 Ultimate
    Local Time: 12:54 PM


      Thread Starter

    Re: Age of Empires 3 not Installing

    Yes, only game that does that, I am able to install other games, software, downloads, tried both drives, same result!

      My System SpecsSystem Spec

  11. #10
    lordbob75's Avatar

    Lord of Bobs


    Join Date : Dec 2008
    In my Fortress
    Posts : 1,676
    Windows 7 x64 build 7100 & Ubuntu 9.04
    Local Time: 11:54 AM
    usa

     

    Re: Age of Empires 3 not Installing

    Then this sounds more like a bad disk. Can you try another one?

    ~Lordbob

      My System SpecsSystem Spec

Page 1 of 3 123 LastLast

Age of Empires 3 not Installing
Similar Threads
Thread Forum
age of empires 2 Vista Games
Age of Empires Vista Games
Age of Empires Vista Games
Age of Empires Vista Games
Re: age of empires 3 Vista Games