Windows Vista Forums

Problems installing upgrades

  1. #1



    Newbie
    Join Date : Sep 2009
    Posts : 6
    currently running xp but end users have vista
    Local Time: 11:48 AM

    Problems installing upgrades

    We are having trouble installing new versions of our application on Vista machines. We have tried to install the new version over the old version but for some reason Vista wants to use the old version that it has somewhere. We have tried looking into what happens with the Shadow Copy feature and it appears that this is what is causing the problem. We have even put the new version into a different folder and pointing the shortcut there but again Shadow Copy wants to take over. The workaround that we found was to disable the Restore feature, delete the old app from the Recylce bin, enable the Restore feature and then install the new version of the app. The problems that we have with this is that, as developers we do not have Administrator privileges and we have over 1000 machines that we have to push the MSI file to. If the machine has never had the application we have no problems. Also, we have two sites that have the app on a server and we have no problems there. It is only when we try to push the app to the client machines that have an existing copy of the app.

    Does anyone have any suggestions on how to resolve this issue?

    Thank you.

      My System SpecsSystem Spec

  2.   


  3. #2



    Banned
    Join Date : Jun 2009
    NY USA
    Posts : 2,456
    Vista 32 win 7 7600 32 bit
    Local Time: 12:48 PM
    micronesia au victoria 2

     

    Re: Problems installing upgrades

    Larry

    Ouch. what is different about this site. is there diferent group security policies, or maybe a different vista sp? if it works on the other site, but not on this one the difference is what is preventing you from installing it here.

    Can you set up a "trusted installer" group with some of the admins rights? I know this is not the time to be messing with rights but you have 1000 machines to push.

    could you tell me a bit more info about the set up

    ken

      My System SpecsSystem Spec

  4. #3



    Newbie
    Join Date : Sep 2009
    Posts : 6
    currently running xp but end users have vista
    Local Time: 11:48 AM


      Thread Starter

    Re: Problems installing upgrades

    Ken:

    Let me make a couple of clarifications. We have a total of 4 sites that we run this app at. One of them runs the app on a Citrix server and they have no problems at all. Another site runs the app on an NT 2003 server and there we have some (not all) users that for some reason the Shadow Copy of the previous version is being run off of their pc rather than the new version off of the server. The other two sites have the app pushed to the pcs via an MSI file. We have the admin rights to push the app to them but when the users try to access the shortcut for the new version the Shadow Copy for the old version gets ran instead of the new copy.

      My System SpecsSystem Spec

  5. #4
    lemur's Avatar

    Senior Member

    Join Date : Aug 2009
    University of Kentucky
    Posts : 1,533
    Windows Vista Enterprise x64 SP2
    Local Time: 11:48 AM
    usa us kentucky

     

    Re: Problems installing upgrades

    Is this a problem that only presents itself when you push the upgrade? If you installed locally there would be no problem?

      My System SpecsSystem Spec

  6. #5



    Newbie
    Join Date : Sep 2009
    Posts : 6
    currently running xp but end users have vista
    Local Time: 11:48 AM


      Thread Starter

    Re: Problems installing upgrades

    Lemur:

    In answer to your question; no, we still have problems with the app. If the vista machine has never had the app it will install and run just fine. but, if there is an old version of the app already on the vista machine then that is the version that is run.

    I am just wondering how do upgrades get done on other software apps? For instance, whenever Acrobat comes out with a new upgrade it seems like there is no problem doing the upgrade. I haven't looked but doesn't the .exe file and all other files, etc. remain the same and are put into the existing directory?

    What we try to do is remove the old version, files, icon. etc. and then push the new version to the same place. But, that just doesn't seem to be the case.

    Thanks.

      My System SpecsSystem Spec

  7. #6
    lemur's Avatar

    Senior Member

    Join Date : Aug 2009
    University of Kentucky
    Posts : 1,533
    Windows Vista Enterprise x64 SP2
    Local Time: 11:48 AM
    usa us kentucky

     

    Re: Problems installing upgrades

    Where is the file stored? Is Volume Shadow Snapshot Service configuredon that location?

    Does the client show up as installed in add/remove programs?

      My System SpecsSystem Spec

  8. #7



    Newbie
    Join Date : Sep 2009
    Posts : 6
    currently running xp but end users have vista
    Local Time: 11:48 AM


      Thread Starter

    Re: Problems installing upgrades

    Lemur:

    Question 1: The files are stored in Program Data on the C: drive.

    Question 2: How do we know if Volume Shadow Snapshot Service configuredon that location? Where would we be able to find that out?

    Question 3: Yes. The client does show up in the Add/Remove programs.

    Thank you.

      My System SpecsSystem Spec

  9. #8
    lemur's Avatar

    Senior Member

    Join Date : Aug 2009
    University of Kentucky
    Posts : 1,533
    Windows Vista Enterprise x64 SP2
    Local Time: 11:48 AM
    usa us kentucky

     

    Re: Problems installing upgrades

      My System SpecsSystem Spec

  10. #9



    Newbie
    Join Date : Sep 2009
    Posts : 6
    currently running xp but end users have vista
    Local Time: 11:48 AM


      Thread Starter

    Re: Problems installing upgrades

    Lemur:

    Yes, we have looked at one of the test machines and Shadow Copy is configuredon for that location.

    That's the problem. We don't want it configured on because Vista keeps wanting to run the old version of the app.

    Is there some way that it can be turned off programmatically when we do the push? Do the install then turn it back on? As stated in my earlier post, we have over 1000 users at one location and there is no way that we can turn each one off manually.

    Thanks

      My System SpecsSystem Spec

  11. #10
    lemur's Avatar

    Senior Member

    Join Date : Aug 2009
    University of Kentucky
    Posts : 1,533
    Windows Vista Enterprise x64 SP2
    Local Time: 11:48 AM
    usa us kentucky

     

    Re: Problems installing upgrades

    I'm trying, I'm trying... lol. Okay, so you are using SMS client push. Any thought to using logon script or group policy?

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast

Problems installing upgrades
Similar Threads
Thread Forum
Installing upgrades repeatedly on startup Vista General
After Vista upgrades : Display adapter problems can not use DVD Ma Vista hardware & devices
Hardware upgrades after installing Vista Vista General
Vista Ulimate upgrades problems Vista General
there is NO upgrade path from XP. No upgrades. No upgrades???? Vista General