Windows Vista Forums

WD My Book stops being recognized

  1. #1


    Join Date : Jan 2010
    Posts : 2
    Vista Home Premium x64
    Local Time: 12:17

    WD My Book stops being recognized

    I just bought a WD My Book Home 1tb about 3 months ago, and I recently started having this peculiar issue with it. I can't "safely remove" as it says a program is using it (I have no idea what) and if I just unplug it, it isn't recognized under My Computer when I plug it back in. I tried using the eSATA connection on it, and I'm assuming it went to sleep or something and isn't accessible. I tried using USB again, on two different ports, and as per something someone said on another site, tried plugging into different outlets, all to no avail. It is listed under device manager as "working" but I can't access it. The only solution I have found is to reboot my computer, but that is quickly growing very annoying. If I plug into my friend's Vista PC (32bit I think) however, it works fine. Can anybody help me out with this?

      My System SpecsSystem Spec

  2. #2
    richc46's Avatar



    Join Date : Dec 2008
    Fairfield County, CT
    Posts : 20,036
    Windows 7 SP1 x64
    Local Time: 14:17
    usa us connecticut

     

    Re: WD My Book stops being recognized

    When you have the problem try bringing up the task manager. alt+cntrl+delete and see whats running. Stop each process, one at a time, and see what is stopping the removal.

      My System SpecsSystem Spec

  3. #3
    patio's Avatar
    Join Date : Nov 2008
    Posts : 403
    Vista Ultimate 64bit
    Local Time: 14:17


     

    Re: WD My Book stops being recognized

    Did you use the MyBook software with this drive ? ?
    It's known to have issues...

      My System SpecsSystem Spec

  4. #4
    whs's Avatar



    Join Date : May 2008
    Germany/Florida
    Posts : 2,026
    Vista home premium 32bit
    Local Time: 20:17
    germany us florida

     
      My System SpecsSystem Spec

  5. #5


    Join Date : Jan 2010
    Posts : 2
    Vista Home Premium x64
    Local Time: 12:17


      Thread Starter

    Re: WD My Book stops being recognized

    Quote Originally Posted by patio View Post
    Did you use the MyBook software with this drive ? ?
    It's known to have issues...
    When I got the drive, it was stupidly formatted in FAT32 some reason, so I reformatted to NTFS right away, and it worked fine for a while, it's just the past week or two it's done this.

      My System SpecsSystem Spec

WD My Book stops being recognized

Similar Threads
Thread Forum
Not all RAM recognized
My computer came with 2 1GB DDR2 RAM. About 6 months ago, I installed another 2 2GB DDR2 RAM making 6GB total. At that time, the computer...
General Discussion
DVD Not Recognized
OS Vista Ultimate x32 SP2 DVD Samsung SH-S183L I placed a DVD in the tray to do a backup. The spindle spins for 5 seconds and stops. The...
Vista General
Addess Book - the word "contact" after each person in address book
I imported my address book from hotmail. after each person in the Name Column, it shows their name eg "John Smith.contact"...any suggestions on how...
Vista mail
WLM Address book vs Windows address book
I recently realized that WLM has a completely different copy of address book entries than windows address book. Is there a way to merge them? \ ...
Live Mail
DVD-RW recognized as CD
I run a Windows XP with a DVD-RW and all of a sudden its being recognized as a CD drive for no apparent reason. Help?
Vista hardware & devices
cd/dvd not recognized
I have an Acer 5100. I have only used the dvd drive once and it worked fine. When i tried to use it again it would not open any CD or DVD I tried....
Vista hardware & devices
CDs sometimes not recognized
I am running Windows Vista Business on a new Dell XPS laptop. Sometimes (frequently) it does not recognize a CD I place in the DVD/ CD drive. In...
Vista General