Hello all,

I hope that someone here might of either seen this before or knows what the cause of it is.

I was recently given a "broken" laptop and when looking at it, it only had a busted hard disk. I have replaced the hard disk so only then needed to install Windows. The laptop has a Vista Business OEM sticker on it but i didn't have the media for it. After doing some research online i found a Vista OEM disk from a company called digital river (i believe to be a microsoft partner). The disk has Vista home, home premium, business and ultimate 32bit onit but you obviously need the OEM license for it to be of any use. After downloading the ISO file and burning it to a disk i tried booting off of it on the laptop to install disk but got a message saying something like disk error replace and press anykey to continue. I have made sure that the disk drive was set first in the boot order and that the BIOS has the Drive enabled. I then went and put the disk into the family Dell Vostro machine and tried booting from the disk and this worked fine. I got to the screen asking which language to install Vista as. I have also tried this disk in a friends Acer laptop and a leptop from work and all boot from the disk no issue so im sure the disk is fine. I had a Dell Vista Business 32Bit disk lying around so i then thought i might as well try it in the HP laptop that needs windows installing and this booted fine, so i have installed Vista on the laptop that way and it has all activated fine etc. Other bootable disks work fine on the HP as well like Ultimate Boot CD and Memtest so im sure the drive in the laptop isn't faulty as well. I was just wondering if anyone would know why the laptop will not boot from this disk as if i didn't have the Dell disk i would of been in a bit of a pickle.

Many thanks in advance.