Windows Vista Forums

Vista Doesn't Recognize My LAN connection

  1. #1


    Join Date : Dec 2008
    Posts : 3
    Vista Ultimate x64
    Local Time: 06:06 PM

    Vista Doesn't Recognize My LAN connection

    I recently built a second PC for myself, and decided to try out Vista on it. It installed flawlessly, but there's one problem. Vista does not seem to be recognizing my LAN connection. I tried hard-wiring it from my modem, to my router, to the Ethernet port on the back of my computer with no success. From there, I tried plugging it straight from my modem to the port on the back of the computer. No success there either. I know that it's not a problem with the motherboard because I installed this program that came with the mobo called 'Expressgate'; and when I run that before my computer loads the OS, the internet works perfectly.

    Any help / suggestions would be greatly appreciated!

    Thanks in advance,

    Rob


    Edit: Forgot to say that my other computers (including the one I'm currently posting on), which are XP, are able to connect via an Ethernet cable or wireless adapter.

      My System SpecsSystem Spec

  2. #2
    Brian the King's Avatar
    Join Date : May 2008
    Posts : 116
    Windows Vista Home Premium x64 SP2
    Local Time: 06:06 PM
    usa

     

    Re: Vista Doesn't Recognize My LAN connection

    Check the Device Manager and make sure your NIC is installed correctly; there should be no yellow or red exclamation marks, or 'unknowns devices'.




      My System SpecsSystem Spec

  3. #3


    Join Date : Dec 2008
    Posts : 3
    Vista Ultimate x64
    Local Time: 06:06 PM


      Thread Starter

    Re: Vista Doesn't Recognize My LAN connection

    Brian, thanks for your quick response!

    I currently have no 'Network Adapters' section of my Device Manager. There is a section called 'Other Devices' that has Ethernet Controller under it. The Ethernet Controller has a yellow exclamation point next to it, however.

      My System SpecsSystem Spec

  4. #4
    Brian the King's Avatar
    Join Date : May 2008
    Posts : 116
    Windows Vista Home Premium x64 SP2
    Local Time: 06:06 PM
    usa

     

    Re: Vista Doesn't Recognize My LAN connection

    There lies your problem Rob. You will have to identify exactly what kind of adapter you have in your computer, and download and install appropriate drivers for it.

    If you bought your computer from a system vendor, you should be able to simply go on that companies support page and enter the service tag on your computer. An appropriate download page will appear.

    If not, go to the support page of the network adapters vendor and find the proper drivers for your card.

      My System SpecsSystem Spec

  5. #5
    Dwarf's Avatar


    Join Date : Mar 2008
    Doncaster, UK
    Posts : 2,760
    Windows 8.1 Pro RTM x64
    Local Time: 12:06 AM
    england uk yorkshire

     

    Re: Vista Doesn't Recognize My LAN connection

    Hi Rob,

    I have checked the specifications of your motherboard and managed to locate a suitable driver: nForce Driver These are the full chipset drivers, including the LAN drivers.

      My System SpecsSystem Spec

  6. #6


    Join Date : Dec 2008
    Posts : 3
    Vista Ultimate x64
    Local Time: 06:06 PM


      Thread Starter

    Re: Vista Doesn't Recognize My LAN connection

    Thanks so much to both of you! My internet works perfectly now

      My System SpecsSystem Spec


Vista Doesn't Recognize My LAN connection
Similar Threads
Thread Forum
Vista doesn't recognize XP partition. General Discussion
Vista doesn't recognize PDA Vista General
Vista doesn't recognize my internet connection Vista networking & sharing
Why Vista doesn't recognize XP? PLease Help !. Vista networking & sharing
Vista doesn't recognize network Vista networking & sharing