Windows Vista Forums

Vista 16-bit MS-DOS Subsystem error

  1. #1



    Newbie
    Join Date : Mar 2008
    Posts : 5
    Windows Vista Enterprise 32 bit
    Local Time: 09:41 AM

    Vista 16-bit MS-DOS Subsystem error

    I'm getting and 16 bit MS-DOS Subsystem error.

    C:\Windows\System32\command.com config.nt
    the system file is not suitable for running MS-DOS and Microsoft Windows Applications
    Choose 'Close' to teminate the application.

    I've seen this error on XP before but never on Vista until now.
    The solutions for XP don't work because those files are already in the System 32 folder.
    I've attached an image of the error.

    I'm running Vista Enterprise edition. It is a 32 bit machine so it should be able to run 16 bit apps
    I just want to use COMMAND.COM instead of cmd.exe

    Any help would be greatly appreciated.

    [IMG]file:///C:/DOCUME%7E1/raboga/LOCALS%7E1/Temp/moz-screenshot.jpg[/IMG][IMG]file:///C:/DOCUME%7E1/raboga/LOCALS%7E1/Temp/moz-screenshot-1.jpg[/IMG]

      My System SpecsSystem Spec

  2.   


  3. #2
    .Joe's Avatar

    1337 spammer


    Join Date : Mar 2008
    127.0.0.1
    Posts : 912
    Windows 7 RC
    Local Time: 06:41 AM
    usa

     

    Re: Vista 16-bit MS-DOS Subsystem error

    Quote Originally Posted by vista_rookie View Post
    I'm getting and 16 bit MS-DOS Subsystem error.

    C:\Windows\System32\command.com config.nt
    the system file is not suitable for running MS-DOS and Microsoft Windows Applications
    Choose 'Close' to teminate the application.

    I've seen this error on XP before but never on Vista until now.
    The solutions for XP don't work because those files are already in the System 32 folder.
    I've attached an image of the error.

    I'm running Vista Enterprise edition. It is a 32 bit machine so it should be able to run 16 bit apps
    I just want to use COMMAND.COM instead of cmd.exe

    Any help would be greatly appreciated.

    [IMG]file:///C:/DOCUME%7E1/raboga/LOCALS%7E1/Temp/moz-screenshot.jpg[/IMG][IMG]file:///C:/DOCUME%7E1/raboga/LOCALS%7E1/Temp/moz-screenshot-1.jpg[/IMG]
    Welcome to the forums!

    What 16 bit program are you trying to run? Does it use the CD Rom drive?

    There may be a solution available, just need to know more about your situation.

      My System SpecsSystem Spec

  4. #3



    Newbie
    Join Date : Mar 2008
    Posts : 5
    Windows Vista Enterprise 32 bit
    Local Time: 09:41 AM


      Thread Starter

    Re: Vista 16-bit MS-DOS Subsystem error

    Thanks for the welcome and your reply.

    The program I'm trying to run I installed on my CPU, its not on a cd-rom. I'm trying to run the app without using things like DOSbox. I know 16 bit apps should work. But when I try to run command.com it won't execute. So right now my machine won't run any 16 bit apps. I did a test with Visicalc and that didn't work either.

      My System SpecsSystem Spec

  5. #4
    .Joe's Avatar

    1337 spammer


    Join Date : Mar 2008
    127.0.0.1
    Posts : 912
    Windows 7 RC
    Local Time: 06:41 AM
    usa

     

    Re: Vista 16-bit MS-DOS Subsystem error

    Quote Originally Posted by vista_rookie View Post
    Thanks for the welcome and your reply.

    The program I'm trying to run I installed on my CPU, its not on a cd-rom. I'm trying to run the app without using things like DOSbox. I know 16 bit apps should work. But when I try to run command.com it won't execute. So right now my machine won't run any 16 bit apps. I did a test with Visicalc and that didn't work either.
    I've been doing some more reading about this issue. The advisors say that 16 bit programs won't run in Vista. The recommendation is that you download and install Virtual PC, which runs other OS's and they say you can run Dos 3.3 in the VPC, then run your 16 bit program. Or as you mentioned DOSbox is an option.

    I'll also open this up for input from our admins and mods to see if they have any suggestions to assist you.

      My System SpecsSystem Spec

  6. #5



    Newbie
    Join Date : Mar 2008
    Posts : 5
    Windows Vista Enterprise 32 bit
    Local Time: 09:41 AM


      Thread Starter

    Re: Vista 16-bit MS-DOS Subsystem error

    Thanks for the suggestions. Some of my friends have Vista Home edition. They are able to open up the command.com window. The process I'm using is open the run command window and type command.com. It works for them, I was just wondering why mine doesn't work. I can't even get the window to open up. Does it work on your machine?

      My System SpecsSystem Spec

  7. #6



    Newbie
    Join Date : Jun 2008
    Posts : 3
    Vista Business 32bit
    Local Time: 02:41 PM


     

    Re: Vista 16-bit MS-DOS Subsystem error

    Hi,

    I have the same problem when launching any 16 bit installs on very machine in my environment. Did you find a solution? I know this works on a vista build straight out of the box but can't workout what has changed in my environment to cause this. Any ideas?

      My System SpecsSystem Spec

  8. #7
    sidney1st's Avatar

    Member
    Join Date : Apr 2008
    Paris
    Posts : 968
    Ultimate SP1 x64 & x86
    Local Time: 03:41 PM


     

    Re: Vista 16-bit MS-DOS Subsystem error

    Hi mjustin and welcome to vista forums

    Make sure these files are in system32 folder and come back..
    config.nt
    autoexec.nt
    command.com

      My System SpecsSystem Spec

  9. #8



    Newbie
    Join Date : Jun 2008
    Posts : 3
    Vista Business 32bit
    Local Time: 02:41 PM


     

    Re: Vista 16-bit MS-DOS Subsystem error

    Hi & Thanks,

    All these files exist and i've also replaced them in case of corruption. Also this issue occurs weather logged in as an administrator or standard user.

    I believe it may be a similar issue to this article as changing the TMP location to c:\windows\temp partailly reolves the issue but i don't believe it be a practical resolution. "Config.nt The system file is not suitable for running MS-DOS and Microsoft Windows applications" error message when you try to run a program in Windows 2000

    Hope this helps

      My System SpecsSystem Spec

  10. #9
    sidney1st's Avatar

    Member
    Join Date : Apr 2008
    Paris
    Posts : 968
    Ultimate SP1 x64 & x86
    Local Time: 03:41 PM


     

    Re: Vista 16-bit MS-DOS Subsystem error

    Can you attach your config and autoexec files?

    EDIT:
    Have a look in your command.com properties.
    Make sure that in program tab/advanced, the path to autoexec and config are rights.
    Make sure in security that users have the execute and read rights
    Make sure screen is not set to full screen
    Memory should be set to auto

    Last edited by sidney1st; 22 Jun 2008 at 12:01 PM.
      My System SpecsSystem Spec

  11. #10



    Newbie
    Join Date : Jun 2008
    Posts : 3
    Vista Business 32bit
    Local Time: 02:41 PM


     

    Re: Vista 16-bit MS-DOS Subsystem error

    Yes all those files settings are standard and are identical to on the vista build i have that works (as far as i can see)

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast

Vista 16-bit MS-DOS Subsystem error
Similar Threads
Thread Forum
16 bit MS-DOS Subsystem Error Software
SPOOLER SUBSYSTEM APP ERROR - need help Vista General
16 BIT WINDOWS SUBSYSTEM ERROR MESSAGE Vista installation & setup
Spooler SubSystem Error Vista print fax & scan
Spooler SubSystem App Error Vista print fax & scan