Windows Vista Forums

unable to install anything!

  1. #1



    Newbie
    Join Date : Feb 2011
    Posts : 1
    x64
    Local Time: 12:33 AM

    unable to install anything!

    Please Help! I first noticed a problem a few weeks ago when I was trying to install a student version of AutoCad. I spent countless hours trying to reading forums and trying to fix the problem on my end without success. Most recently I was trying to update Microsoft security essentials and it will no update, another error code with it goes to intstall. Same with my window's updates. When I try to update my computer it gives me another error code (652) unable to intall. Additionally, I cannot update or install the newest version of itunes. Please help! Not quite sure what to do. My laptob is about a 1 1/2 years old. I have 158GB free of 280, so I think I should have enough space. Any help would be greatly appreciated.

    Thanks,
    debra

      My System SpecsSystem Spec

  2.   


  3. #2
    richc46's Avatar

    BSOD Squad




    Join Date : Dec 2008
    Fairfield County, CT
    Posts : 19,798
    Windows 7 SP1 x64
    Local Time: 03:33 AM
    usa us connecticut

     

    Re: unable to install anything!

    Welcome Debra
    Your symtoms are a classic sign of malwre
    Update and run a full anti virus scan
    Download and run a full and updated malwarebytes scan

    If negative
    Try to install in clean boot. If it works follow the procedure to determine the cause.
    http://support.microsoft.com/kb/929135

    If it does not work try an SFC scan.
    If errors are found run 3 times
    System Files - SFC Command

    If none of the above work, try to correct by a system restore, dated a week before the problem began.

      My System SpecsSystem Spec

  4. #3



    Banned

    Join Date : Dec 2009
    Posts : 3,375
    Vista Home Premium x86 SP2
    Local Time: 08:33 AM
    uk european union

     

    Re: unable to install anything!

    Hello!

    This error message is very specific (Hex lookup, not decimal, error revolving around Windows Installer, not Modems)

    Code:
      ERROR_INSTALL_ALREADY_RUNNING                                 winerror.h
    # Another installation is already in progress.  Complete that
    # installation before proceeding with this install.
    # 5 matches found for "652"
    You have an issue with one of your services. Any Windows Update, any Microsoft Security Essentials Update (which uses Windows Update), any program which uses the Windows installer will all be broken by this one error.

    It isn't easy to fix, and I would estimate to be fixable on about 75% of machines.

    First, I would like to reiterate what Richc46 has said. Credit goes to him for the things he has suggested!

    However, there are a few, specific and quick fixes which might just work.

    Please access services.msc. You can see how to do this here: Services

    I am now going to tell you what to do in there. If you need any help at all, do not be afraid to ask. It is better to ask now, before making a mistake! We will always be here for you.

    In the leftmost Name column of services.msc, scroll down to Windows Installer.

    Double click on it. Click on the Stop button, if it is started. Leave it at Stopped if it is already stopped. Set the startup type to Manual. This is crucial!

    Restart your computer and re-test. If there is still a problem, make sure that no installers whatsoever, or Windows Updates, or anything are running, and then Open Task Manager: Task Manager - Open and Close Applications and Processes

    and kill all and any of the following Processes:

    msiexec.exe
    setup.exe
    hotfix.exe


    Next, we need to view the registry:

    Quote Originally Posted by Dwarf
    To invoke the registry editor, click the start orb and type 'regedit' into the search box. If you need to use the program with administrative privileges, right click on the program and supply the necessary credentials, otherwise press enter/return. The program will appear.
    Then please navigate to:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows

    Does the key Installer\InProgress exist?

    If it does, please just tell me, but don't do anything yet.

    Then please try the Clean Boot and what richc46 has said.

    There are more advanced solutions, but I am hoping that we won't have to go there.

    The very best of luck!

    Richard

      My System SpecsSystem Spec

  5. #4


    Join Date : Feb 2011
    Posts : 34
    Vista Home Premium 32bit
    Local Time: 02:33 AM


     

    Re: unable to install anything!

    To add onto what niemiro and richc46 said, try opening your computer in safe mode with internet connection. Then download Malwarebytes' Anti-Malware. Run the program to see if you have any malware installed by accident on your computer.

      My System SpecsSystem Spec


unable to install anything!
Similar Threads
Thread Forum
Unable To Install IE8 Browsers & Mail
Unable to Install Anything. Vista General
Unable to install SP1 Vista installation & setup
Unable to install WLM Live Mail
Unable to install SP1 Vista General