Windows Vista Forums

No audio through hdmi to tv

  1. #1


    Join Date : Feb 2009
    Posts : 2
    Vista Ultimate x64 w/ SP1
    Local Time: 08:49 PM

    No audio through hdmi to tv

    Seems to be a common problem. I used to connect my HP Pavilion dv9260nr Notebook to my Sharp Aquos LCD tv through an HDMI cable and got audio and video w/ no problems. About 2 months ago I reinstalled Vista Ultimate x64. I haven't tried to reconnect until recently and now I get video but no audio.

    I have tried to set SPDIF Interface to default like I used to but it doesn't work. You can see the green "mixer" bar moving, but I can't hear anything. Also, when it's set to default the configure box is greyed out.



    I have the latest Conexant High Definition Audio Driver, 4.33.1.61.
    I also have Vista Codec pack v511 installed.

    Seems like I need to "enable" hdmi somewhere but I can't find anywhere to. Any ideas?

    Thanks for any help!

      My System SpecsSystem Spec

  2. #2
    joel406's Avatar
    Join Date : Sep 2007
    Reality
    Posts : 471
    Vista Business/Home Premium/Ultimate x64/Server 2008 X64
    Local Time: 08:49 PM


     

    Re: No audio through hdmi to tv

    Use the audio out from our laptop. Thats where the sound is. Always was.

      My System SpecsSystem Spec

  3. #3


    Join Date : Feb 2009
    Posts : 2
    Vista Ultimate x64 w/ SP1
    Local Time: 08:49 PM


      Thread Starter

    Re: No audio through hdmi to tv

    Are you talking about the audio jack in the front? Why would I connect an hdmi cable and and audio cable? Sound did come out of hdmi before, always did.

      My System SpecsSystem Spec

  4. #4
    Hogtowner's Avatar
    Join Date : Jul 2008
    G'ville, FL
    Posts : 68
    Vista Ultimate x64 SP2
    Local Time: 08:49 PM
    usa us florida

     

    Re: No audio through hdmi to tv

    I have the same problem intermittantly, but not through HDMI. I use an optic from my computer to my receiver. Every once in a long while I lose my sound even though the green bar shows output also. But my receiver shows no input. And it ain't the cable.

    I can solve the problem by rebooting, so I think there are conflicts in some of the audio software I run. You might try simplifying your audio driver situation as much as possible until you find the culprit on your system.

    I know this isn't much in the way of help. Thought you might like to know you weren't alone though.

      My System SpecsSystem Spec

  5. #5


    Join Date : Mar 2009
    Posts : 3
    Vista Home Premium 32bit
    Local Time: 08:49 PM


     

    Re: No audio through hdmi to tv

    I am in the exact same situation with my HP Pavilion dv9207us..
    And the interesting part is that I have been using this HDMI to watch movies with no problem for more than an year now and saddenly it stopped working...I have Conexant HD Audio - last drivers...BIOS...tried everything...nothing worked. I think that it may be some Windows update now...If somebody knows something, please let me know..
    Thanks

      My System SpecsSystem Spec

  6. #6
    Martee's Avatar
    Join Date : Mar 2009
    Posts : 584
    Vista Ultimate x64 sp2, Solaris x64
    Local Time: 04:49 PM


     

    Re: No audio through hdmi to tv

    Quote Originally Posted by zwooky View Post
    Seems to be a common problem. I used to connect my HP Pavilion dv9260nr Notebook to my Sharp Aquos LCD tv through an HDMI cable and got audio and video w/ no problems. About 2 months ago I reinstalled Vista Ultimate x64. I haven't tried to reconnect until recently and now I get video but no audio.

    I have tried to set SPDIF Interface to default like I used to but it doesn't work. You can see the green "mixer" bar moving, but I can't hear anything. Also, when it's set to default the configure box is greyed out.



    I have the latest Conexant High Definition Audio Driver, 4.33.1.61.
    I also have Vista Codec pack v511 installed.

    Seems like I need to "enable" hdmi somewhere but I can't find anywhere to. Any ideas?

    Thanks for any help!
    Hello,

    I'm not sure if I can help here, but I have clean installation of Vista and
    found little difference in my Sound window than your one. I will try to explain
    what I mean.

    Go to Control Panel/Hardware and Sound/ Sound then click Manage Audio Devices.
    In this window you should find three items:
    -Digital Output Device (HDMI)
    -Speakers/Headphones
    -Digital Output Device (SPDIF Out)

    From your attached image, looks like, you don't have Digital Output Device (HDMI),
    do you?. But if you got it, right click it and set it as the Dafault, also check
    it and click on Properties, "Enable" the device usage first, then under Levels tab,
    check if the volume level is all the way up.

    Also, in the Device Manager,I found two devices....High Definition Audio Device
    and in my case SigmaTel High Definition Audio CODEC. This first one is just for
    HDMI audio. By the way, audio drivers are still the same that OEM provided.

    You already try set the SPDIF interface to Default, but click Supported Format
    tab and try to check in the Microsoft WMA Audio, and at the same time deselect
    the other ones. Maybe, this will help.

    Cheers...

      My System SpecsSystem Spec

  7. #7


    Join Date : Jul 2009
    Posts : 1
    Vista Home x64
    Local Time: 05:49 PM


     

    Re: No audio through hdmi to tv

    Quote Originally Posted by zwooky View Post
    Seems to be a common problem. I used to connect my HP Pavilion dv9260nr Notebook to my Sharp Aquos LCD tv through an HDMI cable and got audio and video w/ no problems. About 2 months ago I reinstalled Vista Ultimate x64. I haven't tried to reconnect until recently and now I get video but no audio.

    I have tried to set SPDIF Interface to default like I used to but it doesn't work. You can see the green "mixer" bar moving, but I can't hear anything. Also, when it's set to default the configure box is greyed out.



    I have the latest Conexant High Definition Audio Driver, 4.33.1.61.
    I also have Vista Codec pack v511 installed.

    Seems like I need to "enable" hdmi somewhere but I can't find anywhere to. Any ideas?

    Thanks for any help!
    If you click on the background of that window showing your speakers, there is a context menu that allows you to see disabled devices. Put a checkmark there, and when your HDMI shows up you can right click it and choose to enable it and if you want, make it the default device.

      My System SpecsSystem Spec

  8. #8


    Join Date : Mar 2009
    Posts : 3
    Vista Home Premium 32bit
    Local Time: 08:49 PM


     

    Re: No audio through hdmi to tv

    I already solved this problem.
    It is the update of NVidia driver.
    Just uninstall it, restart and everything will work fiine.
    It took me months untill I found out the problem is Video, not audio driver.
    Good luck!

      My System SpecsSystem Spec

  9. #9


    Join Date : Jun 2010
    Danville, CA
    Posts : 1
    Vista Home Premium 64bit
    Local Time: 05:49 PM
    usa us california

     

    Re: No audio through hdmi to tv

    First, sometime during a two-day effort my problem of no HDMI audio was fixed. I don't know exactly when because I finally discovered that the audio test sound (Playback Device's green bar) was not going out over my HDMI link. (It worked fine for the computer and docking-station speakers.) Thus, if you're trying to fix this very common no-audio problem, include a Media Player video or some other audio source in your tests.

    Second, the fix was to download and install (not update) the very latest nVidia driver. (Reinstalling the original driver from the recovery disk may have worked but I'll never know because of the test-sound problem.) When I just updated the driver from Device Manager, it didn't install the associated driver-specific nVidia Control Panel. (Losing the Control Panel also seems to be a common problem.) Thus, I suggest downloading the latest driver from the manufacturer and running their included Setup program. It worked for me.

    One last word: Blindly installing older drivers (a solution suggested by some) looks very dangerous - especially those from a popular site's "European" sources. At least Norton sure didn't like some of them.

      My System SpecsSystem Spec

  10. #10


    Join Date : Jun 2010
    Posts : 1
    Vista
    Local Time: 06:49 PM


     

    Re: No audio through hdmi to tv

    This is my solution apprantley.
    I was trying to run some video clips through different things to test it and I came to this. For example with VLC when you run it it uses it's own settings for sound. So I went into "Audi > Audio Device > And in my case > 5.1.
    And voila it was working, I tried this with Itunes, WMA and same result each time.
    So maybe just try that, it might help.


      My System SpecsSystem Spec

Page 1 of 2 12 LastLast

No audio through hdmi to tv
Similar Threads
Thread Forum
Hdmi to lcd get video no audio Sound & Audio
HDMI audio fades in Sound & Audio
pc to lcd via hdmi = some audio Sound & Audio
Vista HDMI audio Issues Sound & Audio
HDMI Audio Vista General