Windows Vista Forums

Soundblaster Live!

  1. #1



    Newbie
    Join Date : Sep 2007
    Posts : 2
    Vista x64
    Local Time: 07:26 PM

    Soundblaster Live!

    Howdy,

    I have a regular Soundblaster Live! soundcard (not SBLive! 5.1) with the expansion daughter card connected to the orignal Creativelabs 4.1 speaker setup. The card is on black PCB and has gold-plated connectors. This is from back in the days when this combo was the top of the line. Currently I have Vista x32 and am considering moving to x64 to use the full 4GB of RAM I have. However I am concerned there are no drivers for this. Right now I am using the modified KxDrivers 3538m which I get full quadrophonic sound and can adjust it anyway I want like the creative control panels. I don't believe this is compatible with x64. All the "fixes" I see on a simple Google search are for SBLive! 5.1,Audigy,X-Fi, etc. Don't wantt o bother with a new sound card when the old one works perfectly.

      My System SpecsSystem Spec

  2.   


  3. #2
    Choogster's Avatar

    Skilled
    Join Date : Sep 2007
    UK
    Posts : 159
    XP, Linux x64, Vista x64
    Local Time: 06:26 PM
    uk uk england

     

    Re: Soundblaster Live!

    Not entirely sure whether these will help, but worth a try?

    64bitdrivers.com: Creative Sound Blaster Audigy Value for Vista x64

      My System SpecsSystem Spec

  4. #3



    Newbie
    Join Date : Sep 2007
    Posts : 2
    Vista x64
    Local Time: 07:26 PM


      Thread Starter

    Re: Soundblaster Live!

    Quote Originally Posted by Choogster View Post
    Not entirely sure whether these will help, but worth a try?

    64bitdrivers.com: Creative Sound Blaster Audigy Value for Vista x64
    Thanks the tech-geek in me won over and I installed it anyways. Suprisingly Windows Update now provides a generic SBLive! driver for all those users. No control panel no equalizer control but there is a generic 4.1,5.1,7.1 speaker setup which is good enough for me. I was never that much into EAX 9999.0 so as long as it works. This SBLive! has also gone into about 8 machines I have owned over the years.

      My System SpecsSystem Spec

  5. #4
    Choogster's Avatar

    Skilled
    Join Date : Sep 2007
    UK
    Posts : 159
    XP, Linux x64, Vista x64
    Local Time: 06:26 PM
    uk uk england

     

    Re: Soundblaster Live!

    actually, I have to say that I had no problems with my original sblive! card and it worked great. who needs all like X-Fi stuff ;D

      My System SpecsSystem Spec

  6. #5



    Newbie
    Join Date : Nov 2007
    Posts : 1
    Ultimate x64
    Local Time: 09:26 PM


     

    Re: Soundblaster Live!

    Hi, this is my Vista32/64 mod driver for SB live 4.1/5.1 cards series, enjoy¡¡

    Sound Blaster Live series 4.1 - 5.1 vista 32/64 driver (based on sb x-fi driver)


    This Driver have Full OpenAL support, Surround sound, Louder volume, audio console functional, Microsoft enhancements (These enhancements allow highly advanced Bass Management Control, Speaker Fill similar to CMSS, but MS sounds better, Room Correction and Loudness Equalization) and same XP´sound quality.
    Eax work with Alchemy¡
    1-Uninstall old driver
    2-Run setup, if ask the driver not whql,install anyway the driver work just fine reboot
    3-Install Audio Console reboot, this is important to surround sound work, if not install audio console the sound only pass through two front speakers
    4-If you hear distortion sound, change speakers to 4 or 5.1 (preferably use audio console if show all white use windows mixer but leave audio console installed to surround sound work) ; or change sample rate option in panel control, 48000hz 16bit work for me, if you can´t hear any sound after install the driver or change speaker setting, only mute and unmute volume in windows mixer and this fix the problem.
    5-The sounds in vista enviroment have only two channel, test multichannel sounds in games like Bioshock or Prey

    Note: For multichannel sounds in windows vista environment, you have to enable Speaker Fill option in control panel - sound enhancements setting.
    I test multichannel 4 and 5.1 sounds successfully in Bioshock demo.

    Other info
    Audio console work¡¡ EAX work in games¡, Winamp and EAX´s effect in audio console work too¡
    For this,use Creative_Alchemy_Universal_1.00.04 or Creative_ALchemy_1.00.03 both Daneil_K mod.
    Creative MediaSource Player/Organizer 5.10.38 work too¡
    Winamp 5.5 work perfect with ALchemy Universal 1.00.04 for SB Live! / Audigy
    have full support hardware acceleration and multi speakers, the sound is very good¡¡

    Instruction for winamp and other players:
    copy dsound.dll´s ALchemy directory to Winamp folder. enjoy¡

    COPYRIGHT NOTICE: The included files are property of Creative Labs, Inc.

    The files:

    Sound Blaster Live series 4.1 - 5.1 vista 32/64 driver
    http://rapidshare.com/files/64356124/SBAX_2_12_0001_20.zip

    Creative audio console - Install this to surround sound work
    http://rapidshare.com/files/65598530/AudCon.zip


    ----------------------------------------------------------------

    Other files like ALchemy and Vista gameport driver
    Creative ALchemy Universal 1.00.04 for SB Live! / Audigy
    http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=18972

    Gameport support pack for Vista gameport driver
    http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=13336

    Creative MediaSource Player/Organizer 5.10.38
    http://rapidshare.com/files/67342817/CMS5_5.10.38.exe

    ----------------------------------------------------------------

    Read other sb live driver post:
    http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=23567

    http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=19194

    http://forums.creative.com/creativelabs/board/message?board.id=Vista&message.id=22938

    ----------------------------------------------------------------

    All Tested with SB Live Value Model: CT4830 and Windows Vista ultimate 32/64bits
    Full System Setup:
    ATHLON 64 X2 4400+ Core Brisbane
    K9N NEO V1.0 bios v1.6
    2Gb Dual Channel OCZ Platinum Rev.2 800mhz
    WD WD1600AAJS 160Gb SATAII
    DVD-RW LG GSA-H42N
    Zogis Geforce 7950GT 512MB PCIE
    Sound Blaster Live Value
    ATV-TUNER-F Advantek
    Thanks to Daniel_K, and all user to support sb live series¡¡¡¡¡¡
    Sound Blaster Live for ever ¡¡¡¡¡¡¡¡¡¡

      My System SpecsSystem Spec

  7. #6



    Newbie
    Join Date : Jan 2008
    Posts : 1
    XP Pro, Vista, Ubuntu 7.10, DSL Linux, FreeSB, Linspire, DOS 8
    Local Time: 06:26 PM


     

    Re: Soundblaster Live!

    Assuming that Vista recognizes your card and it works fine with distortion, then the following should work well.
    1. Go to Start > Control Panel and click on Classic
    View.
    2. Double-click on Sound and single click on
    speakers.
    3. With Speakers now hilighted, click on the
    Configure button on the bottom left.
    4. Assuming you have two speakers and subwoofer,
    choose 7.1 Surround and click next.
    5. On the next screen, uncheck everything but the
    subwoofer and click Next.
    6. This screen leave only the Front left and right
    option checked.
    7. On the next screen, click Finished and back at the
    Sound screen, just click OK.
    8. Enjoy the sound!

      My System SpecsSystem Spec

  8. #7



    Newbie
    Join Date : Mar 2008
    Posts : 1
    Vista Ultimate x64
    Local Time: 01:26 AM


     

    Re: Soundblaster Live!

    Quote Originally Posted by peto View Post
    Assuming that Vista recognizes your card and it works fine with distortion, then the following should work well.
    1. Go to Start > Control Panel and click on Classic
    View.
    2. Double-click on Sound and single click on
    speakers.
    3. With Speakers now hilighted, click on the
    Configure button on the bottom left.
    4. Assuming you have two speakers and subwoofer,
    choose 7.1 Surround and click next.
    5. On the next screen, uncheck everything but the
    subwoofer and click Next.
    6. This screen leave only the Front left and right
    option checked.
    7. On the next screen, click Finished and back at the
    Sound screen, just click OK.
    8. Enjoy the sound!
    Peto i Specialy Signed in just to be able to Thank you !!!

    Thank you very much for posting this, i followed the steps and my sound is perfect with the Windows Update-driver and the distortion is now gone.
    I was blaming Microsoft al the time, why release such a bad driver, but it is a great driver only the Settings must be changed.

    Thanks again, you made a men happy here !!!

      My System SpecsSystem Spec

  9. #8
    Cartel's Avatar

    Junior Member
    Join Date : Feb 2008
    Hope, BC
    Posts : 14
    Vista Ultimate SP1 x86
    Local Time: 04:26 PM
    canada ca british columbia

     

    Re: Soundblaster Live!

    I found any drivers other than the 2002 drivers make snap, crackle, pop sounds.

    If you want crystal clear sound, with no scratchy crud, I suggest you follow this link.

    Make sure you remove all previous divers and follow my instuctions.

    I've been running this way since RC1 and never had any issues.

    Remember, no creative driver for Live! supports more than 2GB of ram.

    Very important!

    Vista SB0100 The right Way - Windows Vista - Creative Labs

      My System SpecsSystem Spec

  10. #9



    Newbie
    Join Date : Mar 2008
    England
    Posts : 9
    Vista Home Premium 32bit
    Local Time: 01:26 AM
    uk

     

    Re: Soundblaster Live!

    Naimadekar your zipped driver package made my Kaspersky squeal like a pig on acid!

    Maybe someone else has had this and can confirm it has a worm..

    detected: riskware Worm.P2P.generic Running process: C:\WINDOWS\SYSTEM32\OALINST.EXE

      My System SpecsSystem Spec

  11. #10



    Member
    Join Date : Aug 2008
    Posts : 122
    Vista Ultimate 32bit
    Local Time: 10:26 AM


     

    Re: Soundblaster Live!

    Hi,

    I have Soundblaster Live 5.1. Back in the day when i used XP, I could just simply plug my headphones in the 6.35mm jack on the front control panel of the soundcard with all the cool gadgets etc and the sound would automatically channel into the headphones. One day it stopped working, so i thought maybe i need a new 6.35mm adapter. I bought one and it still didnt work. Now i got a new computer with Vista, but I kept the same soundcard. I realised there are no SBLive! drivers for vista. I got my speakers working fine. But my headphones still doesnt work on the front. The only way to get my headphones to work is if I unplugg my speakers from the green connector in the back and then plug my headphones through that. But thats kinda of annoying and not good for my speakers. Does anyone know how I can get the 6.35 on the front to work again. Is it a hardware or software issue?

    Cheers,
    Joronamo.

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast

Soundblaster Live!
Similar Threads
Thread Forum
Soundblaster Live! Sound & Audio
Soundblaster live Vista hardware & devices
SoundBlaster Live! with Vista Vista General
Soundblaster Live Problems Vista hardware & devices
Soundblaster Live! 24-bit Problems Vista hardware & devices