Windows Vista Forums

Service Pack 1 does not seem to install

  1. #1



    Newbie
    Join Date : Nov 2012
    Posts : 1
    Vista home edition 32bit
    Local Time: 02:31 AM

    Service Pack 1 does not seem to install

    Hi

    I removed Windows XP from one of my machines, and reinstalled Windows Vista.

    (Vista was originally installed).

    I have used the incorporated Windows update function to update. I think I've downloaded, and installed, about 200 updates.

    Finally Windows Service Pack 1 shows up as an update alternative.

    I choose to install as normal. I get a window where I have to accept terms, and I am told that the installation will take some time, including shutting down and restarting Windows several times. I accept.

    The installations starts.

    However; nothing seems to happen. The machine does not restart, and there is no further messages from the system in relation to the installation.

    If I (as I have done some times now after waiting far beyond what should be a required installation time) restart the machine manually, Service Pack 1 yet again surfaces on the upgrade monitor as an update ready to get installed. If I choose to install again, the process restarts, and the result is nothing.

    What is happening. Why won't Service Pack 1 install properly?

      My System SpecsSystem Spec

  2.   


  3. #2
    richc46's Avatar

    BSOD Squad




    Join Date : Dec 2008
    Fairfield County, CT
    Posts : 19,840
    Windows 7 SP1 x64
    Local Time: 03:31 AM
    usa us connecticut

     

    re: Service Pack 1 does not seem to install

    Welcome
    Try with a standalone. If that does not work, we have CDs with Vista SP1 and 2 that you can use if you have a proper product key number
    http://www.microsoft.com/en-us/downl...ils.aspx?id=30

      My System SpecsSystem Spec

  4. #3
    tom982's Avatar

    ٩(͡๏̯͡๏)۶




    Join Date : Mar 2010
    England
    Posts : 3,642
    Windows 8.1 Pro x64
    Local Time: 08:31 AM
    uk uk england

     

    re: Service Pack 1 does not seem to install

    Hello Eirik and welcome to the forums

    Could you follow the instructions outlined here please?

    Windows Update Posting Instructions - Windows 7 Forums

    Although I wrote them for Windows 7, they apply to Vista. Post the logs here when you've finished.

    Tom

      My System SpecsSystem Spec

  5. #4



    Veteran
    Join Date : Aug 2007
    Posts : 111
    Vista Ultimate x64
    Local Time: 03:31 AM


     

    re: Service Pack 1 does not seem to install

    Quote Originally Posted by richc46 View Post
    Welcome
    Try with a standalone. If that does not work, we have CDs with Vista SP1 and 2 that you can use if you have a proper product key number
    Download Windows Vista Service Pack 1 Five Language Standalone (KB936330) from Official Microsoft Download Center
    That site says not to install the stand-alone if you are updating just one computer, and to rely on Windows Update for a smaller version instead.

    I have a similar problem.

      My System SpecsSystem Spec

  6. #5
    tom982's Avatar

    ٩(͡๏̯͡๏)۶




    Join Date : Mar 2010
    England
    Posts : 3,642
    Windows 8.1 Pro x64
    Local Time: 08:31 AM
    uk uk england

     

    re: Service Pack 1 does not seem to install

    That's poorly written then. Standalones are perfectly safe to use regardless of the computer. Rather than Windows Update downloading the update, you are instead. The same process is used to install it, so it's really no different

    Could you follow the instructions in this post please?

    http://www.vistax64.com/windows-upda...ml#post1382907

    And post them in a thread of your own.

    Tom

      My System SpecsSystem Spec

  7. #6



    Veteran
    Join Date : Aug 2007
    Posts : 111
    Vista Ultimate x64
    Local Time: 03:31 AM


     

    re: Service Pack 1 does not seem to install

    I'm sorry, but that seems both wrong and ignorant. Please see this link.

    Things to know before you download Windows Vista SP1

      My System SpecsSystem Spec

  8. #7
    z3r010's Avatar

    Administrator

    Join Date : Oct 2005
    Standish, Lancashire, England
    Posts : 21,975
    Windows 8
    Local Time: 08:31 AM
    uk england

     

    re: Service Pack 1 does not seem to install

    Well as you seem to know better than the people that help fix these problems everyday, good luck fixing it yourself and I'll mark this thread as solved.

      My System SpecsSystem Spec

  9. #8



    Veteran
    Join Date : Aug 2007
    Posts : 111
    Vista Ultimate x64
    Local Time: 03:31 AM


     

    re: Service Pack 1 does not seem to install

    This thread is not for me, I'm not the OP. So, please don't mark it as solved. Hope I don't seem to be all-knowing. That seems to be trend among some to tend to think that way about others.

      My System SpecsSystem Spec

  10. #9



    Veteran
    Join Date : Aug 2007
    Posts : 111
    Vista Ultimate x64
    Local Time: 03:31 AM


     

    re: Service Pack 1 does not seem to install

    I may be all-knowing (I am not), but I solved my problem. If I were to boast myself as all-knowing, I wouldn't tell you how this was solved. But I will.

    For some reason, the automatic windows updates Vista x64 SP1 installation was "successful," as displayed in the "view update history" box, but was never actually installed (it installed very quickly, about less than a minute). The installation was repeated (automatic updates), but never got installed. I downloaded and installed the stand-alone x64 SP1 installer and SP2 installer manually.

    SP1 installer
    http://www.microsoft.com/en-us/downl....aspx?id=21299

      My System SpecsSystem Spec

  11. #10
    tom982's Avatar

    ٩(͡๏̯͡๏)۶




    Join Date : Mar 2010
    England
    Posts : 3,642
    Windows 8.1 Pro x64
    Local Time: 08:31 AM
    uk uk england

     

    re: Service Pack 1 does not seem to install

    Quote Originally Posted by z3r010 View Post
    Well as you seem to know better than the people that help fix these problems everyday, good luck fixing it yourself and I'll mark this thread as solved.
    Thanks for the support John

    Quote Originally Posted by MDOC View Post
    I may be all-knowing (I am not), but I solved my problem. If I were to boast myself as all-knowing, I wouldn't tell you how this was solved. But I will.

    For some reason, the automatic windows updates Vista x64 SP1 installation was "successful," as displayed in the "view update history" box, but was never actually installed (it installed very quickly, about less than a minute). The installation was repeated (automatic updates), but never got installed. I downloaded and installed the stand-alone x64 SP1 installer and SP2 installer manually.

    SP1 installer
    Download Windows Vista Service Pack 1 Five Language Standalone for x64-based Systems (KB936330) from Official Microsoft Download Center
    Windows Update downloads updates that are specific to your computer, and won't download things that you don't need. If you're using the MSDC then you have the opportunity to download updates that won't work on your system - either because they're for unsupported hardware, or a different system architecture. The update will fail when you try and install it though, so it's not a problem. Aside from this, there is no issue with downloading a standalone as opposed to using Windows Update - after the update has been downloaded, they do exactly the same thing. I can't think of any other reason that MS would advise against it other than it causing the end user an inconvenience and then they waste MS Technical Support's time with their questions.

    As an example, 0x8024200D error codes will only be solved by downloading and installing a standalone.

    Tom

      My System SpecsSystem Spec

Page 1 of 2 12 LastLast

Service Pack 1 does not seem to install
Similar Threads
Thread Forum
Can't install service pack 2 Windows Updates
Why cant I install service pack 1? Windows Updates
Can't Install Service Pack 2 Windows Updates
SERVICE PACK 1 INSTALL Vista file management
Service Pack Install Vista installation & setup