KB4012598 The update does not apply to your system

chris0803

New Member
Hello!

This is my first post in the Vista forums. I just wanted to ask about this patch not installing. I think this is the Wannacry patch but my Vista machine doesn't want to install it. I got Windows Update going again and it tells me that there's no available updates. I don't even know if it's updated up to the last patches in 2017 but it should have done. I'm running Windows Vista Home Premium 32 bit with SP2.

Would anyone have any ideas how I could get this patch going please? I've been looking online but I can't find a answer that worked yet. I'm not too worried if I can't get this patch installed, it'd just be nice.

Thank you :)
 

Attachments

  • Capture.JPG
    Capture.JPG
    194.7 KB · Views: 6
  • Capture2.JPG
    Capture2.JPG
    79.3 KB · Views: 7

My Computer

System One

  • Operating System
    Windows Vista Home Premium SP2

Vistaar

Vista Guru
Welcome!

You have probably installed one or more updates for Windows Server 2008 SP2 released after April 2017 that replaced KB4012598. It was first superseded by KB4018466 in May 2017.
72427BE7-83A7-4624-AB29-885D43C2447F.jpeg
 

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT

chris0803

New Member
Welcome!

You have probably installed one or more updates for Windows Server 2008 SP2 released after April 2017 that replaced KB4012598. It was first superseded by KB4018466 in May 2017.
View attachment 31081
Thank you!

Ah yeah that makes more sense then, thank you for that! I'll have a look into KB4018466 then, hopefully that'll install.
I know I installed a few Server 2008 updates to get Windows Update going again, mostly needed the sha2 support so I'll see if any of those patches have patched it already.

Thank you again for the help!
 

My Computer

System One

  • Operating System
    Windows Vista Home Premium SP2

wither 3

Vista Guru
Gold Member
For information, I have the 4012598 on this system which is completely up-to-date with the Microsoft Vista updates but doesn't have any of the Server 2008 updates.
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps

Vistaar

Vista Guru
I'll have a look into KB4018466 then, hopefully that'll install. I know I installed a few Server 2008 updates to get Windows Update going again, mostly needed the sha2 support so I'll see if any of those patches have patched it already.
KB4018466 isn’t going to apply either. Either you already have it, or (more likely) you installed at least one monthly rollup issued in February 2019 or later that superseded it. An update “does not apply to your system” if you already have more recent versions of affected files, which I believe must be the case. You can just forget about that particular update.
 

My Computer

System One

  • Operating System
    Vista Home Premium x86 SP2
    Manufacturer/Model
    HP Pavilion Elite m9150f
    CPU
    Intel Q6600
    Memory
    3 GB
    Graphics Card(s)
    NVIDIA GeForce 8500 GT

Volume Z

Member
An update starts to not apply the moment it gets installed. This is the reason there exists a relief to the Vista general update search issue. The load of having to process a particular update is taken from the Update Service by making it not apply manually. If a superseding version is installed, the equivalent of the update is still present, making it continue to not apply.

When a superseding version of a triggering update became available, an old trigger became applicable in a new wrapper, which is why the issue got relaunched on a monthly basis.
 
Last edited:

My Computer

Top