5.1 sound not playing out of all speakers

ComicBookGuy

New Member
Hey.

I have Logitech X-530 speakers, a 5.1 setup. Yesterday I wanted to use my headset to play a game, so I had to change my settings to stereo to get the sound out of both the left and right headphones. When I had finished, I changed it back to 5.1 through the control panel, but now the sound is only playing out of the left and right speakers. All speakers are functional, since when I test it through the control panel the 'bing' sound plays through all one-by-one. The speakers worked fully in 5.1 before I changed the settings.

Windows Vista 32bit SP2.

Thanks.
 

My Computer

System One

  • Manufacturer/Model
    Dell Dimension 9200
    Memory
    2 GB
    Graphics Card(s)
    NVIDIA 7900

chrisdandare123

New Member
have you tried giving you computer a system restore this should store all your old factory settings if you do not know how to do this just reply back for more help thank you :)
 
Last edited by a moderator:

My Computer

ComicBookGuy

New Member
I've enabled speaker fill, but I don't really want this. It tries to channel stereo into 5.1, but it just ends up making the audio quality poor. How can I make it like it used to be - channel stereo the same levels out of all speakers, but channel 5.1 as it should be.
 

My Computer

System One

  • Manufacturer/Model
    Dell Dimension 9200
    Memory
    2 GB
    Graphics Card(s)
    NVIDIA 7900

zigzag3143

Banned
CBG

we really need you to fill in your system specs (lower left corner of your posts) so we know what hardware you have. We could also use what aduio card you have?

thanks

ken
 

My Computer

System One

  • Manufacturer/Model
    Dell Inspiron E 1405
    CPU
    [email protected]
    Memory
    4 gigs
    Graphics Card(s)
    integrated intel 945
    Sound Card
    integrated
    Screen Resolution
    1440x900
    Hard Drives
    300 gig internal
    Internet Speed
    10 down 1.5 up

ComicBookGuy

New Member
Sorry, I'm not sure what audio card I have. dxdiag says Sound 1 is Speakers (High Definition Audio) and Sound 2 is Digital Output Device (SPDIF)
 

My Computer

System One

  • Manufacturer/Model
    Dell Dimension 9200
    Memory
    2 GB
    Graphics Card(s)
    NVIDIA 7900

MrNeeds

PC Geek
Vista Guru
Gold Member
Sorry, I'm not sure what audio card I have. dxdiag says Sound 1 is Speakers (High Definition Audio) and Sound 2 is Digital Output Device (SPDIF)
if its a dell dimension 9200 then your soundcard is this:

Type: Sound card - plug-in card
Audio Adaptor: Creative Sound Blaster X-Fi XtremeMusic
Sound Output Mode: 7.1 channel surround
Compliant Standards: Dolby Digital Surround, THX, High Definition Audio
 

My Computer

System One

  • Manufacturer/Model
    Custom Build
    CPU
    Intel Q6600 @ 2.8GHz
    Motherboard
    Evga NF78-CK-132-A 3-Way SLI
    Memory
    8Gb DDR2 Corsair Dominator @ 1066Mhz 5-5-5-15
    Graphics Card(s)
    EVGA 560 GTX SC FTW 1GB
    Sound Card
    Realtek ALC888 7.1 Audio, Logitech G35 7.1 Surround Headset
    Monitor(s) Displays
    Dell S2409W 16:9, HDMi, DVI & VGA
    Screen Resolution
    1920 x 1080
    Hard Drives
    Samsung 7200rpm 250Gb SATA,
    Samsung 7200rpm 750Gb SATA,
    WD 7200rpm 1TB SCSI SATA.
    PSU
    Xigmatek 750W Quad sli quad core 80% eff
    Case
    Antec 900 Gaming Case
    Cooling
    Zalman CNPS9700-NT NVIDIA Tritium, Dominator RAM cooler
    Mouse
    Razor Lachesis Banshee V2 Blue, 4000DPI
    Keyboard
    Logitech generic keyboard
    Internet Speed
    16Mb Sky bb
    Other Info
    Wireless Gaming Receiver for Windows, Wireless Xbox 360 Pad, Wireless Xbox 360 Les Paul Guitar

stormy13

Member
Vista Guru
Sorry, I'm not sure what audio card I have. dxdiag says Sound 1 is Speakers (High Definition Audio) and Sound 2 is Digital Output Device (SPDIF)
if its a dell dimension 9200 then your soundcard is this:

Type: Sound card - plug-in card
Audio Adaptor: Creative Sound Blaster X-Fi XtremeMusic
Sound Output Mode: 7.1 channel surround
Compliant Standards: Dolby Digital Surround, THX, High Definition Audio
Only if he added one (either at the time of purchase, or after),

Documentation

Audio
Type
Sigmatel 9227 audio codec
Internal 7.1 channel or PCI option cards
This,

dxdiag says Sound 1 is Speakers (High Definition Audio) and Sound 2 is Digital Output Device (SPDIF)
looks like the drivers either aren't installed, or have been corrupted somehow. If it is the Sigmatel onboard have a look around in this forum to find one newer than what Dell has listed on their site; over 2 years old, and there are newer Sigmatel drivers, just not listed for your comouter from Dell.

If it is the Xtreme Gamer same thing, the drivers from Dell are ancient (from mid-2207). About the best driver set going for the X-fi cards (not the Xtreme Audio though) is this,

SB X-Fi Series Support Pack 2.0 (05/15/2009) - Creative Labs
 

My Computer

System One

  • Manufacturer/Model
    Me
    CPU
    Athlon x2 7750 BE
    Motherboard
    Asus M4A78 Pro
    Memory
    2x2gb Kingston
    Graphics Card(s)
    Sapphire HD 4830
    Sound Card
    X-Fi Xtreme Music
    Monitor(s) Displays
    Acer P221w and Acer 1916w
    Screen Resolution
    1680x1050 and 1440x900
    Hard Drives
    2x80 GB Seagate 7200.10 in RAID0, 500 GB Seagate 7200.12
    PSU
    Antec Earthwatts 500W
    Case
    Antec Sonata III
    Cooling
    AC Freezer 64 Pro and a couple of 120 mm case fans
    Mouse
    Logitech G5 v2
    Keyboard
    Logitech Wave
    Internet Speed
    10000/1000

ComicBookGuy

New Member
Thanks, this worked great.

However, I have a different problem now. Whenever I plug in my CREATIVE headphone/mic set it still plays out in 5.1 - by that I mean only the left and right speaker sounds play thru the left and right headphones. I am not hearing anything from the middle or two back speakers. In my case, I cannot hear people in Steam voice chat, but I can hear the game sounds.

Thanks.
 

My Computer

System One

  • Manufacturer/Model
    Dell Dimension 9200
    Memory
    2 GB
    Graphics Card(s)
    NVIDIA 7900

stormy13

Member
Vista Guru
It set to Game Mode when playing games? You can also set it to headphones from within the Console Launcher/Game Mode options.
 

My Computer

System One

  • Manufacturer/Model
    Me
    CPU
    Athlon x2 7750 BE
    Motherboard
    Asus M4A78 Pro
    Memory
    2x2gb Kingston
    Graphics Card(s)
    Sapphire HD 4830
    Sound Card
    X-Fi Xtreme Music
    Monitor(s) Displays
    Acer P221w and Acer 1916w
    Screen Resolution
    1680x1050 and 1440x900
    Hard Drives
    2x80 GB Seagate 7200.10 in RAID0, 500 GB Seagate 7200.12
    PSU
    Antec Earthwatts 500W
    Case
    Antec Sonata III
    Cooling
    AC Freezer 64 Pro and a couple of 120 mm case fans
    Mouse
    Logitech G5 v2
    Keyboard
    Logitech Wave
    Internet Speed
    10000/1000

stormy13

Member
Vista Guru
Open the Creative Console Launcher (if you installed the daniel_k drivers you should have it) from either the Creative folder in the Start menu or from the Volume Panel icon in the notification area (if it is running). Then you can make all the changes from there (modes, speaker settings, mixer, EQ, etc).

Might be a good idea to grab this (you will have to right click, select Properties and click on Unblock before you can open it),

Creative Worldwide Support > X-Fi XtremeMusic

Click on "Quickstart user Guide" and download the manual (Filesize: 998.85 KB), and see what all your card can do.
 

My Computer

System One

  • Manufacturer/Model
    Me
    CPU
    Athlon x2 7750 BE
    Motherboard
    Asus M4A78 Pro
    Memory
    2x2gb Kingston
    Graphics Card(s)
    Sapphire HD 4830
    Sound Card
    X-Fi Xtreme Music
    Monitor(s) Displays
    Acer P221w and Acer 1916w
    Screen Resolution
    1680x1050 and 1440x900
    Hard Drives
    2x80 GB Seagate 7200.10 in RAID0, 500 GB Seagate 7200.12
    PSU
    Antec Earthwatts 500W
    Case
    Antec Sonata III
    Cooling
    AC Freezer 64 Pro and a couple of 120 mm case fans
    Mouse
    Logitech G5 v2
    Keyboard
    Logitech Wave
    Internet Speed
    10000/1000

ComicBookGuy

New Member
I actually installed the SigmaTel drivers, since I think that is what is meant to be used on my machine.
 

My Computer

System One

  • Manufacturer/Model
    Dell Dimension 9200
    Memory
    2 GB
    Graphics Card(s)
    NVIDIA 7900
Top