Solved Access Denied - External Drive

Frank C

Member
Access Denied
Hi ,
I want to delete some files/folders from a local network shared external drive.
These files/folders are copies of the "C" drive of a discontinued Vista machine.
The external drive is accessible to a Vista Laptop on the same network.
On that laptop I created a user account with administrator privileges where the user name is equal to the owner of the difficult files.
I turned off user account control and ran RMDIR /S from a elevated cmd prompt in safe mode.
I still get access denied.
I need a way to access these files to delete them.
Frank C
 

townsbg

~~тσωηsвg~~
Vista Guru
Gold Member
It doesn't matter if you created an account with the same user name because each account has a separate ID and that is what windows goes by. You need to take ownership of the folder and grant yourself access. If it won't let you do that over the network try doing so from the system connected to the hard drive.
 

Frank C

Member
Another Way
After many futile attempts to access the externaldrive without encountering the "Access Denied" stopper.
I went to Western Digital's Network Storage Manager tool and deleted the share from there (delete C_Drive_Share.png).
delete C_Drive share.png
It did work to free up the space It shows zero files and folders (C_drive.png).
C  _ Drive.png
It had a slight disadvantge in that the folder for the Vista_C_Drive is still present in Windows Explorer(Explorer_ c_drive.png).
Explorer_ c_drive.png
Townsbg, I will try to change the owner as you suggested to get rid of this. I am reluctant to disconnect the ExternalDrive from the router and connect it directly to the Vista Computer.
I don't have confidence that I can get it back on the local network successfully.
Barman, I did try the hidden administrator account in Win 10. I ran RMDIR /S in cmd prompt from safe mode. I sill got Access Denied.
Thanks
Frank C
 
Top