Solved All Windows-based services aren't working

MeganeT

Member
Yesterday, after visiting a website that may not have been secure, I found my Windows Security Center was turned off. Shortly after this McAfee removed a trojan from my computer. After doing a scan of my computer I re-opened Security Center. When I clicked "Turn on now" it said "The Security Center service can't be started". Following another thread's advice I did Start > Search 'services' > Security Center (which has nothing under Status and Disabled under Start-up type) > Properties and though I could change Disabled to Automatic (Delayed Start) when I clicked OK and re-clicked Properties it had turned itself back to disabled. Also, under Service Status it says Stopped, yet I cannot click Start.

I also found that Windows Firewall was not using the recommended settings. When I click Update Settings it says "Windows Firewall was unable to make the requested updates". Clicking 'Turn Windows Firewall on or off' a box saying "Windows Firewall settings cannot be displayed because the associated service is not running. Do you want to start the Windows Firewall service?" I click yes and it opens the settings box however it says I am using the recommended settings.

To add to my problems, clicking on Windows Defender on the side menu brings up this message: "Application failed to initialize: 0x800106ba. A problem caused this program's service to stop. To start the service restart your computer or search Help and Support for how to start a service manually". Since then my computer has been restarted twice and still no luck.

Lastly, whether it is a connected issue I'm not sure, however my Windows Live Messenger, when attempting to sign in, will begin to load, then stop working and close itself. Restarting didn't help this either.

Any advice at all on what might have caused this or how to fix any of these problems would be greatly appreciated.
 

My Computer

MeganeT

Member
Ah! Thankyou. It's all back now :)

I did have Automatic Updating turned off to try and make my computer go a little faster but I think I'll be keeping that on from now on.

Thanks again.
 

My Computer

richc46

Vista Guru
Gold Member
Your welcome.
Glad that it worked or you.
 

My Computer

System One

  • Manufacturer/Model
    Dell XPS420
    Memory
    6 gig
    Graphics Card(s)
    ATI Radeon HD3650 256 MB
    Sound Card
    Intergrated 7.1 Channel Audio
    Monitor(s) Displays
    Dell SP2009W 20 inch Flat Panel w Webcam
    Hard Drives
    640 gb
    Cooling
    Fan
    Mouse
    Dell USB 4 button optical
    Keyboard
    Dell USB
    Other Info
    DSL provided by ATT

wither 3

Vista Guru
Gold Member
What is the purpose of your question?
 

My Computer

System One

  • Operating System
    Vista Home Premium 64 bit SP2
    Manufacturer/Model
    Cyberpower
    CPU
    Intel Quad CPU Q6700 2.67 GHZ
    Motherboard
    NVIDIA 780i
    Memory
    4 GB
    Graphics Card(s)
    MSI GTX 560 TI Twin Frozr
    Sound Card
    Sound Blaster SB Audigy
    Monitor(s) Displays
    Viewsonic VG2436
    Screen Resolution
    1920x1080p
    Hard Drives
    Samsung HD 105SI
    WDC WD20
    Case
    Apevia XJupiter
    Cooling
    air
    Mouse
    Logitech MX 600
    Keyboard
    Logitech MX 3200
    Internet Speed
    30 Mbps
Top