Solved Auto play / run doesn't work anymore when USB Device is plugged in.

wazz64

Member
My Auto Run/Auto Play stopped working in Vista Home Premium 32 bit OS, I 've ticked the box Use Autoplay for all media devices in Control Panel / Hardware and Sound/ Autoplay. Also tried other options like I'd used before when it used to work.
Tried Reset all defaults.Nothing seems to fix it.
Sounds like a Registry issue??? But don't know!
Any ideas how to repair/fix this problem please.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    HP PAVILION DV9700 NOTEBOOK
    Mouse
    LOGITECH V220

ilikefree

Vista Guru
Gold Member
What anti-virus software do you use. If there is a virus on a USB my anti-virus (nod32) won't let auto run start. Try another device before you go into the registry.
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

wazz64

Member
Hi,

I'm running Kaspersky Internet Security but had the same problem with Mcafee and Norton,I've had this problem for some months now but just can't find a solution.
I've used Registry Repair Pro but it doesn't find anything either.

If I go to My Computer I can access any USB Device, External HD and Thumb drives there with no problems at all. It just won't bring up the Auto play Options.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    HP PAVILION DV9700 NOTEBOOK
    Mouse
    LOGITECH V220

ilikefree

Vista Guru
Gold Member
Last edited by a moderator:

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

wazz64

Member
Can't find it with the link, tried another link below from another user and downloaded it, only 72kb. Seems small.
Installed it,scan took about a millasecond to scan and DONE, but didn't ask where to scan or what drive to scan and then come up with nothing missing. Something wrong there!

I checked my registry after reading the My Digital Life page and noticed my Registry Key settings were these Default REG_SZ (Value not set) BindDirectlyToPropertySetStorage 0x00000000 (0) NoDriveTypeAuto REG_ DWORD 0x0000003c (60). The article said it should be 0×00000091. Could this be the problem? Very cautious about touching the registry and don't know how to change it if I was game enough to.
Also tried Auto Fix exe. It just crashes and says it stopped working.. Windows is looking for a solution blah blah!!!

Any suggestions?
 

My Computer

System One

  • Manufacturer/Model
    HP PAVILION DV9700 NOTEBOOK
    Mouse
    LOGITECH V220

ilikefree

Vista Guru
Gold Member
You should always back up your registry before making changes.
Right click the registry and select export, in the bottom left corner is the options All or Selected Branch. Pick all and save to your desktop.
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

Sweet

Banned
Hello Wazz64

Download and extract the ZIP file,
then click on Fix Autorun - Windows Vista.reg

I hope this helps
 

Attachments

My Computer

System One

  • Manufacturer/Model
    Acer Aspire 5738G-644G32MN
    CPU
    Intel Core 2 Duo - clockspeed 2000 MHz
    Motherboard
    Acer JV50
    Memory
    RAM 4 GB - SO-DIMM DDR3
    Graphics Card(s)
    NVIDIA GeForce - G105M - 512 MB
    Screen Resolution
    1366 x 768 Pixels
    Hard Drives
    Hitachi HTS543232L9A300
    320 GB - Type SATA - Speed 5400 rpm
    Mouse
    Logitech Wireless Mouse M505
    Keyboard
    Azerty
    Internet Speed
    Currently 14.5 MB/Sec which means 1.8 MB/Sec effective

ilikefree

Vista Guru
Gold Member
Also go to Services and see if Shell Hardware Detection is set to Automatic in the start drop down box.
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

ilikefree

Vista Guru
Gold Member
OK also check Plug and Play. Maybe even try SSDP Discovery,Remote Procedure Call (RPC),Windows Image Acquisition (WIA)

When you are in the properties section look at the dependencies and see that they have started.

You could also try Disabling Shell Hardware Detection, Reboot,Re-enable,Reboot.
Did you backup your registry?

You could try the registry change in the My Digital Life link I sent you but remember to back up the registry first.
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

wazz64

Member
Additional you can try both things

1.Try this program Removing unwanted AutoPlay Handlers in Windows XP and Windows Vista
2.Download ,unpack and import another fix to registry View attachment 20191
and restart computer
:) Thank you so much, I'm not real sure which program I used, I think it may have been the second one, AUTOPLAYFIX exe. Done exactly what you suggested, it changed the registry value to what it should have been automaticley restarted my pc and NOW it's finally working perfectly after almost 2 years of not working.

Thank you so much,I really do appreciate you helping me out..:party:
 

My Computer

System One

  • Manufacturer/Model
    HP PAVILION DV9700 NOTEBOOK
    Mouse
    LOGITECH V220

ilikefree

Vista Guru
Gold Member
Additional you can try both things

1.Try this program Removing unwanted AutoPlay Handlers in Windows XP and Windows Vista
2.Download ,unpack and import another fix to registry View attachment 20191
and restart computer
:) Thank you so much, I'm not real sure which program I used, I think it may have been the second one, AUTOPLAYFIX exe. Done exactly what you suggested, it changed the registry value to what it should have been automaticley restarted my pc and NOW it's finally working perfectly after almost 2 years of not working.

Thank you so much,I really do appreciate you helping me out..:party:
SWEET glad to hear that's fixed I will click the ! symbol and mark it solved.
 

My Computer

System One

  • Manufacturer/Model
    Lenovo Thinkpad T400
    CPU
    Intel Mobile Core 2 Duo P8700 @ 2.53GHz
    Motherboard
    LENOVO 64734VM
    Memory
    2.00GB Single-Channel DDR3 @ 531MHz
    Graphics Card(s)
    Intel Mobile Intel 4 Series Express Chipset Family
    Sound Card
    Conexant 20561 SmartAudio HD
    Monitor(s) Displays
    15 inch
    Screen Resolution
    1280 x 800
    Hard Drives
    1x 180GB Intel 530 series SSD
    1 x 120GB Hitachi 5400rmp
    1 x 650GB Western Digital Elements 5400rpm
    1x 1Tb Western Digital Elements 5400rpm
    Internet Speed
    Medium for New Zealand
    Other Info
    Weakest part of my computer is the graphics chipset.
    Only ever used a laptop.
    Also use USB Freeview TV Card
    Lenovo Docking Station
    External Speakers
    Other bits a pieces as needed

wazz64

Member
Thank you to all the kind people who went out of their way to help me out with this problem.

I'm so happy that it is now working, used autoplayfix.zip, it changed the registry value to what it should have been, I restarted my pc and autoplay worked as soon as I plugged in my thumb drive.
So HAPPY NOW...........THANKS ALL............
 

My Computer

System One

  • Manufacturer/Model
    HP PAVILION DV9700 NOTEBOOK
    Mouse
    LOGITECH V220

wazz64

Member
Additional you can try both things

1.Try this program Removing unwanted AutoPlay Handlers in Windows XP and Windows Vista
2.Download ,unpack and import another fix to registry View attachment 20191
and restart computer
:party:Thank you so much, I'm not real sure which program I used, I think it may have been the second one, AUTOPLAYFIX exe. Done exactly what you suggested, it changed the registry value to what it should have been automaticley restarted my pc and NOW it's finally working perfectly after almost 2 years of not working.

Thank you so much,I really do appreciate you helping me out..:D
 

My Computer

System One

  • Manufacturer/Model
    HP PAVILION DV9700 NOTEBOOK
    Mouse
    LOGITECH V220

adeanda

New Member
Thank you to all the kind people who went out of their way to help me out with this problem.

I'm so happy that it is now working, used autoplayfix.zip, it changed the registry value to what it should have been, I restarted my pc and autoplay worked as soon as I plugged in my thumb drive.
So HAPPY NOW...........THANKS ALL............
Does this zip also work for vista 64?
 

My Computer

Flavius

Expelled
Thank you to all the kind people who went out of their way to help me out with this problem.

I'm so happy that it is now working, used autoplayfix.zip, it changed the registry value to what it should have been, I restarted my pc and autoplay worked as soon as I plugged in my thumb drive.
So HAPPY NOW...........THANKS ALL............
Does this zip also work for vista 64?
Yes of course.It owrks for x32 & x64 as well .
 

My Computer

Top