• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Automatically connect to unsecured wireless networks in Vista

Hi there,

Running Vista Home Premium withOUT SP1.

I'm trying to automatically connect to the same unsecured wireless network. When I connect to it I choose to Save it.

When I go to "Network and Sharing Center" --> "Manage wireless networks" I see the unsecured wireless network in the list. When I right click on it and click Properties I see this dialog box(Wireless Network properties):

no options for automatically connect :(

I'm sure it is possible as I have seen this screenshot:

From what I have found out so far, when you choose to Save a network an xml file is created in:
with a filename like:
I've compared the xml files created when you join an unsecured network and when you join a secured network. I noticed that the secured networks have these two extra keys in the xml file:
the former maps to "Connect even if the network is not broadcasting" and the latter maps to "Connect to a more preferred network if available" checkboxes when you open up the "Wireless Network properties" dialog box. Another key is:
which maps to "Connect automatically when this network is in range". I've tried editing this value from "manual" to "auto" and rebooting but when windows loads back in I find that the xml file has been deleted.

I've also tried saving this xml file to another directory, editing the <connectionMode> and changing it from "manual" to "auto" and then using the netsh command from the command line:
C:\Users\justincase>netsh wlan add profile filename="unsecuredwlan.xml" interface="Wireless Network Connection"
Failed to add the profile. Error x8000E: Automatic connection cannot be set for an ad hoc network.

I've tried to track down either the file or registry entry which controls this behaviour but have hit a dead end. I do know that when I run the netsh command that these files are accessed:

Any pointers or help would be greatly appreciated.


My Computer

Users Who Are Viewing This Thread (Users: 1, Guests: 0)