• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Automaticaly turn on wireless capability at startup

dHb

New Member
#1
Hello,

I have a problem with the switch button for my wireless network adapter on my laptop. It doesn't turn the radio on when the laptop restarts. I suppose, it stays on off no matter what the button position is.

So at every boot one has to:
- wait until it fails, (so all programs needing network at startup fail too)
- click on the network icon in the system tray, diagnose and repair
- wait for Vista to work out that there is no wireless connectivity,
- click on turn on wireless connectivity then wait until Vista repairs itself.

After that is works happily until the next reboot.
I repeat - it is not some software option. The on/off switch doesn't work (nor the function key).

Question 1 Can I switch on the connectivity on startup to allow this to
happen seamlessly. Is there a cmd command which I can setup to run at startup.

Question 2 Is there some way of creating a shortcut
which would allow the click of one button rather than going through the
learning experience each time that the connectivity requires to be switched
on.

Thanks for reading
 

roy69

47,65,65,6B
Vista Guru
Gold Member
#2
First, what type of laptop have you got? What make and model is it?
Have you had a look in your bios to see if there is a default state for the wireless.
My backup laptop has wireless and boots with it is the same state as it was when the system is closed down.
You may have to change the order of things that start up when you switch on your laptop or even put in a delay for some programs so that they do not start untill your laptop is connected to the wireless network.
 

dHb

New Member
#3
I don't think it matters, but I have Asus F3SV.
Yes, i searched the bios for an option, there isn't such.

I wish i had like your laptop, but mine starts every time with radio turned off.

When it starts, the diode for Wireless does not emit light, after vista repairs it, it starts to. That diode shows, if the radio is enabled. It should be controlled by the switch.

It is not really fatal, that some programs fail at startup, its that I have to "turn on wireless capability" every time it boots. It is very anoying, you know.

Is there no such command, to turn on wireless capability without going through the diagnose and repair?? Or perhaps some kind of tool, which instructs Vista to turn the radio on without diagnosing (after all, i know why it can't connect, but there is no such option to choose)


Thanks for replying
 

echrada

Vista Guru
#6
Yes. If that is done and you cannot find any other fault or error then I would think that you have, as you already stated a faulty switch that needs professional attention.

Unless you are brave enough to open the casing of your laptop and have a look round - normally an easy job if you know what you are doing or looking for.

See if you can find a service manual for your specific laptop and have a look at the procedure.
 

dHb

New Member
#7
I will open it with pleasure, but it is in warranty.
So I must be absolutely sure there is no software solution.
And what is the chance that i could fix it? Not big.
I could let it be repaired by asus, which are at best 10 days off. That i cannot afford.

Such thing as service manual or motherboard map or something is for laptops nowhere to find. Those things get not published.

Today I thought, it shoud be easy to invoke the diagnose utility or turn the antenna on or off from command prompt. But, as it seems, its something no one needs and therefore no one knows how it is done.
 

dHb

New Member
#9
Those manuals are about how to put your battery on.

I did find somewhat as solution:
At startup one can start the Windows Mobility Center, there are a couple of options and one of them is to turn the antenna of the wireless card on or off. So this is much more comfortable and time inexpensive, but not perfect.

I'm searching for another solution and if i find such, i'll post.

Thanks
 
#10
This is not an Asus problem. The original poster doesnt need to worry about looking through his manual or contacting Asus. Its a Vista problem. Why?

Because Im using a brand new Lenovo T500 and have the EXACT same problem. No idea how to fix it. Ive been googling for suggestions which is how I found this thread.

Turn on computer.
No wireless connectivity.
Have windows diagnose problem.
Says, "Wireless capability has been turned off on this computer."
Ask it to turn capability back on.
Everything works fine.

You have to do it every single time you turn on or reboot the conmputer. Its beyond annoying and there should be some fix out there somewhere.

(Yes, my computer has a wireless antena switch on the front of the keyboard. Yes it is turned on and stays turned on. This is not the problem either.)

Anyone know?
 

dHb

New Member
#11
It is interesting to hear that the same problem exists on a new laptop. I thought, there is a hardware problem with my switch. This is still possible though, are you completely sure your switch functions correctly? For example, can you turn wireless on or off during work under vista? Or with the function key? Cause my switch doesn't do these things. What is the state of your wireless led indicator upon start?

Did you read my previous post?
With Windows Mobility Center you can turn wireless on without the need of running the diagnose function.

That saves some nerves.
 
#12
Yes, I am entirely sure my switch is working. Do a google search for "wireless capability off" and you will find numerous threads such as this one with many other people having the same errors. So far though I have yet to find any answer.

Most of the suggestions are "Is your switch on?"
 

Mace

New Member
#13
dHb,
I have the exact same problem with my Fujitsu Siemens laptop, yes it's vista, yes it costs you nerves, no it's not your switch.

Dunnow if this will work but try it:

Try going to network and sharing center => manage wireliss networks => adapter properties => configure => power management => uncheck "Allow the computer to turn off this device to save power"
 
#14
I had the same problem with my notebook for like a year. The switch would be on and the antenna would be lit but still nothing. The way i fixed mine, and i know alot of people wont like but it works, is to reset it. But when you do make sure the switch is on. I mean the switch on the side and the antenna both. You wont be able to use your computer for like an hour but at least u wont have to go through the annoying set up. I know it works because ive done it on my computer 3 times. Hope this helps. P.S. if theres anything you really need thats on your computer save it on to a usb drive.
 

a93

New Member
#16
i think it's the power supply settings, like the default power-supply profile is set to save energy - and therefore shut down the wireless connection (softwerely, not from the hardwere).

trying to find the option about the wireless, and if not - just make a non-power-saving profile and see if it helps
 
#18
Hi,Broughden
if your device is still in warranty takeit to where you got it from and have them send it to the manufacture to reapir it.or check Microsoft Corporation for any updates that will fix this problem the only other thing i would recomend is eitther a proffesional computer tech or contacting microsoft.

skript kiddie
 
#19
I have a Lenovo T500 with Vista Home Premium. How do I turn on the wireless radio?
hi fcpceo
welcome to vista forums,
your wireless radio should be by default enabled, if not go to the PC that is connected to your router via cat5 (Ethernet) cable and in the address bar typr: 192.168.2.1 this should bring you to the routers setup page type in your password(default should be blank or usr nme:admin / passwrd: admin) scroll down the menus to wireless and tick enable wireless radio. you can do this on some routers by accessing their LCD screen on the surface.
 
#20
I am having this same problem with my Asus AFTER I sent it in for repairs with the screen. I didn't have this problem before and now I don't know how to get it to stop. I'm having to restart it several times, til eventually it tells me Radio is off and I can click it and turn it on, but until that happens, it doesn't even give me an option and I'm stuck with no internet...