Bluetooth Peripheral Device not functioning

mrigankp

New Member
Hi. I am running a laptop on vista ultimate 64-bit OS. Recently, I've been encountering problems with the bluetooth peripheral device. I want to pair my Sony Ericsson k850i to my laptop. Evrythng wrks fine but den I get dis error. Wen I try 2 reinstall or update the driver thru Device Manager, it dusn wrk. I also tried 'search the internet' and 'browse your computer' options. But, to no avail. Plz help me. Thnx.
 

My Computer

System One

  • Manufacturer/Model
    HP 6314tx
    CPU
    Intel C2D 1.73ghz
    Memory
    2gb
    Graphics Card(s)
    Nvidia GEFORCE GO 7400 128mb
    Hard Drives
    Hitachi SATA 160gb
    Other Info
    External Seagate 1TB HDD, Logitech 5.1 speakers

AstaLaVista

Lost in Cyberspace
Vista Pro
What error do you get?

What doesn't work... why?

Explaining in detail what your dongle is doing might help us help you better. I am going to have to say that the bluetooth dongle software you got does not support Vista x64, meaning, those drivers are only for XP or Vista 32 (if anything).

Was it working before or it never worked on your Vista 64 OS?
 

My Computer

System One

  • Manufacturer/Model
    Custom Built
    CPU
    Intel Q9650 w/CM V8 Cooler...
    Motherboard
    EVGA 780i SLI FTW... Latest Bios & Drivers
    Memory
    Corsair Dominator 8GB (4 x 2GB) PC2-8500C5D
    Graphics Card(s)
    EVGA GTX260
    Sound Card
    Realtek High Def Onboard
    Monitor(s) Displays
    Acer 22" LCD Widescreen
    Screen Resolution
    1680 x 1050
    Hard Drives
    WD Velociraptor 160GB
    Samsung Sata 750GB
    Maxtor External 160GB
    PSU
    PC Power & Cooling 750w Silencer
    Case
    Thermaltake Speedo Advance
    Cooling
    Air Cooled... See CPU
    Mouse
    Logitech G7
    Keyboard
    Logitech G15
    Internet Speed
    Comcast 6MB Broadband
    Other Info
    Linksys WRT54G router

mrigankp

New Member
Ok, here's a screenshot.
 

Attachments

My Computer

System One

  • Manufacturer/Model
    HP 6314tx
    CPU
    Intel C2D 1.73ghz
    Memory
    2gb
    Graphics Card(s)
    Nvidia GEFORCE GO 7400 128mb
    Hard Drives
    Hitachi SATA 160gb
    Other Info
    External Seagate 1TB HDD, Logitech 5.1 speakers

mrigankp

New Member
Now, when I right click on 'bluetooth peripheral device' and try to 'update driver software' it doesn't work. Like I have mentioned in the previous post, this occurs when I try to pair my k850i with my laptop.

It was working before. It has never happened before. It happened just out of the blue.
 

My Computer

System One

  • Manufacturer/Model
    HP 6314tx
    CPU
    Intel C2D 1.73ghz
    Memory
    2gb
    Graphics Card(s)
    Nvidia GEFORCE GO 7400 128mb
    Hard Drives
    Hitachi SATA 160gb
    Other Info
    External Seagate 1TB HDD, Logitech 5.1 speakers
Top