Bootmgr is missing

ByLine
You get this error while booting into windows
Synopsis
This tutorial will show you to get rid off this error.
Issue : Unable to boot to windows error “bootmgr is missing”

Note   Note
Before trying the step below please run startup repair first


Solution :




1. Boot the computer from Vista OS DVD.
  • Click on Repair Your Computer.

  • Click on Command prompt.

  • At the X:\Sources prompt, type bcdedit /export C:\BCD_Backup and press <Enter>

  • Type c: and press <Enter>.

  • At the C:\ prompt, type cd boot and press <Enter>.

  • At the C:\Boot prompt, type attrib bcd -s -h -r and press <Enter>.

  • At the C:\Boot prompt, type ren c:\boot\bcd bcd.old and press <Enter>.

  • At the C:\Boot prompt, type bootrec /rebuildbcd and press <Enter>.

  • The Boot Configuration File will be rebuilt at this point. Once it finishes, type exit and press <Enter>. Click the Restart button . ;)
 

Attachments

  • thumb_Hard_Drive.png
    thumb_Hard_Drive.png
    8.3 KB · Views: 153
Last edited by a moderator:

Kernel

Vista User
Power User
Hi Dinesh,

Good one. I would like to add few points here. Instead of trying RebuildBCD/Recreate as a first step, we could try startup repair at least 3 to 5 times which would search for problems and fix it.

Here are some commends

bootrec /RebuildBcd - Use this option when you must completely rebuild the BCD
bootrec /FixMbr - writes a Windows Vista-compatible MBR to the system partition
bootrec /FixBoot - writes a new boot sector to the system partition by using a boot sector that is compatible with Windows Vista
 

My Computer

System One

  • Manufacturer/Model
    Custom
    CPU
    AMD
    Motherboard
    ASUS
    Memory
    2GB
    Graphics Card(s)
    Nvidia 256MB
    Sound Card
    Creative 7.1
    Monitor(s) Displays
    19" Viewsonic and Sony 26" S Series TV
    Screen Resolution
    1920x1080
    Hard Drives
    Sata (1 TB) and IDE (350GB)
    Mouse
    Optical (Wireless)
    Keyboard
    Multimedia (Wireless)
    Internet Speed
    2MB

SIW2

Vista Guru
Gold Member
Hi Dinesh,

If the automated startup repair doesn't do it - even after a few goes , as Prasath says,

I would try this first

bootrec /fixmbr

your dvdrom drive letter:\boot\bootsect.exe /nt60 all /force

del C:\boot\bcd

bootrec /rebuildbcd

Close cmd prompt, remove dvd, Reboot.

Fingers crossed.

SIW2

your dvdrom drive letter: needs to be the letter as seen in WinRe, e.g. E: or F: etc.
 
Last edited:

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

mattfree99

New Member
I have the same problem with bootmgr is missing.
I just went through the steps listed.
Just at At the C:\Boot prompt, type ren c:\boot\bcd bcd.old and press <Enter>.
It states there is a duplicate file or file is not found.

 

My Computer

dinesh

Vista Expert
Vista Guru
Hi mattfree, Try the above method from SIW2.
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

mattfree99

New Member
OK, just tried that and it states.

Successfully scanned Windows installations.
Total identified Windows installations: 0
The operation completed successfully.
Just has nothing changed.

I was able to reformat this once before when the hard drive was full of games with no problems. I even send a email to emachines.com and they want a receipt to help in any way.
 

My Computer

dinesh

Vista Expert
Vista Guru
I would recommend you to do a clean install using Vista DVD. Sorry mate but some problems are unfixable withour reinstalation. :(
 

My Computer

System One

  • Manufacturer/Model
    Compaq
    CPU
    intel core 2 duo T 5550 @ 1.83 MHz
    Motherboard
    intel 965 chipset family
    Memory
    2 GB DDR 2 SD RAM @ 667 MHz
    Graphics Card(s)
    On board upto 358 MB RAM
    Sound Card
    Onboard
    Monitor(s) Displays
    15"
    Hard Drives
    160 GB WDC

mattfree99

New Member
I was trying to do a clean installation.
Seems I have no drivers not able to do a clean installation of Vista.
The computer does not see any thing on the CD.
So now it's back to XP.
Edit note.
I just check my older computer and the Windows Vista says it will work on it.
So maybe after I get the newer computer running again on XP I will be able to install the Vista afterward.

Thanks anyhow.
 
Last edited:

My Computer

arthur247

New Member
hi i have a sony vaio vgn-ar61zu i installed vist due to my laptop crashing anyway half way through the installation i got an error. I restarted my laptop all i get is "bootmgr is missing press ctrl+alt+del to restart" even with the vista cd inside it it will not go pass this stage :confused:

Ive removed the 2 hardrives and tried booting it from just the cd/dvd drive it says operating system not found. I removed the cd drive and replaced it just to make sure its not the cd drive which is faulty but im getting the same problem wit the new drive so the cd drive is ok too :confused:

Any ideas what it can be it wont go into bios nor will it go pass bootmgr is missing
 

My Computer

SIW2

Vista Guru
Gold Member
Try going into Bios and disabling AHCI mode , set it to ATA or IDE, see if that helps.
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

arthur247

New Member
thanks for the reply but it wont go into bios all im getting is BOOTMGR is missing press ctrl+alt+del to restart

it wont boot all i get is “bootmgr is missing” even with the cd inside it
 

My Computer

SIW2

Vista Guru
Gold Member
Can you ( not it ) go into Bios?

Startup and press F2 or Del, or whatever it says for "setup" on the screen.
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

arthur247

New Member
Can you ( not it ) go into Bios?

Startup and press F2 or Del, or whatever it says for "setup" on the screen.

No "i" cant go into bios as soon as it loads up i "del" it wont let me go into bios whereas it did before just goes straight onto "Bootmgr is missing" this is whats doing my head in :confused:
 

My Computer

arthur247

New Member
ive used hirens boot cd ran some diagnostics rebooted its letting me go into bios now so im getting somewhere :)
but in boot i have

boot priority order

1) usb optical drive *
2) internal optical drive
3) floppy disk drive
4) usb flash *
5) usb hard disk drive*
6) internal hard disk drive
7) network
 

My Computer

SIW2

Vista Guru
Gold Member
If you have any external drives/devices connected - disconnect them.

Set the Hd you want to install on as the first boot device.

See if the installation continues.

If not,

Use the boot pop up menu selection on the startup screen ( e.g. press f11 or whatever for "boot menu" )

Arrow down to cdrom drive - put the dvd in , press enter.

It will probably ask to confirm - press enter again.

Hope it helps
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

arthur247

New Member
i have no external devices connected are you on msn i think ive just deleted some raid settings in bios i have no idea about the bios settings :( please help me out
 

My Computer

SIW2

Vista Guru
Gold Member
That is ok.

See if you can find the disk controller and set it to ATA - not AHCI.

You might just have donesomething like this :

Changed RAID ON to RAID AutoDetect / ATA

That should be fine.

Then try as per my previous post.
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb

SIW2

Vista Guru
Gold Member
Bios are not all the same - you just need to look for something similar.

Where you saw those Raid settings is probably it.
 

My Computer

System One

  • Operating System
    Vista
    CPU
    Intel E8400
    Motherboard
    ASRock1333-GLAN R2.0
    Memory
    4gb DDR2 800
    Graphics Card(s)
    nvidia 9500GT 1gb
Top