Solved BSOD on installing zte data card AC2739.


New Member
My Toshiba Satellite A100 - PSAAKL - 00M006 runs on genuine Windows Vista Home Basic - SP2 with auto updates enabled and is up-to-date. Though the system is slow (old model), and the Bios is 2007, there has been no major problem. However, when I tried to install zte data card Ac2739, windows consistently blue screens. I've ascertained that there's no problem with the data card itself. I have done the memory test, checkdisc, and sfc /scannow, but no issues. I've tried to install it in Safe Mode,Clean Boot Mode and with Avast disabled, but no go. Whocrashed says the probable culprit is cdrom.sys, but the installed driver version (2006) is the latest one. I've disabled the driver and tried to install the data card, but still the same result.

Though the Minidump folder contains earlier reports, only those from 13.02.2015 are relevant, and all these are caused by inserting the data card. The USB port is ok, since I am using it to access GPRS through my phone.

Any help is appreciated. Thank you. View attachment 28825

My Computer

System One

  • Manufacturer/Model
    Toshiba Satellite A100 - PSAAKL - 00M008
    1.73 gigahertz Intel Core Duo
    ATI SB450 Rev0.4b
    1 GB
    Graphics Card(s)
    Sound Card
    Realtek High Definition Audio
    Monitor(s) Displays
    Laptop screen