Solved cannot restore REALTEK HD audio

dave 851

Member
I have a HP PC with Vista(32bit) Home Premium. Recently I had some hardware issues and I now find I cannot install or reinstall Realtek HD Audio drivers on my system. I still have the icons and links to Realtek HD Audio Manager in programs, start, and in control panel (nothing happens on clicking or opening those links).

I cannot get Realtek to show in audio output/playback devices. Now take note I have an extra PCi Sound Card installed on my PC. I use the 2nd card for cue functions in a DJ music program (VirtualDJ) and I have previous had both Realtek and the PCi show up in output/playback devices. I had simply enabled Realtek as the default and everything worked just fine. C-Media, Realtek and HD-3000 all showed and could be enabled disabled defaulted etc. without issue.

Additional note: I've even tried reinstalling the original (outdated) file from HP's website sp37543.exe but i get an error about specs or config not suitable for this file. I've also tried doing all this troubleshooting in safe mode and even downloaded a driver sweeper from another website.

Now I see only the PCi software (C-Media PCi software) show up and listed in device manager/sound,video game controllers along with HD-3000 (webcam).

I've uninstalled reinstalled disabled enabled, even tried loading as legacy hardware. It never installs and under installing legacy hardware it loads and installs, only to tell me there was an error (invalid access to memory location).

Any ideas?

I've even tried installing the original drivers from HP's site sp37543.exe. But that doesnt install it gives me some error regarding configuration of specifications.
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    HP a6603w
    CPU
    Intel(R) Pentium(R) Dual CPU E2220 @ 2.40GHz
    Motherboard
    nVidia MCP73
    Memory
    2048 MB DDR2-SDRAM (PC2-6400 / 800 MHz)1024 MB DDR2-SDRAM (PC2-6400 / 800 MHz) Total 3gigs
    Graphics Card(s)
    NVIDIA GeForce 7100 / NVIDIA nForce 630i
    Sound Card
    Realtek High Definition Audio - 6.0.1.5789, 2-11-2009
    Monitor(s) Displays
    HP w2007 (HP w2007 Wide LCD Monitor)1680 x 1050 (32-bit) (60 Hz)
    Screen Resolution
    1680 x 1050 (32-bit) (60 Hz)
    Hard Drives
    WDC -320 GB Main Hard Drive
    ST3160812A - 149.05 GB ATA drive (secondary hard drive)

    Hitachi Ultra Speed USB Ex Drive 500 gb

Lottiemansion

Vista Guru
Gold Member
Hi,

I would suggest, removing the C-media card & booting into the BIOS & forcing the HP on-board sound device as active (Not Auto or disabled).

Reboot the system as normal & load the HP website drivers not auto install drivers from within Windows. Once that is working re-introduce the C-media card.

OK?
 

My Computer

System One

  • Manufacturer/Model
    HP-Pavilion m9280.uk-a
    CPU
    2.30 gigahertz AMD Phenom 9600 Quad-Core
    Motherboard
    ASUSTek Computer INC. NARRA3 3.02
    Memory
    3582 Megabytes Usable Installed Memory (4 Gig)
    Graphics Card(s)
    ASUS NVIDIA Geforce GTS450
    Sound Card
    Realtek High Definition 7.1 Audio (HP drivers)
    Monitor(s) Displays
    HP w2408 24.0" (Dual monitor)
    Screen Resolution
    1920 * 1200, 1920 * 1200
    Hard Drives
    3*500 Gigabytes Usable Hard Drive Capacity
    Plus 2x USB (160Gig each) external HDD
    BluRay & DVD Weiters
    HL-DT-ST BD-RE GGW-H20L SCSI CdRom (Bluray RW) Device
    AlViDrv BDDVDROM SCSI CdRom (Blueray) Device
    TSSTcorp CDDVDW TS-H653N SCSI CdRom
    Internet Speed
    40 Meg

dave 851

Member
thanks for the suggestion. i actually thought i would or should do that, but i was hoping for an easier one lol. but i will physically remove the secondary card .. i'll do that today and get back. thanks
 

My Computer

System One

  • Manufacturer/Model
    HP a6603w
    CPU
    Intel(R) Pentium(R) Dual CPU E2220 @ 2.40GHz
    Motherboard
    nVidia MCP73
    Memory
    2048 MB DDR2-SDRAM (PC2-6400 / 800 MHz)1024 MB DDR2-SDRAM (PC2-6400 / 800 MHz) Total 3gigs
    Graphics Card(s)
    NVIDIA GeForce 7100 / NVIDIA nForce 630i
    Sound Card
    Realtek High Definition Audio - 6.0.1.5789, 2-11-2009
    Monitor(s) Displays
    HP w2007 (HP w2007 Wide LCD Monitor)1680 x 1050 (32-bit) (60 Hz)
    Screen Resolution
    1680 x 1050 (32-bit) (60 Hz)
    Hard Drives
    WDC -320 GB Main Hard Drive
    ST3160812A - 149.05 GB ATA drive (secondary hard drive)

    Hitachi Ultra Speed USB Ex Drive 500 gb

dave 851

Member
Okay did the physical disable of the second sound card and booted up.. and as you said, realtek loaded. i'll now reinstall the hardware for the second card and load its drivers, shouldnt be anymore issues. thanks again
 

My Computer

System One

  • Manufacturer/Model
    HP a6603w
    CPU
    Intel(R) Pentium(R) Dual CPU E2220 @ 2.40GHz
    Motherboard
    nVidia MCP73
    Memory
    2048 MB DDR2-SDRAM (PC2-6400 / 800 MHz)1024 MB DDR2-SDRAM (PC2-6400 / 800 MHz) Total 3gigs
    Graphics Card(s)
    NVIDIA GeForce 7100 / NVIDIA nForce 630i
    Sound Card
    Realtek High Definition Audio - 6.0.1.5789, 2-11-2009
    Monitor(s) Displays
    HP w2007 (HP w2007 Wide LCD Monitor)1680 x 1050 (32-bit) (60 Hz)
    Screen Resolution
    1680 x 1050 (32-bit) (60 Hz)
    Hard Drives
    WDC -320 GB Main Hard Drive
    ST3160812A - 149.05 GB ATA drive (secondary hard drive)

    Hitachi Ultra Speed USB Ex Drive 500 gb

Lottiemansion

Vista Guru
Gold Member
Hi,

Now go back in to the BIOS & reset it to Auto.

All should be OK & back to normal after that. I think the issue was caused by a Windows sound driver update (That is what happened to my system).

Paul H.
 

My Computer

System One

  • Manufacturer/Model
    HP-Pavilion m9280.uk-a
    CPU
    2.30 gigahertz AMD Phenom 9600 Quad-Core
    Motherboard
    ASUSTek Computer INC. NARRA3 3.02
    Memory
    3582 Megabytes Usable Installed Memory (4 Gig)
    Graphics Card(s)
    ASUS NVIDIA Geforce GTS450
    Sound Card
    Realtek High Definition 7.1 Audio (HP drivers)
    Monitor(s) Displays
    HP w2408 24.0" (Dual monitor)
    Screen Resolution
    1920 * 1200, 1920 * 1200
    Hard Drives
    3*500 Gigabytes Usable Hard Drive Capacity
    Plus 2x USB (160Gig each) external HDD
    BluRay & DVD Weiters
    HL-DT-ST BD-RE GGW-H20L SCSI CdRom (Bluray RW) Device
    AlViDrv BDDVDROM SCSI CdRom (Blueray) Device
    TSSTcorp CDDVDW TS-H653N SCSI CdRom
    Internet Speed
    40 Meg
Top