• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Cannot update anything, 80080005

Posts
5
#1
I've been trying to get Automatic Windows Updates to work for quite some time now, and I've got the error code 80080005 every time. I'm currently trying to manually update to vista service pack 2 and am getting the same error code.

I've also been trying to manually update other windows components, like .NET, and it fails on me everytime. I read in one troubleshooting thread that windows update needs to be active for some of these to work. Nothing I have done works, and I can't seem to find any threads about this. The only things I ever find in a search is people confused by the problem with no surefire way to fix it. Anyone familiar with this?
 

My Computer

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
Wale's

Posts
2,685
#2

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set
Posts
5
#3
I did the scan, 1 registry key infected and removed.
"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\NoActiveDesktopChanges (Hijack.DisplayProperties) -> Bad: (1) Good: (0) -> Quarantined and deleted successfully."

I tried to run the SFC commands, as I have tried to do before (found that post before one time) and I cannot run it: "Windows Resource Protection could not start the repair services." No error code, and it does it everytime on every scan or verify command.

Thank you all for any help on this
 

My Computer

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
Wale's

Posts
2,685
#4
"Windows Resource Protection could not start the repair services."

There are as many "fix's" for this as there are for windows not updating, but i think if you can get this problem solved it will sort the other one.

Here are a "few" links with possible solutions.


Fix SFC problem “Windows Resource Protection could not start the repair service” in Windows Vista - iTechtalk

Fix "Windows Resource Protection could not start..." when trying to run SFC : MAC-NET Secures IT

Fix for Error "Windows Resource Protection could not start the repair service" When Running SFC in Vista - The Winhelponline Blog

Give it a try and please post your results. Thanks and good luck.
 

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set
Posts
5
#5
OK. I tried what these said with no results. The Windows Modules Installer can't even start : "Error 126: The specified module could not be found." . I'm trying to search for other ways to get the SFC running correctly now.

Anymore ideas? I'm going to try a safemode sfc....
 

My Computer

Posts
5
#6
Here's a fun tidbit. SFC didn't run in safe mode (half didn't expect it to) but then I remembered I could run SFC from my windows disc if you boot cmd from CD. I fully expected that to work. No luck. It actually gave me the generic "this will take time" sort of message, then almost instantly I got the same error/ cannot be done message.

Any other thoughts? I would LOVE to avoid formatting and reinstalling.
 

My Computer

stoneys-nutz

Gamerholic
Vista Guru
Gold Member
Wale's

Posts
2,685
#7
You probaly did this, but did you run this from an elevated command prompt ?, if not try that. Re-formatting is a last resort, i still think if you can fix one the other will follow without too much kicking and screaming.
 

My Computer

System One

  • Manufacturer/Model
    Self Build
    CPU
    QX9650 (black box) [email protected]
    Motherboard
    Asus P5Q Premium
    Memory
    8GB-4x2GB Corsair Dominator DDR 2-1066
    Graphics Card(s)
    2 x ASUS EAH 4870 X 2 (Quad)
    Sound Card
    Supreme FX 2
    Monitor(s) Displays
    Fujitsu Siemens 22inch flat screen
    Screen Resolution
    1680x1050
    Hard Drives
    150 Gig WD Raptor
    300 Gig Maxtor
    300 Gig Maxtor, (External)
    PSU
    CoolerMaster 1000
    Case
    CoolerMaster N-Vidia stacker 830
    Cooling
    Noctua NH-U12P x 1x120mm fan, 6x120mm case fans
    Mouse
    Logitech G5
    Keyboard
    Logitech G15
    Internet Speed
    20Mbps
    Other Info
    Audio FX Pro 5+1 gaming head set
Posts
15
#8
Has anybody come up with a solution to the windows update 80080005 error where the windows modules installer gives error 126. I have this exact problem with vista business x32.


:confused::confused::confused::cry:
 

My Computer

delphin

Eager to learn
Vista Pro
Chennai

Posts
636
#10
Has anybody come up with a solution to the windows update 80080005 error where the windows modules installer gives error 126. I have this exact problem with vista business x32.


:confused::confused::confused::cry:
hi,

Thats why i always hate reg cleaners....

Try this registry entry View attachment cid.reg


Let me know the result :)
 

My Computer

System One

  • Manufacturer/Model
    Wipro
    Motherboard
    Intel dq35j0
    Memory
    8 Gb
    Graphics Card(s)
    inter express chipset
    Sound Card
    Realtek
    Monitor(s) Displays
    Wipro
    Screen Resolution
    1024*768
    Hard Drives
    500 gb
    Mouse
    Dell
    Keyboard
    DELL
    Internet Speed
    100 mbps(office lan)

delphin

Eager to learn
Vista Pro
Chennai

Posts
636
#13
Has anybody come up with a solution to the windows update 80080005 error where the windows modules installer gives error 126. I have this exact problem with vista business x32.


:confused::confused::confused::cry:
hi,

Thats why i always hate reg cleaners....

Try this registry entry View attachment 14358


Let me know the result :)

Tried this now have error 80070424
This error is related to bits service..

Let us recconfigure bits service, To do that follow my steps,

1. Click Start, click Run, type services.msc, and then click OK.
2. Double-click Background Intelligent Transfer Service.
3. In the Startup type box, click Automatic(delayed start), and then click Apply.
4. Click the Log On tab, and then verify that the service is enabled in every hardware profile that
is listed. If the service is disabled in one or more hardware profiles, click the hardware profile,
click Enable, and then click Apply.
5. Click the General tab, and then click Start.

If that's all okay, then perhaps

1. Click Start.
2. Choose Run.
3. In the Run box, type (pressing okay after the command) Regsvr32 QMGR.DLL

Otherwise reinstall Bits. Its available here

Let me know the result :)
 

My Computer

System One

  • Manufacturer/Model
    Wipro
    Motherboard
    Intel dq35j0
    Memory
    8 Gb
    Graphics Card(s)
    inter express chipset
    Sound Card
    Realtek
    Monitor(s) Displays
    Wipro
    Screen Resolution
    1024*768
    Hard Drives
    500 gb
    Mouse
    Dell
    Keyboard
    DELL
    Internet Speed
    100 mbps(office lan)
Posts
15
#15
hi,

Thats why i always hate reg cleaners....

Try this registry entry View attachment 14358


Let me know the result :)

Tried this now have error 80070424
This error is related to bits service..

Let us recconfigure bits service, To do that follow my steps,

1. Click Start, click Run, type services.msc, and then click OK.
2. Double-click Background Intelligent Transfer Service.
3. In the Startup type box, click Automatic(delayed start), and then click Apply.
4. Click the Log On tab, and then verify that the service is enabled in every hardware profile that
is listed. If the service is disabled in one or more hardware profiles, click the hardware profile,
click Enable, and then click Apply.
5. Click the General tab, and then click Start.

If that's all okay, then perhaps

1. Click Start.
2. Choose Run.
3. In the Run box, type (pressing okay after the command) Regsvr32 QMGR.DLL

Otherwise reinstall Bits. Its available here

Let me know the result :)
Running vista the download was for xp. I am getting an error continually from windows modules installer error 126 module not found but the truestedinstaller.exe is in the servicing folder along with a number of dlls..
 

My Computer

delphin

Eager to learn
Vista Pro
Chennai

Posts
636
#16
Tried this now have error 80070424
This error is related to bits service..

Let us recconfigure bits service, To do that follow my steps,

1. Click Start, click Run, type services.msc, and then click OK.
2. Double-click Background Intelligent Transfer Service.
3. In the Startup type box, click Automatic(delayed start), and then click Apply.
4. Click the Log On tab, and then verify that the service is enabled in every hardware profile that
is listed. If the service is disabled in one or more hardware profiles, click the hardware profile,
click Enable, and then click Apply.
5. Click the General tab, and then click Start.

If that's all okay, then perhaps

1. Click Start.
2. Choose Run.
3. In the Run box, type (pressing okay after the command) Regsvr32 QMGR.DLL

Otherwise reinstall Bits. Its available here

Let me know the result :)
Running vista the download was for xp. I am getting an error continually from windows modules installer error 126 module not found but the truestedinstaller.exe is in the servicing folder along with a number of dlls..
Error 126 is usually displayed at run time when some of the DLLs on your system are missing. The message with the error code 126 may also be displayed when an application is trying to connect to a database and a required DLL is not specified in your machine’s PATH

Found on other forum..

Will u pls post the name of the dll files inside your servicing folder...

We can check with other computer :)
 

My Computer

System One

  • Manufacturer/Model
    Wipro
    Motherboard
    Intel dq35j0
    Memory
    8 Gb
    Graphics Card(s)
    inter express chipset
    Sound Card
    Realtek
    Monitor(s) Displays
    Wipro
    Screen Resolution
    1024*768
    Hard Drives
    500 gb
    Mouse
    Dell
    Keyboard
    DELL
    Internet Speed
    100 mbps(office lan)
Posts
2,049
#17
Running vista the download was for xp. I am getting an error continually from windows modules installer error 126 module not found but the truestedinstaller.exe is in the servicing folder along with a number of dlls..
Run>>search>>Services.msc

and check you have service Windows Modules Installer and is set to MANUAL
Windows Vista Service Pack 2 Services Information - Windows Modules Installer

Have you tried also my post 9?
http://www.vistax64.com/1093990-post9.html
 

My Computer

Posts
15
#18
This error is related to bits service..

Let us recconfigure bits service, To do that follow my steps,

1. Click Start, click Run, type services.msc, and then click OK.
2. Double-click Background Intelligent Transfer Service.
3. In the Startup type box, click Automatic(delayed start), and then click Apply.
4. Click the Log On tab, and then verify that the service is enabled in every hardware profile that
is listed. If the service is disabled in one or more hardware profiles, click the hardware profile,
click Enable, and then click Apply.
5. Click the General tab, and then click Start.

If that's all okay, then perhaps

1. Click Start.
2. Choose Run.
3. In the Run box, type (pressing okay after the command) Regsvr32 QMGR.DLL

Otherwise reinstall Bits. Its available here

Let me know the result :)
Running vista the download was for xp. I am getting an error continually from windows modules installer error 126 module not found but the truestedinstaller.exe is in the servicing folder along with a number of dlls..
Error 126 is usually displayed at run time when some of the DLLs on your system are missing. The message with the error code 126 may also be displayed when an application is trying to connect to a database and a required DLL is not specified in your machine’s PATH

Found on other forum..

Will u pls post the name of the dll files inside your servicing folder...

We can check with other computer :)
DLL's and exe in servicing
CbsApi.dll
CbsMsg.dll
TrustedInstaller.exe
vsp1ceip.exe
wrpintapi.dll

folders
en-US
GC32
Packages
Packages
 

My Computer

Posts
2,049
#19
You should also have folder Version.Do you have this folder?

EDIT

I have Vista x64 PL and there are bit different than in EN version,and you have x32
but folder Version you should have
 

Attachments

My Computer