can't get Group Policy to update for user

Cliffmarcum

New Member
Ok not sure where to post this but im sure i will be told if its in the wrong place.

i have around 15 out of 36 vista biz 32bit computers that will not update group policy's for the user that works on that computer. i have done gpupdate with /force and /sync and everything else that you can add to it. but still nothing happens.

but if i log the user's account into another computer everything is updated like it should be. but when i log them back into their own computer it goes back to the old policy. I have tried everything I konw to fix this hope you guys can help.

a litte more info for you guys is the problem computers are still looking for an old server to redirect files to. even tho the new policy has it pointing to the new server. we have even removed the redirect to see if that would help but it doesn't they still look for the old server and lock up every few mins looking for those files.
 

My Computer

Lorien

Account Suspended
Hi Cliffmarcum,

Welcome to Vista Forums!

I'm not certain how you are deploying the GPO's, but the following article may help with procedures, guidelines, hints, troubleshooting tips, and so forth: Deploying Group Policy Using Windows Vista.

On a computer that isn't working, go to Start / All Programs / Accessories / right click on Command prompt and click on Run as Administrator. Type gpresult /v and enter. This should provide a great deal of information about how GP is affecting that machine (and possibly why it is not affecting that machine). Now login as that user on a computer that is working and do exactly the same thing. Compare the two results. I'd be willing to bet SOMETHING is different that's causing the problem.

The Event Viewer has a wealth of information regarding Group Policy. Unfortunately, it requires you to look at all of the different log files to find entries for Group Policy. There you'll find entries related to policy application, policy replication, and policy refresh, all of which can be useful when trying to track down a problem. There is not always a lot of information on specific Group Policy errors in the event logs, but remember that you can always search TechNet if you find errors you can't identify (or post them here and we'll see if we can help). The following article may help here: Troubleshooting Group Policy Using Event Logs.

(From: http://technet.microsoft.com/en-us/magazine/2007.02.troubleshooting.aspx - which may contain additional helpful information.) Target Object Must Be in the Path of the GPO When you notice that a GPO setting is not affecting an object as it should, there is one more important setting-the object must be in the Scope of Management (SOM) of the GPO. This means that the object must be located under the node where the GPO is linked (even a child node will be sufficient). For example, none of the objects in the Marketing OU will be affected by a GPO that is linked to the Finance OU, as shown in Figure 3. The SOM of a GPO is from the node where it is linked, down through the Active Directory structure.
Figure 3 When OUs Are at the Same Level, GPOs Only Apply to the OU Where It Is Linked. I mention this because if these computers are looking to a different server instead of the new server (perhaps a different OU), they may not be able to receive the GPO.

I don't know why disabling re-direction doesn't help except perhaps it is only disabling the redirection process and not whatever is causing the computer to want to redirect or even perceive the old server. I feel certain that this is the root cause of the problem - but can't explain why it only applies to half of the computers as one would expect this to apply to all or none - and yet, if it is a difference between those that work and those that don't, it's pretty clearly the culprit.

Not knowing your setup, it's hard to suggest alternatives; however, if possible and reasonable (e.g., you use imaged machines and no user data is stored on them and everything is handled through the network including the logon and so forth), I would consider re-imaging those 15 machines to get rid of whatever is causing them to see the old server (make them like the computers that are working) and then apply the GPO and everything else should work fine on them like it does on the other computers. But your setup could be more complicated than that, so it's hard to see how much effort this would take - but I'd be willing to bet that this would solve the problem.

I hope this helps.

Good luck!
 
Last edited:

My Computer

System One

  • Manufacturer/Model
    Dell Inc. MP061 Inspiron E1705
    CPU
    2.00 gigahertz Intel Core 2 Duo 64 kilobyte primary memory
    Motherboard
    Board: Dell Inc. 0YD479 Bus Clock: 166 megahertz
    Memory
    2046 Megabytes Usable Installed Memory
    Graphics Card(s)
    ATI Mobility Radeon X1400 (Microsoft Corporation - WDDM) [Di
    Sound Card
    SigmaTel High Definition Audio CODEC
    Monitor(s) Displays
    Generic PnP Monitor (17.2"vis)
    Screen Resolution
    1920 x 1200 pixels
    Hard Drives
    Hitachi HTS541616J9SA00 [Hard drive] (160.04 GB) -- drive 0, s/n SB2411SJGLLRMB, rev SB4OC74P, SMART Status: Healthy
    Case
    Chassis Serial Number: 5YK95C1
    Mouse
    Logitech HID-compliant Cordless Mouse
    Keyboard
    Standard PS/2 Keyboard
    Internet Speed
    1958 Kbps download ; 754.8 Kbps upload
    Other Info
    Optiarc DVD+-RW AD-5540A ATA Device [CD-ROM drive]

    Dell AIO Printer A940

    Conexant HDA D110 MDC V.92 Modem

    6TO4 Adapter
    Broadcom 440x 10/100 Integrated Controller
    Broadcom 802.11n Network Adapter
    Microsoft ISATAP Adapter
    Teredo Tunneling Pseudo-Interface

    Router Linksys / WRT54G -01

Cliffmarcum

New Member
ok read over the stuff you sent all good stuff but so far i have done alot of that and nothing has work did the report on the trouble computer/user account and it says
Folder RedirectionPending2/17/2011 1:33:30 PM Folder Redirection did not complete policy processing because the user needs to log on again for the settings to be applied. Group Policy will attempt to apply the settings at the user's next logon.
so I log them off and back on and nothing changes and that message is still in the report when i run it again. so yeah anyway to tell it to shut up and do what i say lol.
 

My Computer

Cliffmarcum

New Member
Ok fixed this problem just in case anyone else ever has it here was the fix I cam up with.

1st I have no idea why half the computers did this but the easy fix was to log in to the users computer as the domain admin. go to the users folder and remove the users folder that is having the trouble. then go into Regedit and remove that user from the profilelist and restart the computer and log in as the user and there you go new GP's downloaded from the server and everything is fine. just make sure to back up all user files and anything else they want cause it will all be deleted when you do this. thanks for the help.
 

My Computer

Top