• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't get Vista SP1 to install

#1
Here's my situation. I bought a custom gaming PC about a year ago and it came with Vista Home Premium 32bit. Since SP1 was released, I've tried several times to install it both through Windows Update and manually but it always fails. I looked at the information in the Knowledgebase article about the error message I was getting and it suggested running a system scan utility through the command line interface which I did. The utility said that it fixed some files but I had corrupted files that it was not able to repair.

I went out and bought an upgrade version of Vista Home Premium that contained SP1 thinking I could just upgrade it as a workaround. No dice, the upgrade option is disabled unless you already have SP1 installed. It will only let me do a clean install. This brings me to my first question. If I do the clean install, it's going to format my HD right? I'll have to reinstall all my software?

My second question is, does anybody know how I can get SP1 to install on my current installation? Any way to find and repair those supposedly corrupt files?

Thanks in advance
 
#2
I've been battling with this all night and the better part of this morning. I think my best bet is just to do a clean install of the OS.

Can you guys please let me know what I should backup? I won't lose my software but the registry entries will be gone correct? So I'll have to reinstall that stuff anyway?
 
#3
I've been battling with this all night and the better part of this morning. I think my best bet is just to do a clean install of the OS.

Can you guys please let me know what I should backup? I won't lose my software but the registry entries will be gone correct? So I'll have to reinstall that stuff anyway?
Hello Peter,
I don't know how much it will help you, as I don't have SP1. Here is a link showing you several resoluions.Good luck.

Error message when you try to install Windows Vista Service Pack 1: "Installation was not successful" or "An internal error occurred while installing the service pack"
 
#4
I already tried all that but thanks for trying.

All I really want to know now is what I'm going to lose if I do a clean Vista install and what I need to backup. I haven't had to do a clean install of an OS to fix a problem since I was running Windows 98.

I seem to recall that, back then, it would not format the HD and delete everything but your stuff like My Documents and what not would be erased. All the software you installed would still be there but all the registry entries go poof so it needs to be reinstalled.

That's what I'm wondering about now. If anybody can confirm or deny those things, I'll get started on doing this reinstall.
 
#5
I already tried all that but thanks for trying.

All I really want to know now is what I'm going to lose if I do a clean Vista install and what I need to backup. I haven't had to do a clean install of an OS to fix a problem since I was running Windows 98.

I seem to recall that, back then, it would not format the HD and delete everything but your stuff like My Documents and what not would be erased. All the software you installed would still be there but all the registry entries go poof so it needs to be reinstalled.

That's what I'm wondering about now. If anybody can confirm or deny those things, I'll get started on doing this reinstall.
Hello Peter,
If I were you, I would save files/folders that I wanted to keep on cds before reinstalling. I have never done a clean installing, but I do know you need to re-install all your drivers. You should have a DRIVERS & UTILITIES disk that came with the computer. (Mine did.) That's just about all I know. Good luck.
 

sidney1st

Member
Vista Guru
#10
So, open Windows Update, in the left pane, click View update history and check the updates that have failed to install.
If any updates failed, please give the error details.
On of the reason of this error is that one of the prerequisite update pre-SP1 failed to install.
 
#11
Other than SP1 and some driver updates for the raid controller (since updated without Windows Update) there is only one windows update that failed to install. However, that update installed successfully a few days later.
 
#12
Can't get Vista SP1 to install- error cbs.log?

i found some errors in the CBS.log that may prevent me from installing SP1

i would like some to review because i really do not see why these errors would impact

the install:

HERE IT GOES

2008-04-30 22:00:18, Info CSI 00000dfb Performing 1 operations; 1 are not lock/unlock and follow:
LockComponentPath (10): flags: 0 comp: {l:16 b:d8c91a1b2fabc801c50c000028018004} pathid: {l:16 b:d8c91a1b2fabc801c60c000028018004} path: [l:220{110}]"\SystemRoot\WinSxS\amd64_microsoft-windows-wmi-cmiplugin_31bf3856ad364e35_6.0.6001.18000_none_1921286ae4653dec" pid: 128 starttime: 128540805617428054 (0x01c8ab2e81f82656)
2008-04-30 22:00:18, Error CSI 00000b5d (F) Logged @2008/5/1:02:00:18.661 : [ml:54{27},l:52{26}]"JobsHandler::Install enter"
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b5e (F) Logged @2008/5/1:02:00:18.661 : [ml:46{23},l:44{22}]"ProcessOnlineJob enter"
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b5f (F) Logged @2008/5/1:02:00:18.661 : [ml:142{71},l:140{70}]"WmiCmiPlugin jobshandler.cpp(148): RegisterTask failed. HR=0x800706b5."
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b60 (F) Logged @2008/5/1:02:00:18.661 : [ml:116{58},l:114{57}]"WmiCmiPlugin plgutil.cpp(215): fnc failed. HR=0x800706b5."
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b61 (F) Logged @2008/5/1:02:00:18.661 : [ml:150{75},l:148{74}]"WmiCmiPlugin jobshandler.cpp(259): ForEachElementIn failed. HR=0x800706b5."
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b62 (F) Logged @2008/5/1:02:00:18.661 : [ml:148{74},l:146{73}]"JobsHandler::Install: retry service unavailable error 0x800706b5 (1 time)"
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b63 (F) Logged @2008/5/1:02:00:18.661 : [ml:46{23},l:44{22}]"ProcessOnlineJob enter"
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b64 (F) Logged @2008/5/1:02:00:18.661 : [ml:142{71},l:140{70}]"WmiCmiPlugin jobshandler.cpp(148): RegisterTask failed. HR=0x800706b5."
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b65 (F) Logged @2008/5/1:02:00:18.661 : [ml:116{58},l:114{57}]"WmiCmiPlugin plgutil.cpp(215): fnc failed. HR=0x800706b5."
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b66 (F) Logged @2008/5/1:02:00:18.661 : [ml:150{75},l:148{74}]"WmiCmiPlugin jobshandler.cpp(259): ForEachElementIn failed. HR=0x800706b5."
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b67 (F) Logged @2008/5/1:02:00:18.661 : [ml:148{74},l:146{73}]"JobsHandler::Install: retry service unavailable error 0x800706b5 (2 time)"
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000b68 (F) Logged @2008/5/1:02:00:18.661 : [ml:46{23},l:44{22}]"ProcessOnlineJob enter"


008-04-30 22:00:18, Error CSI 00000b6e@2008/5/1:02:00:18.676 (F) CMIADAPTER: AI failed. HRESULT = HRESULT_FROM_WIN32(1717)
Element:
[2285]"<taskScheduler xmlns="urn:schemas-microsoft-com:asm.v3">
<Task xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task" version="1.2">
<RegistrationInfo>
<URI>\Microsoft\Windows\NetworkAccessProtection\NAPStatus UI</URI>
<SecurityDescriptor>D:P(A;;FA;;;BA)(A;;FA;;;SY)(A;;FR;;;BU)</SecurityDescriptor>
<Author>$(@%SystemRoot%\system32\qagentrt.dll,-8)</Author>
<Description>$(@%SystemRoot%\system32\qagentrt.dll,-9)</Description>
</RegistrationInfo>
<Triggers>
<LogonTrigger>
<Enabled>true</Enabled>
<Delay>PT00M05S</Delay>
</LogonTrigger>
<EventTrigger>
<Enabled>true</Enabled>
<Subscription>
&lt;QueryList&gt;
&lt;Query Id="1"&gt;
&lt;!-- restricted --&gt;
&lt;Select Path="Microsoft-Windows-NetworkAccessProtection/Operational"&gt;
*[System/EventID='18' and System/Provider[@Name='Microsoft-Windows-NetworkAccessProtection'] and UserData/*/CurrentIsolationStateNumeric='3']
&lt;/Select&gt;
&lt;!-- probation --&gt;
&lt;Select Path="Microsoft-Windows-NetworkAccessProtection/Operational"&gt;
*[System/EventID='18' and System/Provider[@Name='Microsoft-Windows-NetworkAccessProtection'] and UserData/*/CurrentIsolationStateNumeric='2']
&lt;/Select&gt;
&lt;/Query&gt;
&lt;/QueryList&gt;
</Subscription>
</EventTrigger>
</Triggers>
<Principals>
<Principal id="AnyUser">
<GroupId>S-1-5-32-545</GroupId>
</Principal>
</Principals>
<Actions Context="AnyUser">
<ComHandler>
<ClassId>{f09878a1-4652-4292-aa63-8c7d4fd7648f}</Cla[gle=0x80004005]
2008-04-30 22:00:18, Error CSI ssId>
<Data>/b</Data>
</ComHandler>
</Actions>
<Settings>
<MultipleInstancesPolicy>Parallel</MultipleInstancesPolicy>
<ExecutionTimeLimit>PT00H00M03S</ExecutionTimeLimit>
<DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
<StopIfGoingOnBatteries>false</StopIfGoingOnBatteries>
</Settings>
</Task>
</taskScheduler>"
[gle=0x80004005]
2008-04-30 22:00:18, Error CSI 00000dfc@2008/5/1:02:00:18.676 (F) d:\rtm\base\wcp\cmiadapter\installers.cpp(356): Error HRESULT_FROM_WIN32(1717) originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::ResolveAndInvokeInstaller expression: hr
[gle=0x80004005]
2008-04-30 22:00:44, Error CSI 00000b6f@2008/5/1:02:00:44.526 (F) CMIADAPTER: Exiting with HRESULT code = HRESULT_FROM_WIN32(1717).
[gle=0x80004005]
2008-04-30 22:00:44, Error CSI 00000dfd@2008/5/1:02:00:44.526 (F) d:\rtm\base\wcp\cmiadapter\installers.cpp(123): Error HRESULT_FROM_WIN32(1717) originated in function Windows::WCP::CmiAdapter::CMIWrapperBasicInstaller::Install expression: hr
[gle=0x80004005]
2008-04-30 22:01:05, Info CSI 00000dfe@2008/5/1:02:01:05.866 CSI Advanced installer perf trace:
CSIPERF:AIDONE;{386b5911-b69e-4d2d-a3ab-796d2ec6af38};Microsoft-Windows-NetworkAccessProtection-Agent, Version = 6.0.6001.18000, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral;48373337
2008-04-30 22:01:05, Error CSI 00000dff (F) Failed execution of queue item Installer: Task Scheduler ({386b5911-b69e-4d2d-a3ab-796d2ec6af38}) with HRESULT HRESULT_FROM_WIN32(1717). Failure will not be ignored: A rollback will be initiated after all the operations in the installer queue are completed; installer is reliable (2)[gle=0x80004005]
2008-04-30 22:01:05, Info CSI 00000e00 End executing advanced installer (sequence 1974)
Completion status: HRESULT_FROM_WIN32(ERROR_ADVANCED_INSTALLER_FAILED)
2008-04-30 22:01:05, Info CSI 00000e01 Begin executing advanced installer phase 32 (0x00000020) index 1942 (0x0000000000000796) (sequence 1975)
Old component: Microsoft-Windows-Disk-Failure-Diagnostic-Module, Version = 6.0.6000.16386, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral
New component: Microsoft-Windows-Disk-Failure-Diagnostic-Module, Version = 6.0.6001.18000, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral
Install mode: install
Installer ID: {386b5911-b69e-4d2d-a3ab-796d2ec6af38}
Installer name: [14]"Task Scheduler"
2008-04-30 22:01:05, Info CSI 00000e02 Performing 1 operations; 1 are not lock/unlock and follow:
LockComponentPath (10): flags: 0 comp: {l:16 b:f82b40372fabc801c70c000028018004} pathid: {l:16 b:f82b40372fabc801c80c000028018004} path: [l:220{110}]"\SystemRoot\WinSxS\amd64_microsoft-windows-wmi-cmiplugin_31bf3856ad364e35_6.0.6001.18000_none_1921286ae4653dec" pid: 128 starttime: 128540805617428054 (0x01c8ab2e81f82656)
2008-04-30 22:01:07, Info CSI 00000e03@2008/5/1:02:01:07.286 CSI Advanced installer perf trace:
CSIPERF:AIDONE;{386b5911-b69e-4d2d-a3ab-796d2ec6af38};Microsoft-Windows-Disk-Failure-Diagnostic-Module, Version = 6.0.6001.18000, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral;1455941
2008-04-30 22:01:07, Info CSI 00000e04 End executing advanced installer (sequence 1975)
Completion status: S_OK
2008-04-30 22:01:07, Info CSI 00000e05 Begin executing advanced installer phase 32 (0x00000020) index 1944 (0x0000000000000798) (sequence 1977)
Old component: Microsoft-Windows-Security-Licensing-WMI, Version = 6.0.6000.16509, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral
New component: Microsoft-Windows-Security-Licensing-WMI, Version = 6.0.6001.18000, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral
Install mode: install
Installer ID: {9f4ec79f-3a97-4772-b635-2899468900a2}
Installer name: [3]"Mof"
2008-04-30 22:01:07, Info CSI 00000e06 Performing 1 operations; 1 are not lock/unlock and follow:
LockComponentPath (10): flags: 0 comp: {l:16 b:18c918382fabc801c90c000028018004} pathid: {l:16 b:18c918382fabc801ca0c000028018004} path: [l:226{113}]"\SystemRoot\WinSxS\amd64_microsoft-windows-wmi-mofinstaller_31bf3856ad364e35_6.0.6001.18000_none_6e3bfabfe41e1e82" pid: 128 starttime: 128540805617428054 (0x01c8ab2e81f82656)
2008-04-30 22:01:07, Info CSI 00000e07@2008/5/1:02:01:07.832 CSI Advanced installer perf



POQ 98 ends.
2008-05-10 19:13:13, Info CSI 00000273 [SR] Verify complete
2008-05-10 19:13:13, Info CSI 00000274 [SR] Repairing 0 components
2008-05-10 19:13:13, Info CSI 00000275 [SR] Beginning Verify and Repair transaction
2008-05-10 19:13:13, Info CSI 00000276 Repair results created:
POQ 99 starts:

POQ 99 ends.
2008-05-10 19:13:13, Info CSI 00000277 [SR] Repair complete


THANKS IN ADVANCE!!!!