• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't install printer - Add printer error

#1
I have Vista 32bit and the system recently "lost" its printer.

I have checked the HW and the printer and cable work fine on another system. The strange thing is when I go control panel > printers the pane is blank - not even the XPS writer is there.

When I press add printer I get error "Windos cant open Add Printer. The local print spooler service is not running. Please restart the spooler or restart the machine.

Checking under services the spooler appears to be there and running.

I have tried to use the Brother driver removal utility but it ends with a failure. I have tried reinstalling driver and I get the pop up from the taskbar saying driver installed and device ready to use but it just does not work!
 

koolkat77

SF Flag waver
Member
#2
Play with the spooler settings again.
Go to start
Type services in the search box
Scroll down to alphabet P = Print Spooler
Right click and Start the service

Now the printer should appear in the Device and Printers box.
Test by printing to confirm, and if it still does not, stop the spooler service and start it again.

Let us know how it goes.
 

koolkat77

SF Flag waver
Member
#6
Have you pushed the Start button on print spooler settings? Check the attachment to see what I mean. The service may be running - automatically there but you will need to check if actually is after adding printers. Otherwise I don't see any reason for your printer not working.
 
#7
Thanks for your continued interest. Yes I have "started" the service and stopped/started it as well without any success. The printers in control panel remains blank even though the driver appears to load OK...
 

koolkat77

SF Flag waver
Member
#8
Okay.
Could you got to services again start Bluetooth Support Services.

I'm not very sure it will help. But try it and post back and I'll come back with more suggestions.
 
#10
thanks for the posts. The PC does not have BT functionality at all. I have tried other USB ports, I cant use a different user - I am logged in as ADMIN and I has to work under ADMIN. The HL2140 thread did not provide anything useful that I haven't already tried.
 
#13
Thanks Koolkat77 the topics covered in your link have either been tried or are not relevant.

Thanks Brink, I have already manually cleared the Print Spooler Queue as per option 2 of your link