• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Can't see other PC on wifi network (Vista Home)

We have 2 XP computers and 2 Vista Home. Everything was fine with our old Linksys router. I put in a new Linksys router (WRT160n) and now, the Vista laptops can't see the others computers and can't ping them. The XP machines still work - they can see the Vista machines and their printers. All can get to the Internet just fine. Linksys will not help because we can get to the internet through the router and they tell me that is all they are responsible for.

This is what I have done:
1. I made sure all PCs are in the same workgroup, the network is private, and I set up the same user names on each PC. (I did the latter as a troubleshooting step - but I've never had to do this before, and this machine used to see the others without it.)
2. Network Discovery, etc., all except password protected sharing is On.
3. Firewall: Made sure that the IP range was allowed, and when that didn't work, disabled the firewall. (Tried McAfee, then Windows - tried them both, one at a time, then none - i never had them both running at the same time). Also, set them up to allow ping requests and opened system services ports as recommended by Microsoft in the Vista File and Printer Sharing document.
4. Made sure that all of the sharing was set up properly on the other PCs and printers.
5. Changed the default WPA2 security on the Linksys router to WPA, then to WEP, then to no security.
6. Reset router.
7. AP Isolation is not checked on the router, unchecked Filter Anonymous Internet Requests and associated setting.

I know that I've probably forgotten something...it seems like I have done more than this. I've been searching for solutions and I tried everything I could find that I hadn't already done.

Thanks in advance.

6/9/09 - The other Vista machine has the following problem: In the NSC, our home wireless network is almost always in this state - Identifying (Public). When you try to view the map, it says the network has to be Private in order to view. I've gone through and set it to Private, a couple of times. After I set it to Private again, it holds for about 5 seconds. Then it spins back into its Identifying (Public). And while its doing this, the Network Discovery goes back to being unchosen (because it thinks it's a public network, of course).

So, this is the problem now - and I still can't find anything on the Internet. I've seen a few other problems where people have this same thing after restarting. No one has given them answers, either. But I haven't seen any where it holds for 5 seconds, then resets.

I did see a posting where it was suggested that they set up a static IP address. But then he will have the same problem I have, in that every time the router crashes or I restart, my static IP settings are gone. I haven't found a resolution for that yet, either.

Please help?

Oh, and this all started after getting the stupid new router. What a pain this is, and Linksys has not been helpful. My move was from a WRT54GS to WRT160N. I would not recommend this.

6/10/09: Okay, when he started his laptop today, there he was, on the map and the private network finally stuck. We added the printer and all is well.

However, we still have the situation of the XP machine. We can see it on the network map but can't access it. I may start a new thread just about this problem, since it has evolved as I've figured things out and no one has responded to help me. See y'all later. Kiss kiss.

6/11/09: Me again. It's fixed. It's not enough to enable the range in the firewall, you have to use McAfee's EasyNetwork to share files and printers. There's a time-consuming setup and approval process and you have to use the EasyNetwork for everything. But at least we are all set now.

Thanks to all of you who at least read my post even if you didn't have an idea of something for me to try.
Last edited:

My Computer