COD4 64bit

Pinsonxc

New Member
Is there a COD4 game made for a 64bit, or does the 32bit work well with a 64bit? I am new to PC gaming and was not sure if the two would work well together.
 

My Computer

System One

  • CPU
    Gateway 6860FX
    Memory
    4GB
    Graphics Card(s)
    NVIDIA GeForce Go 8800M GTS

ripbox

Nerd
Vista Pro
cod4 work as normal so get playing :D
 

My Computer

System One

  • Manufacturer/Model
    Me :P
    CPU
    Core 2 Quad Q6600
    Motherboard
    Abit IN9 32X MAX
    Memory
    8 GB OCZ PC2-6400 nVIDIA SLI-Ready Edition (4X2GB)
    Graphics Card(s)
    AMP! GeForce GTX 260² 896MB 448-bit GDDR3 (650MHz/2100MHz
    Sound Card
    Realtek 7.1 CH HD Audio
    Monitor(s) Displays
    17" Fujitsu siemens TFT + 32" LG HD LCD TV
    Screen Resolution
    1280x1024 + 1360x768
    Hard Drives
    150GB Raptor HDD
    500GB Caviar HDD
    PSU
    Thermaltake W0133RB 1200W PSU
    Case
    Antec 900
    Cooling
    Stock + Antec 900 case fans
    Mouse
    Logitech MX Revolution
    Keyboard
    Logitech G15 (full layout)

Pinsonxc

New Member
Overall I am very happy with the operating of the game, I was wondering if you had any advice on how to cut down on the lag that happens during multiplayer, it is pretty bad!
 

My Computer

System One

  • CPU
    Gateway 6860FX
    Memory
    4GB
    Graphics Card(s)
    NVIDIA GeForce Go 8800M GTS

Axon

Beacon of Happiness
Vista Pro
I don't have any lag in multiplayer, maybe it's your Internet.

Do you share the network? (maybe someone else is downloading stuff)
 

My Computer

System One

  • CPU
    Intel Core 2 Duo E8400
    Motherboard
    ASUS P5B-E Plus
    Memory
    4GB Kingston ValueRAM DDR2-667
    Graphics Card(s)
    ASUS EN8800GT 512
    Sound Card
    Creative X-Fi XtremeGamer
    Monitor(s) Displays
    Packard Bell Maestro 190W
    Screen Resolution
    1440x900 @ 75Hz
    Hard Drives
    WesternDigital 200GB 7200RPM + Iomega Desktop HD 360GB 7200RPM
    PSU
    Xilence Power 600W Gaming Edition
    Case
    Coolermaster Centurion 534 Black
    Cooling
    Standard Coolermaster Case Fans + Standard Intel CPU Fan.
    Mouse
    Razer Copperhead Tempest Blue
    Keyboard
    Logitech G15 V1
    Internet Speed
    100.0 Mbps

ripbox

Nerd
Vista Pro
toning down the graphics settings can help
you must remember that in multi player mode that there tends to be a lot more happening at once thus putting more strain on you cpu and g-card
however this is not always the case
like Axon said this can be caused via a shared network and can also be caused the host too
try joining a small group of ppl on a sever i.e 10VS10 rather than a 50VS50
 

My Computer

System One

  • Manufacturer/Model
    Me :P
    CPU
    Core 2 Quad Q6600
    Motherboard
    Abit IN9 32X MAX
    Memory
    8 GB OCZ PC2-6400 nVIDIA SLI-Ready Edition (4X2GB)
    Graphics Card(s)
    AMP! GeForce GTX 260² 896MB 448-bit GDDR3 (650MHz/2100MHz
    Sound Card
    Realtek 7.1 CH HD Audio
    Monitor(s) Displays
    17" Fujitsu siemens TFT + 32" LG HD LCD TV
    Screen Resolution
    1280x1024 + 1360x768
    Hard Drives
    150GB Raptor HDD
    500GB Caviar HDD
    PSU
    Thermaltake W0133RB 1200W PSU
    Case
    Antec 900
    Cooling
    Stock + Antec 900 case fans
    Mouse
    Logitech MX Revolution
    Keyboard
    Logitech G15 (full layout)

TheNerd

New Member
I find that adjusting the "cl_maxpackets" setting works best for me. Try to make the number as high as possible without lag. Generally, a value of "30" is as low as I need to go...
 

My Computer

deckstein

New Member
Along the same lines - just bought a HP-2700 Laptop with a Intel-Duo Core T5550 64-bit processor, running Windows Vista-Home Premium. I installed COD4 on the machine with no problem. Application runs fine until I actually go into a game (either single or multiplayer). Once inside a game, the display and response slows to a crawl. I realize this notebook is not the optimum solution, but I should be able to run the game at lower graphic settings with reasonable response. At the current levels, it is unplayable and very frustrating.

I'm an old hand at COD4, but new to 64-bit OS and Vista. In fact, not even sure if my Vista is 32-bit or 64-bit version. :o It was OEM install. If anyone can provide some useful info or links to resolve this, I'd be very grateful. I'm fixing to go on the road and would really want to take COD4 with me. Thanks in advance "pistol_pete"
 
Last edited:

My Computer

System One

  • CPU
    Intel-T5550 @ 1.83ghz

radiored

New Member
Along the same lines - just bought a HP-2700 Laptop with a Intel-Duo Core T5550 64-bit processor, running Windows Vista-Home Premium. I installed COD4 on the machine with no problem. Application runs fine until I actually go into a game (either single or multiplayer). Once inside a game, the display and response slows to a crawl. I realize this notebook is not the optimum solution, but I should be able to run the game at lower graphic settings with reasonable response. At the current levels, it is unplayable and very frustrating.

I'm an old hand at COD4, but new to 64-bit OS and Vista. In fact, not even sure if my Vista is 32-bit or 64-bit version. :o It was OEM install. If anyone can provide some useful info or links to resolve this, I'd be very grateful. I'm fixing to go on the road and would really want to take COD4 with me. Thanks in advance "pistol_pete"

Have a look @ your Control Panel\System and Maintenance\System options & it will tell you which OS you have , 32b or 64b.

Have a look at the top of the menu of this forum for the "Latest DirectX Update" link. It may help with your CoD playing speed. Also make sure all your drivers are up to date especially re the video. Make sure you have any patches for CoD that may have a connection to slow game play. Also max out the supported amount of ram your notebook supports. If you do have Vista64 you will be able to install & put to use more ram as a 32bit OS won't use much over 3gigs no matter how much ram is installed.
 

My Computer

Crusty

Junior Member
Member
Just to throw a bit more info into this thread, let me relay my COD4 experiences after upgrading from 32 bit with two gigs of DDR3 to 64 bit with 4 Gigs of DDR3.

I finally got my machine up and running yesterday after the long and horrible process of upgrading (?) the OS. Well, for some reason COD4 seems to have run better with the 32 bit and 2 gig of ram than with the 64 bit and 4 gigs. The problem: lag issues.

When I had the game running on the 32 bit system I had everything set to max (Nvidia 8800 XFX / 756) and the game ran as smooth as butter. However, when playing yesterday the game crashed after a few minutes of play. I then checked to make sure I had the latest 64 bit drivers from Nvidia, loaded them up, and managed to get on line to play. The game lagged, but not enough to make it unplayable. However, I did not invest thousands of pounds in a gaming rig to not play everything on top settings.

Well, because it was Sunday evening and I am a BT customer, there could have been a network problem as they are notorious for borrowing my bandwidth and redistrinbuting it to the masses. However, when I went to boot up this morning for a quick check, my machine crashed and failed upon load up, so who knows what the hell? I didn't have time to fiddle with it as I was running late for work, but I'll let you know how I get on. :geek:
 

My Computer

System One

  • CPU
    Intel CPU Core 2 Quad Pro Q660
    Motherboard
    Asus motherboard P5E3 LGA775 I
    Memory
    OCZ 2GB Kit (2x1024) Gold Edition Memory DDR3 1066MHz PC3-8500 CL 7-7-7-21 Dual Channel Gold Layered
    Graphics Card(s)
    GeForce 8800 GTX 768MB
    Hard Drives
    3 x Western Digital 500GB Caviar SE16 SATA II 300 7200rpm 16MB cache Hard Disk Drive

deckstein

New Member
Thanks for the input RADIORED. Here are few more tidbits of info to consider if you feel up to it:

You're right, the machine and Vista are both 64-bit. I running DX version 10 - no problems encountered. Assume 10 works as well as 9 with COD4 - correct?? I ran a web utility called "Can You Run It?" to see if machine met COD4 requirements. Everything passed except video. Only problem is - in the details of the report (see below) EVERYTHING passed so I have no idea why the summary line says it failed. Go figure.

Lastly - the main app loads very fast. All videos and demos run great.at high or low resolution. Both Single and Multiplayer apps load fast and even game play loads like lightning. I have 6mb of bandwidth running smooth and usually get multiplayer pings in the 30s or 40s. (Don't know how to determine FPS). So. . .everything runs like greased lightning until I get into actual game play - then mouse response goes in the toilet and movement is filled with lag and ridiculously slow response. So. . . .any new suggestions besides "Take it back? would be great. Thanks again.


CAN YOU RUN IT REPORT.
You Have: Mobile Intel(R) 965 Express Chipset Family (Mobile Intel(R) 965 Express Chipset Family)

FAIL: Sorry, your video card does not meet this minimum requirement.
Video Card Features - Minimum attributes of your Video Card Video RAM:
Required - 128 MB , You have - 448 MB
Video Card 3D Acceleration: Required - Yes , You have - Yes
Video HW Transform & Lighting: Required - Yes , You have - Yes
Vertex Shader Ver.: Required - 2.0 , You have - 3.0
Pixel Shader Ver.: Required - 2.0 , You have - 3.0

SO WHAT THE HECK FAILED????
 

My Computer

System One

  • CPU
    Intel-T5550 @ 1.83ghz

voltsb333

New Member
@deckstein

if you want to see your current FPS ingame, bring down the console (press "`" key, below the ESC key) and type "/cg_drawfps 1" without the qoutes.

also try these settings in your graphics options

sync every frame = no
dual video cards = no
shadows = yes
specular map = no (this takes alot of GPU power)
depth of field = no
glow = no
number of dynamic lights = low
soften smoke edges = no
ragdoll = no
bullet impacts = no
model detail = normal
water detail = off

Texture settings:

texture filtering = auto
anisotrophic filtering = all the way left
texture quality = auto

these settings takes away a lot of eye candy, but you won't have time enjoying the eye candy when someone's out to frag you :D

HTH.
 
Last edited:

My Computer

System One

  • CPU
    Q6600
    Motherboard
    Asus Commando
    Memory
    4X1GB Corsair 6400C5DHX
    Graphics Card(s)
    8800GT
    Hard Drives
    2x80GB Seagate RAID-0
    1x250GB Seagate ES
    1X500GB Seagate ES
Top